NW4C SoundMaker

NintendoWare for CTR
NW4C SoundMaker
Version 1.3.0
2010-12-13

"Confidential"

This document contains confidential and proprietary information of Nintendo and is also protected under the copyright laws of the United States and foreign countries. No part of this document may be released, distributed, transmitted or reproduced in any form or by any electronic or mechanical means, including information storage and retrieval systems, without permission in writing from Nintendo.

[注意！]　このドキュメントの内容は、秘密情報であるため、厳重な取扱い、管理を行なってください。

Copyright ©2009-2010 Nintendo/HAL Laboratory, Inc. All Rights Reserved.

Microsoft Internet Explorer 5.0 以降推奨


更新履歴

（[*]）は該当するページへのリンクです。

Version 1.3.0　2010-12-13

    ※ 注意 ※

    ・NW4C SoundMaker を起動するには、Microsoft 社の .NET Framework 3.5 SP1 がインストールされている必要があります。

    ・本マニュアル内に Viewer についての記述がありますが、この機能は現在未実装です。

機能追加／変更点

  • (SoundMaker) パラメータパネルでのキー入力による再生機能を追加しました。 [*]

    • パラメータパネル上でスペースキーを押すことにより、対象のインストルメントを再生できる機能を追加しました。

  • (SoundMaker) 3D パラメータを追加しました。

    • 下記の 3D パラメータが設定できるようになりました。

      - 各サウンド (STRM / WSD / SEQ) リストの「3D Span」「3D Filter」
      - ウェーブサウンドリストの「S パン」

  • (ドキュメント) HioSoundPlayer 実行時の注意点を追記しました。 [*]

    • SoundMaker ユーザーズガイドの HioSoundPlayer ページに HioSoundPlayer を実行する際の以下の注意点を記載しました。

      - PARTNER-CTR HIO-Daemon が起動していない場合は起動してください。
      - NW4C_ROOT 環境変数を設定、あるいは変更した場合には HIO-Daemon、PARTNER-CTR デバッガ と SoundMaker の再起動が必要です。
      （NW4C の setup.wsf を実行した場合も含まれます。）

  • (ドキュメント) SoundPlayer のサウンドヒープサイズを明記しました。 [*]

    • SoundPlayer の説明として下記の説明を SoundMaker ユーザーズガイドに追記しました。

      - サウンドデータ用のヒープサイズ (＝nw::snd::SoundHeap::Create 関数に渡されるメモリサイズ) が、12MB であること
      - これより大きなサイズのデータが必要なサウンドは再生できないこと

不具合修正点

  • (全般) 「リンク」グループに登録した波形アーカイブの個別ロードに対応しました。

    • これまで、出力方式が「リンク」のグループに、個別ロードが ON の波形アーカイブを参照するようなサウンドやバンクを登録すると、個別ロードが ON であるにもかかわらず、当該波形アーカイブのすべての波形データがロードされていましたが、これを修正しました。

    たとえば、下記のような構成で GROUP_SE をロードすると、

      - SEQ_SE : BANK_SE : WARC_COMMON (個別ロード ON)
      - WSDSET_SE : WARC_COMMON (個別ロード ON)
      - GROUP_SE (リンク) : SEQ_SE (関連アイテム登録 ALL)

    これまでは、WARC_COMMON のうち WSDSET_SE に関連する波形までロードされていましたが、現バージョンから BANK_SE に関連する波形だけをロードするようになります。

    本機能を利用するには、サウンドアーカイブを再コンバートする必要があります。

  • (SoundMaker) インストのエンベロープ適用対象変更に関する不具合を修正しました。

    • インストのエンベロープ適用対象をインスト単位からリージョン単位にすると、サステインの値がリリースと同じ値になってしまう不具合を修正しました。

  • (SoundMaker) 「フロントバイパス」セルへの貼りつけ・やり直しに関する不具合を修正しました。

    • フロントバイパス以外のチェックボックスのセルに「セルのコピー」し、フロントバイパスのセルに「貼り付け」を２回以上行った後に「やり直し」を行うと SoundMaker が落ちる現象がありましたがこれを修正しました。

  • (SoundMaker) MIDI 入力の選択に関する不具合を修正しました。 [*]

    • [オプション] - [MIDI] にて、「MIDI キーボード入力」と「MIDI シーケンサー入力」で、同じデバイスを選択できる不具合がありましたが、「MIDI キーボード入力」で選択されているデバイスは、「MIDI シーケンサー入力」では選択できないようにしました。

  • (SoundMaker) シーケンスサウンドのバンクの「セルのコピー」「貼り付け」に関する不具合を修正しました。

    • シーケンスサウンドのバンク（一つだけ設定されているもの）に対して「セルのコピー」「貼り付け」をすると、コピーしたものが追加されてマルチバンクになってしまい、「元に戻す」で元に戻らない不具合がありましたが、これを修正しました。

  • (コンバータ) SMF の CC93 が fxsend_c に変換される不具合を修正しました。

    • SoundMaker で SMF ファイルをコンバートすると、CC (コントロールチェンジ) 93 が「fxsend_c」コマンドに変換されていましたが、変換せず、無視するようにしました。

  • (コンバータ) fxsend_c コマンドがエラーにならない不具合を修正しました。

    • テキストシーケンスに fxsend_c, fxsend_c_r, fxsend_c_v コマンドが書かれていても、コンバートエラーにならない不具合がありましたが、エラーになるように修正しました。

  • (ドキュメント) 独自に確保したボイスに対する操作についての説明を修正しました。

    • サウンドプログラマーズガイド「7.1.2 同期処理」の章において、独自に nn::snd::AllocVoice 関数で確保したボイスに対する説明が誤っていたので、これを修正しました。

    おもな修正点は下記のとおりです。

      - サウンドスレッドがシステムコアで動作している場合は、独自に確保したボイスに対する操作は SoundSystem::SetSoundFrameuserCallback 関数で設定したコールバックの中から行う必要がある
      - サウンドスレッドがアプリケーションコアで動作している場合は、独自に確保したボイスに対する操作はサウンドスレッドから行う必要がある。

  • (ドキュメント) 波形アーカイブの自動(共有, 個別)設定の説明を修正しました。 [*] [*]

    • SoundMaker ユーザーズガイドのウェーブサウンドセット、バンクの波形アーカイブの [自動(共有)] および [自動(個別)] 設定の解説において、誤解を生じる説明となっていた点を修正しました。

    具体的には、【共有します】と書かれていたため、波形レベルで共有されるように受け取られることもありましたが、【1つにまとめられます】という説明に変更しました。

  • (ドキュメント) 波形アーカイブとグループの関係に関する説明を修正しました。 [*]

    • ウェーブサウンドセットおよびバンクでの波形アーカイブの [自動(共有)]、[自動(個別)] 設定と、グループでの出力方式の関係について、SoundMaker ユーザーズガイドのグループ の節に挙動の説明を追記しました。

  • (ドキュメント) Windows 7 動作確認情報を改訂しました。

    • NintendoWare for CTR Windows 7 (64-bit) 動作確認情報ページ
    ($NW4C_ROOT\documents\ReleaseNotes\Windows7.html)
    において、サウンド開発環境の既知の問題としてあった以下の項目について、Windows 7 以外の環境でも問題が発生するため、NintendoWare for CTR 全般のサウンド開発環境の既知の問題として移行しました。

      (SoundMaker) プロジェクトの修復のフォルダ参照ダイアログが初回しかツリー展開されない
      (SoundMaker) HTMLサウンドリストの出力するリストのチェックを外してしまう操作がある
      (SoundMaker) HTMLサウンドリストが出力設定名のものと異なる設定で出力される
      (SoundMaker) 接頭語を付けずに数字名のアイテムを追加すると先頭にアンダーバーが表示される
      (SoundMaker) ソートによってフォーカスが外れたアイテムを削除するとアプリケーションエラー

    また次の問題点は、現在のバージョンでは発生しないため削除しました。

      (SoundMaker) 項目を選択して貼り付けでアプリケーションエラー
      (SoundMaker) 再生ボタンと再生時間でセルのコピーを実行するとアプリケーションエラー

  • (SoundPlayer) HioSoundPlayer ストリーム再生時の不具合を修正しました。

    • HioSoundPlayer でストリームサウンドを再生しようとすると、それ以降操作を受け付けなくなる不具合がありましたが、CTR_SDK-0.14 以降の SDK 側の修正により、本不具合が再現しなくなりました。

  • (SoundPlayer) サウンドが再生できない不具合を修正しました。

    • 下記 (A) の条件を満たすバンクやウェーブサウンドを、下記 (B) の条件を満たすグループ「だけ」に登録した場合、データのロードに失敗しサウンドが再生できない不具合がありましたが、これを修正しました。

      - 【(A) バンクやウェーブサウンドの条件】波形アーカイブとして「自動 (共有)」を選択
      - 【(B) グループの条件】 出力形式として「埋め込み」を選択

    本不具合の修正を反映するには、サウンドアーカイブを再コンバートする必要があります。

既知の問題点

  • (SoundMaker) 動作環境のDPIの設定で、通常のサイズ(96 DPI)以外を選択すると、ツール上の描画が正しく行われない可能性があります。 [*]

    • この問題の修正時期は未定です。

  • (SoundMaker) 特定のシーケンスサウンド再生で異常終了します。

    • シーケンスの途中に alloctrack コマンドのあるシーケンスサウンドを PC プレビュー再生しようとすると、SoundMaker が異常終了します。

  • (SoundMaker) 検索結果表示に関する不具合があります。

    • 検索結果ウィンドウに表示されるインストルメントに、必ず「！」マークがついてしまう不具合があります。

  • (SoundMaker) プレイヤー名変更時の不具合があります。

    • プレイヤー名を変更してリンク切れを解消しても「！」マークが消えず、そのままコンバートすると内部エラーになる不具合があります。
    エラーが発生する状態でプロジェクトを開き直すと、復旧します。

  • (SoundMaker) セルのコピーに関する不具合があります。

    • 「再生時間」「フロントバイパス」カラムで「セルのコピー」を実行してもコピーされません。
    「再生」カラムで「セルのコピー」メニューがグレー表示になりません。

  • (SoundMaker) バンクのリンク切れに関する不具合があります。

    • シーケンスサウンドにプロジェクト内に存在しないバンクを指定しても、シーケンスサウンドリスト上に警告アイコンの「！」マークが表示されません。

  • (SoundMaker) プロジェクトの修復に関する不具合があります。

    • 「プロジェクトの修復」実行時、検索を行うフォルダを指定する際に、一回目のフォルダ参照では構成がツリー展開されているのに対して、一度目的のファイルが無いフォルダを検索して再度フォルダを参照するとツリー展開されていない状態で表示されます。

  • (SoundMaker) HTMLサウンドリストの設定に関する不具合があります。

    • 「プロジェクトの設定」の HTML サウンドリストタブで、「設定リストの編集」ボタンを押してから開いた設定リストの編集ウィンドウを閉じると、出力項目タブの「出力するリスト」のチェックが全て外れてしまいます。

  • (SoundMaker) HTMLサウンドリストの出力に関する不具合があります。

    • 「プロジェクトの設定」の HTML サウンドリストタブで、「設定リストの編集」ボタンから 新規作成を行い再コンバートすると、「出力設定名」に表示されていた設定ではなく、新規作成された設定で HTML サウンドリストが出力されます。

  • (SoundMaker) アイテム名の設定に関する不具合があります。

    • 「プロジェクトの設定」のアイテム名タブで「接頭語を付ける」欄のチェックを外し、サウンドリストにアイテムを追加する際、ファイル名が数字から始まるファイルを選択して、アイテム名をファイル名から作成すると、アイテム名の先頭にアンダーバーが表示されます。

    アイテム名がアルファベットで始まるファイルでは発生しません。

  • (SoundMaker) リストでのアイテム削除に関する不具合があります。

    • リストアイテムをフォーカスした後、名前などでソートするとフォーカスが外れてしまいます。
    この状態でツールバーの コピー・切り取り・削除 のアイコンが点灯したままになり、切り取り・削除 ボタンを押すと、アプリケーションエラーが発生します。

  • (SoundMaker) HTML インストルメントリストの出力項目に関する不具合があります。

    • サウンドの項目として追加された【再生時間】【ティック数】【補間タイプ】について、「HTML インストルメントリストの出力」項目にこれらが存在しないため、出力できません。

  • (SoundMaker) PC プレビューでの FILTER 効果に関する不具合があります。

    • PC でエミュレーション再生する際、LPF や Biquad フィルタが効かない不具合があります。

  • (SoundMaker) [項目を選択して貼り付け] 後の Undo に関する不具合があります。

    • サウンドリストで [編集]→[項目を選択して貼り付け] を行うと、プロジェクトツリーに編集マークは付きますが、リスト上の見た目の変化はありません。
    またその後、[元に戻す] を実行するとアプリケーションエラーが発生します。

  • (SoundMaker) 関連アイテム登録のエラー表示文言に関する不具合があります。

    • 波形アーカイブが自動設定で、グループの関連アイテム登録設定を「波形アーカイブ」と「バンクまたはWSDSET」を両方含まない設定に変更しようとすると、"ALL" の指定を促すエラーが表示されますが、実際には "ALL" だけでなく、"BANK と WARC のみ", "SEQ/SEQSET のみ" も選択できます。

  • (SoundMaker) .mus からの .cseq 生成に関する不具合があります。

    • インポート実行時、.mus ファイルから .cseq ファイルを生成する時に、不完全な .cseq ファイルが生成されてしまう不具合があります。
    具体的には、.cseq ファイルは、.mus ファイルのデータ部分のみでなければならないのに、.mus ファイルテーブル部分が残ってしまいます。

  • (SoundMaker) アイテムの追加時のアイテム名に関する不具合があります。

    • プロジェクト設定のアイテム名タブにある「接頭語をつける」にチェックがついていなくても、任意の新規作成ダイアログからアイテムの追加を行うと接頭語がついてしまう不具合があります。

  • (SoundMaker) バンクのラベル名変更時に関する不具合があります。

    • バンクのラベル名を変更すると、そのバンクを使用しているシーケンスサウンド側で追随してラベル名が変わらないため、シーケンスのプレビュー再生やコンバートでエラーメッセージが表示される場合があります。

  • (SoundMaker) 波形ファイルの追加時に関する不具合があります。

    • 波形ファイルをインストリストに追加する際、波形ファイル名に含まれているオリジナルキーの文字列が反映されない不具合があります。

  • (コンバータ) ストリームサウンドコンバート時のエラーメッセージに不備があります。

    • 本来不正なループ情報を持つ WAV ファイルをコンバートした際、内部エラーとなり適切なエラーメッセージが表示されず、ユーザーに何が問題となっているのかわからない状態となる問題があります。

  • (コンバータ) コンバート時に内部エラーが発生する不具合があります。

    • 以下の状態でコンバートを行うと、内部エラーの表示が出てしまいます。

      - リンク切れグループアイテムを含むプロジェクト
      - 異なる種類のアイテムで名前が重複している
      - シーケンスコンバートでのエラー発生後

  • (コンバータ) SMF から変換したテキストシーケンスに関する不具合があります。

    • SoundMaker 上で、ファイルタイプ：[SMF] の .mid ファイルをコンバートするとテキストシーケンス .cseq ファイルが .mid ファイルのフォルダに出力されますが、この後、この出力されたテキストシーケンスをファイルタイプ：[テキスト]として直接指定してから再度コンバートを行うと、このテキストシーケンスファイル .cseq が消えてしまう不具合があります。
    そのため、更に次のコンバート以降ではファイルが見つからずエラーとなります。

Version 1.2.0　2010-11-04

機能追加／変更点

  • (全般) インストルメント単位の補間タイプ選択機能を追加しました。 [*] [*]

    • SoundMaker 上のインストリストやパーカッションリストで、「補間タイプ」が選択できるようになりました。
    詳しくは 本マニュアル内の [応用編]-[バンクタブ]-[インストリスト] または [パーカッションリスト] の「補間タイプ」の項目をご覧ください。

    また、従来 nw::snd::SoundSystem::SetSrcType 関数で設定できていた「補間タイプ」はストリームサウンドおよびウェーブサウンドのみに影響し、シーケンスサウンドに関しては、今回追加した「インストルメント単位の補間タイプ」が影響します。

  • (SoundMaker) ファイル出力に関する機能を追加しました。 [*] [*]

    • プロジェクト設定の「コンバート」タブに「アイテム別ラベルを出力する」チェックボックスを追加しました。
    チェックボックスを ON にすることにより、ID のヘッダを種類別のファイルに分けて出力することができるようになります。

  • (SoundMaker) タイトルバーのプロジェクト名表記変更機能を追加しました。 [*]

    • [ツール] → [オプション] → [全般] タブで、「タイトルバーのプロジェクト名をフルパスで表示する」チェックボックスを ON にすると、タイトルバーのプロジェクト名表記がフルパスに変更される機能を追加しました。

  • (コンバータ) 波形ファイルのループ設定に関する仕様を変更しました。

    • ループ設定されている波形ファイルのループ開始と終了が同フレームだった場合、ループなしの設定にするように仕様を変更しました。

  • (コンバータ) cinl ファイルからの無効なインストルメントを除外しました。

    • インストルメントを無効にすると、コンバート時に cinl ファイル (インストルメントのラベルファイル) から、当該インストルメントが含まれないようにしました。

    無効なインストルメントのラベルを参照しているシーケンスを、コンバートエラーにすることが目的です。

  • (ドキュメント) SoundMaker ユーザーズガイドのトラブルシューティングを追記しました。 [*]

    • SoundMaker を利用中、リスト内の文字が表示されなくなった場合の対処方法について、本マニュアルのトラブルシューティングの章に追記しました。

  • (SoundPlayer) クリッピングモード選択機能を追加しました。

    • nn::snd::SetClippingMode 関数で設定できる、クリッピングモードを選択できる機能を追加しました。
    「OutputMode」画面から選択することができます。

  • (SoundPlayer) SoundPlayer-TS.cia 作成機能を削除しました。

    • CTR_SDK-0.14.0 以降の DevMenu で、cia ファイルのインポート機能が廃止されたため、SoundPlayer の cia 版作成機能も削除されました。

不具合修正点

  • (SoundMaker) シーケンスサウンドの PC プレビュー再生に関する不具合を修正しました。

    • タイムベースが 480 かつテンポが 78 以下のシーケンスサウンドを PC プレビュー再生するとサウンドが再生されない不具合がありましたが、これを修正しました。

    本症状は NW4C-1.1.0 から再現していました。

  • (SoundMaker) インストルメントリスト表示に関する不具合を修正しました。

    • キーリージョンを削除してパーカッションタブを開くと例外になる不具合がありましたが、これを修正しました。

  • (コンバータ) 波形コンバートに関する不具合を修正しました。

    • 極端に短い無音波形を再生するとノイズがのる不具合がありましたが、これを修正しました。

  • (コンバータ) インストルメントの圧縮方式がコンバート結果に反映されない不具合を修正しました。

    • SoundMaker でインストルメントの圧縮方式を変更しても、コンバートした結果に反映されない不具合がありましたが、これを修正しました。

  • (コンバータ) サンプルマップの分割に関する不具合を修正しました。

    • サンプルマップを 2 つに分割後、片方の波形ファイル割り当てを削除し、シーケンスサウンドのノートオン時に削除した方のリージョンを参照していても、音を再生することができていました。

    これは、空のリージョンを含めて 2 つに分割した場合、削除した方のリージョンにも波形割り当てが残ったままになるコンバータの不具合で、今回修正されました。

    本修正により、波形割り当てのないリージョンでは、ノートオン時に音が鳴らなくなります。

  • (コンバータ) サウンドプロジェクトコンバータのオプション指定に関する不具合を修正しました。

    • サウンドプロジェクトコンバータ (NW4C_SoundProjectConverter.exe) で、オプションを先に書くとエラーになる不具合がありましたが、これを修正しました。

  • (SoundPlayer) エフェクトパラメータ設定に関する不具合を修正しました。

    • SoundPlayer 上で、下記のエフェクトパラメータについて、負の値が設定できるようになっていましたが、これを修正しました。
      - FxReverb::Param::m_EarlyReflectionTime
      - FxReverb::Param::m_FusedTime
      - FxReverb::FilterSize::m_Comb0
      - FxReverb::FilterSize::m_Comb1
      - FxReverb::FilterSize::m_AllPass
      - FxDelay::Param::m_DelayTime

Version 1.1.0　2010-10-04

機能追加／変更点

  • (SoundMaker) MIDI 設定に関する機能を追加しました。

    • [ツール] - [オプション] - [MIDI] タブの [MIDI キーボード入力] コンボボックスに、[指定なし] の項目を追加しました。

    対応する MIDI デバイスを 1 つだけ接続している場合、これまでは [MIDI キーボード入力] として必ず選択されていましたが、これを外すことができるようになります。

  • (SoundMaker) インポートに関する機能を追加しました。

    • NTR バンクファイルを単体でインポートできるように対応しました。

  • (SoundPlayer) SoundPlayer が UIC-MIDI に対応しました。

    • UIC-MIDI デバイスを TS ボード、白箱 (PARTNER-CTR Debugger)、開発用実機に接続すると、SoundPlayer 上で MIDI 信号を受信し、プレビュー再生できるようになりました。

  • (ドキュメント) マップファイルに関する説明を追記しました。 [*]

    • コンバート時に作成されるマップファイルについての説明を、本マニュアルの [基本編] - [コンバート] - [生成されるファイル] に追記しました。

    マップファイルから ROM サイズ、バンク容量などがわかります。

不具合修正点

  • (全般) ウェーブサウンドのリリースが効かない不具合を修正しました。

    • SoundMaker のウェーブサウンドリストにて、EnvR カラムのパラメータを変更しても、
      - 出力バイナリ (bcsar) に反映されない
      - ランタイムでリリースが効かない
    問題がありましたが、それぞれ修正しました。

  • (SoundMaker) 空サウンドセットを含む HTMLサウンドリストの表示不具合を修正しました。

    • 空サウンドセットを含む HTMLサウンドリストにおいて、サウンドセットのフィルタ表示が正しく動作しない問題がありましたが、これを修正しました。

  • (SoundMaker) SoundPlayer の作成における不具合を修正しました。

    • 「ストリームファイルの出力先パス」として、2 階層以上あるディレクトリを指定した場合、「SoundPlayer の作成」で作成した SoundPlayer でストリームサウンドを再生すると、例外エラーで停止する不具合がありましたが、これを修正しました。

  • (SoundMaker) ファイル関係の不具合を修正しました。

    • [ファイルを開く] のフィルタ [All Files] の場合に、cbnk ファイル以外を指定すると例外エラーになる不具合がありましたが、これを修正しました。

  • (コンバータ) 環境変数 NW4C_ROOT 未設定時の不具合を修正しました。

    • 環境設定 NW4C_ROOT を設定しないままコンバートすると、コンバート後に例外エラーが発生する不具合がありましたが、これを修正しました。

  • (SoundPlayer) 文字列テーブルが含まれないサウンドアーカイブを読み込んだ場合の不具合を修正しました。

    • 文字列テーブルが含まれないサウンドアーカイブを、SoundPlayer / HioSoundPlayer に読み込ませると、アプリ起動途中 or サウンドアーカイブリロード中に停止する不具合がありましたが、これを修正しました。

    文字列テーブルが含まれない場合は、アイテム名 (SE_YOSHI など) のかわりに、「...」が表示されます。

  • (ドキュメント) 波形アーカイブ共有設定に関する説明を修正しました。 [*] [*]

    • 本マニュアルの [応用編] - [サウンドセットタブ] - [ウェーブサウンド] および [バンク] の項目内にある、波形アーカイブの説明において、共有に関係するサウンドの説明に不備があったので、これを修正しました。

Version 1.0.1　2010-08-25

機能追加／変更点

  • (全般) シーケンスコマンドに frontbypass_on / frontbypass_off を追加しました。

    • シーケンスコマンドに、frontbypass_on / frontbypass_off を追加しました。
    詳しくは、シーケンスデータマニュアルをご覧ください。

    また、SampleData/Sound/Projects/simple/seq/se.cseq の jump_seq シーケンス (シーケンスサウンド SEQ_JUMP) を、当該コマンドを使用したものに変更しました。

  • (SoundMaker) リスト操作に関する仕様を変更しました。

    • 読み取り専用サウンドセット内のサウンドを、プレビュー再生できるように変更しました。

  • (SoundPlayer) サラウンドパン設定を追加しました。 [*]

    • SoundPlayer 上で、ボリュームやピッチ、パンと同様に、サラウンドパンも設定できるようになりました。

  • (SoundPlayer) サウンドアーカイブリロード時にサウンド ID を保存するようにしました。

    • HioSoundPlayer にて、サウンドアーカイブをリロードすると、サウンド ID がリセットされていましたが、リセットされず、サウンド ID が保存されるように変更しました。
    ただし、指定しているサウンド ID が、リロード後のサウンドアーカイブに格納されているサウンドの数より大きい場合は、以前と同じくリセットされます。

不具合修正点

  • (SoundMaker) NITRO-SoundMaker プロジェクトインポートに関する不具合を修正しました。

    • デスクトップ上に置かれた NITRO-SoundMaker プロジェクトのインポートに失敗する不具合がありましたが、これを修正しました。

  • (SoundMaker) リスト表示に関する不具合を修正しました。

    • パーカッションリストで音階が表示されない不具合がありましたが、これを修正しました。

  • (コンバータ) ADPCMループノイズが発生する不具合を修正しました。

    • ループスタートフレームが 0 の時、ADPCMエンコードすると、ループノイズが発生する不具合がありましたが、これを修正しました。
    波形データの再コンバートが必要です。

  • (コンバータ) ストリームループ時のノイズを修正しました。

    • ストリームデータループ時に、ノイズが発生する不具合がありましたが、これを修正しました。
    波形データの再コンバートが必要です。

  • (SoundPlayer) 再生開始時にパラメータが反映されない不具合を修正しました。

    • サウンド再生開始時に、音量やピッチなどのパラメータが反映されない不具合がありましたが、これを修正しました。

  • (ドキュメント) 音量に関する説明を修正しました。

    • SoundMaker の各リストで設定できる音量に関する説明を修正しました。
    ストリームサウンド、ウェーブサウンド等の「音量」の解説をご覧ください。 [*]

    また詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

Version 1.0.0　2010-07-29

機能追加／変更点

  • (SoundMaker) ウェーブサウンドリストへセンドカラムを追加しました。 [*]

    • ウェーブサウンドリストに、各バスへのセンド量を指定する下記のカラムを追加しました。
      - センド AUX A
      - センド AUX B
      - センド MAIN

  • (SoundMaker) サウンドのフロントバイパスモードに対応しました。 [*] [*] [*]

    • 各サウンド (ストリームサウンド、ウェーブサウンド、シーケンスサウンド) が、「フロントバイパスモード」に対応しました。
    SoundMaker の各リストで設定可能です。
    SampleData/Sound/Projects/simple の下記サウンドでご確認ください。
      - STRM_MARIOKART_FB
      - SE_YOSHI_FB
      - SE_STEREO_FB
      - SEQ_CALL_FB
      - SEQ_MARIOKART_FB

  • (SoundPlayer) エフェクトに対応しました。 [*]

    • SoundPlayer 上でエフェクトを試すことができるようになりました。

不具合修正点

  • (SoundMaker) SoundPlayer 作成時の不具合を修正しました。

    • サウンドアーカイブの出力先を output 以外に設定すると、SoundPlayer の作成に失敗する不具合がありましたが、これを修正しました。

  • (SoundMaker) リスト操作に関する不具合を修正しました。

    • リスト操作に関して下記の不具合を修正しました。
      - シーケンスファイルに不正な文字列があると、再生開始位置選択時に例外エラーが発生
      - 「再生」「再生時間」カラムで「セルのコピー」をすると例外エラーが発生

  • (コンバータ) DSP ADPCM ストリーム再生時の不具合を修正しました。

    • DSP ADPCM でエンコードされたストリームサウンドを再生すると、データ末尾およびループ時にノイズがのる問題がありましたが、これを修正しました。

  • (SoundPlayer) インポートに関する不具合を修正しました。

    • SoundPlayer-TS.cia がインポートできない不具合がありましたが、これを修正しました。

Version 0.8.1　2010-07-07

不具合修正点

  • (SoundMaker) サンプルデータに含まれるサイン波形のループ調整をしました。

    • サンプルデータに含まれるサイン波形 (SampleData/Sound/Projects/simple/aif/sin440.aiff) を再生すると、ループ時にノイズがのる問題がありましたが、これを修正しました。

  • (コンバータ) バンクコンバートに関する不具合を修正しました。

    • パーカッションリストやパラメータパネルで設定できる、ベロシティリージョンの下記のパラメータが、バイナリサウンドアーカイブファイル (.bcsar) (正確にはバイナリバンクファイル (.bcbnk) ) に正しく反映されない問題がありましたが、これを修正しました。
      - 音量
      - ピッチ (半音)

  • (コンバータ) 波形コンバートに関する不具合を修正しました。

    • 波形コンバートに関する下記の不具合を修正しました。
      - PCM16/PCM8 エンコードでサンプルが出力されない
      - ADPCM エンコードで不正な内容が出力される

  • (コンバータ) 8bit PCM 波形のコンバートに関する不具合を修正しました。

    • 8bit PCM の .wav / .aiff ファイルをコンバートすると、SoundPlayer などの実機での再生や PC エミュレーション再生において、「音が割れる」「音が鳴らない」などの不具合が発生していましたが、これを修正しました。

  • (コンバータ) 存在しないバンクファイルを参照しているプロジェクトコンバート時の不具合を修正しました。

    • 存在しないバンクファイル (.bcnk) を参照しているプロジェクトをコンバートすると、警告内容の書かれていないダイアログが表示される不具合がありましたが、これを修正しました。

  • (コンバータ) 存在しない再生開始位置を指定した場合のエラーメッセージを修正しました。

    • シーケンスサウンドのコンバート時に、存在しない再生開始位置を指定した場合、どのラベルのどの再生開始位置でエラーが起こっていたのかわかりにくい問題がありました。
    これを「ラベル」「再生開始位置」がわかるように修正しました。

    以下に、例を示します。
      - (修正前) [内部エラー] start label not found.
      - (修正後) [エラー : SEQ_WIHAHO] 再生開始位置のラベル名 "wihaho2" は、シーケンスデータ中に存在しません。

  • (ドキュメント) アイテム名に関する説明を修正しました。

    • SoundMaker の各リストで設定できるアイテム名に関する説明を修正しました。
    名前に使用できる文字には制限があり、以下の文字が使えます。
      - 名前の先頭は、半角英字とアンダーバー [a-zA-Z_]
      - 先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

Version 0.8.0　2010-06-28

機能追加／変更点

  • (SoundMaker) TEG2 版 SoundPlayer の作成メニューを削除しました。

    • CTR-TEG2 サポートを打ち切りのため、TEG2 版 SoundPlayer の作成メニューを削除しました。

  • (SoundPlayer) DSP 処理負荷と使用ボイス数表示を追加しました。

    • SoundPlayer の上画面表示に下記を追加しました。
      - DSP 処理負荷
      - 使用ボイス数

  • (SoundPlayer) 出力モード、サラウンドデプス値設定を追加しました。 [*]

    • Y ボタンにて出力モードの変更、L/R ボタンにてサラウンド出力時のサラウンドデプス値の変更ができるようになりました。

  • (SoundPlayer) HioSoundPlayer を追加しました。 [*]

    • Host IO 経由でサウンドアーカイブをリロードできる、HioSoundPlayer.cci を追加しました。
    $NW4C_ROOT/tools/SoundPlayer/ に含まれています。

不具合修正点

  • (SoundMaker) コンバートイベントに関する不具合を修正しました。

    • コンバート前コマンドやコンバート後コマンドで実行するコマンドで、対話的に入力を求められるとフリーズする問題がありましたが、これを修正しました。
    キャンセルボタンを押すことで、コンバートをキャンセルすることができます。

    コンバート前コマンド・コンバート後コマンドでは、対話的な入力には対応していませんので、ご注意ください。

  • (コンバータ) ADPCM のループエンドに関する不具合を修正しました。

    • ループ付き波形を ADPCM でコンバートすると、ループエンド周辺で波形の形が安定しない不具合がありましたが、これを修正しました。

Version 0.7.1　2010-05-21

不具合修正点

  • (SoundMaker) リスト操作に関する不具合を修正しました。

    • コンバートエラーを起こすテキストシーケンスサウンドに対して、再生開始位置を変更させる操作を行うとエラーが発生する問題がありましたが、これを修正しました。

Version 0.7.0　2010-05-14

機能追加／変更点

  • (全般) サンプルデータを $NW4C_ROOT/SampleData/Sound/Projects に移動しました。

    • SoundMaker のサンプルデータを $NW4C_ROOT/SampleData/Sound/Projects に移動しました。
      - $NW4C_ROOT/tools/SoundMaker/samples/simple → $NW4C_ROOT/SampleData/Sound/Projects/simple
      - $NW4C_ROOT/demos/snd/externalFile/dataSrc → $NW4C_ROOT/SampleData/Sound/Projects/externalFile
      - $NW4C_ROOT/demos/snd/playerHeap/dataSrc → $NW4C_ROOT/SampleData/Sound/Projects/playerHeap

    これにともない、デモの OMakefile および vcproj ファイルを調整しました。

  • (SoundMaker) SoundPlayer の作成機能を追加しました。[*] [*] [*]

    • SoundMaker のメニューから、SoundPlayer の実行ファイル(SoundPlayer.cci) を作成する機能を追加しました。

  • (SoundMaker) 波形データの時間表示を追加しました。

    • 下記のリストに、波形データの時間表示カラムを追加しました。
    一部のリストには、ティック数表示カラムも追加しました。
      - バンクのインストリスト [*]
      - バンクのパーカッションリスト [*]
      - ウェーブサウンドリスト [*]
      - ストリームサウンドリスト [*]

  • (SoundPlayer) nn::snd::SendParameterToDsp 処理時間の表示を追加しました。

    • CTR_SDK の nn::snd::SendParameterToDsp の処理時間を、上画面に表示するようにしました。

不具合修正点

  • (SoundMaker) プロジェクト設定ファイルに関する不具合を修正しました。

    • 起動パラメータにプロジェクトファイルへの相対パスを指定して SoundMaker を起動した場合に、プロジェクト設定ファイルが正しく保存されなかったり、SoundMakerを終了しようとするとエラーが発生する問題がありましたが、これを修正しました。

  • (SoundMaker) SoundPlayer 作成に関する不具合を修正しました。

    • NW4C-0.7.0 スナップショット版で、プロジェクトファイル (.cspj) の絶対パスにスペースが含まれていると、SoundPlayer が作成できない不具合がありましたが、これを修正しました。

  • (SoundMaker) 中間ファイル入出力に関する不具合を修正しました。

    • アクタープレイヤー、ユーザーデータ、EnvelopeRelease を編集して保存しても、中間ファイル入出力が正しく行われない不具合がありましたが、これを修正しました。

  • (コンバータ) デモ並列ビルド時に失敗する不具合を修正しました。

    • デモを並列ビルドした際に、同一プロジェクトファイルをコンバートしようとしてコンバートエラーが発生する問題がありましたが、これを修正しました。

  • (コンバータ) インストルメントのプログラム番号の上限値を修正しました。

    • インストルメントのプログラム番号に 255 以上の値を設定すると、コンバートエラーが発生する問題がありましたが、これを修正しました。

    正しい上限値は、32767 になります。

  • (コンバータ) サウンドプロジェクトコンバータに関する不具合を修正しました。

    • サウンドプロジェクトコンバータに関する下記の不具合を修正しました。
      - コンバート処理の成否に関わらず、必ず成功コードを返す不具合
      - プロジェクトファイルを相対パスで指定すると、内部エラーが発生して必ずコンバートに失敗する不具合

  • (コンバータ) CSIDファイル出力に関する不具合を修正しました。

    • 複数のサウンドセットを含むプロジェクトをコンバートした際に、CSIDファイルのサウンドID が正しく出力されない問題がありましたが、これを修正しました。

Version 0.6.2　2010-04-23

不具合修正点

  • (コンバータ) インストのリージョン分割数を 4 の倍数にした場合の不具合を修正しました。

    • インストのリージョンの分割数を 4 の倍数にし、当該インストを再生するシーケンスサウンドを再生すると、アサートで停止する問題がありましたが、これを修正しました。

Version 0.6.1　2010-04-16

機能追加／変更点

  • (SoundPlayer) TEG2 版と TS 版それぞれを生成する wsf ファイルを追加しました。

    • SoundPlayer の CTR-TS ボード対応にともない、TS 版および TEG2 版の cci ファイルを生成するための次の wsf ファイルが追加されました。
      - MakeSoundPlayer-TS.wsf
      - MakeSoundPlayer-TEG2.wsf

    これまでパッケージに含まれていた MakeSoundPlayer.wsf は削除されました。

Version 0.6.0　2010-03-19

機能追加／変更点

  • (SoundMaker) アクタープレイヤー・3D サウンドパラメータを追加しました。

    • SoundMaker 上でアクタープレイヤーや、3D サウンドパラメータが設定できるようになりました。

    これにともない、(プロジェクト名).cspj .settings ファイルのバージョンも更新され、以前の (プロジェクト名).cspj .settings ファイルはいったんリセットされます。

  • (コンバータ) 3D サウンドパラメータに対応しました。

    • 3D サウンドパラメータのコンバートに対応しました。

  • (SoundPlayer) SoundPlayer ツールを追加しました。

    • CTR-TEG2 で利用できる SoundPlayer ツールを追加しました。
    使い方については、$NW4C_ROOT/tools/SoundPlayer/Readme.txt をご参照ください。

    今回の SoundPlayer ツール追加にともない、$NW4C_ROOT/demos/snd/SoundPlayer は削除されました。

不具合修正点

  • (コンバータ) 無効アイテムを参照するグループコンバート時の不具合を修正しました。

    • グループが無効アイテムを参照するようなプロジェクトをコンバートしようとすると、エラーや内部エラーが発生する問題がありましたが、これを修正しました。

  • (コンバータ) 不正なインストルメントを含むバンクコンバート時の不具合を修正しました。

    • プログラム番号が同一バンク内で重複していたり、0 から 255 の範囲にないインストルメントを含むバンクをコンバートした際に、正しくエラー表示されない問題がありましたが、これを修正しました。

  • (コンバータ) コンバートに関する不具合を修正しました。

    • 以下の条件を満たすプロジェクトをコンバートしようとすると内部エラーが発生する問題がありましたが、これを修正しました。
      - 波形アーカイブ設定が "自動(共有)" であるアイテム（バンクまたはウェーブサウンドセット）を含む
      - 上記アイテムが埋め込みグループのアイテムに登録されている
      - 上記アイテムを関連アイテムとして参照するアイテムが別のグループに登録されている

Version 0.5.1　2010-03-05

機能追加／変更点

  • (SoundMaker) ストリームのマルチトラックに関する仕様を変更しました。

    • ストリームに追加できるトラックの最大数を 4 つに変更しました。
    「マルチトラックの設定」ダイアログで 5 つ以上のトラックに "!" アイコンを表示するように変更しました。

  • (コンバータ) ストリームのマルチトラックに関する仕様を変更しました。

    • ストリームにトラックが 5 つ以上付いていた場合、エラーになるように変更しました。

不具合修正点

  • (SoundMaker) シーケンスサウンドの alloctrack に関する不具合を修正しました。

    • シーケンスサウンドで確保するトラック数が 16 以上(テキストシーケンス .cseq の場合、alloctrack 0xffff) にすると、コンバートエラーになっていましたが、これを修正しました。

Version 0.5.0　2010-02-19

機能追加／変更点

  • (コンバータ) 波形データフォーマットの仕様を変更しました。

    • ADPCM エンコードした波形データのうち、不要なパラメータを削除しました。
    対象は、
      - バンクのインスト用の波形
      - ウェーブサウンド用の波形
      - ストリームサウンド用の波形
    です。

    旧バージョンとのデータ・ライブラリと互換性がありませんので、NW4C-0.5.0 以降のライブラリを利用する場合は、データを再コンバートする必要があります。

不具合修正点

  • (SoundMaker) インポートに関する不具合を修正しました。

    • NITRO-SoundMaker 中間ファイルのインポートで .mus ファイルに記述されているプリプロセッサ命令が、インポート後に生成される .cseq ファイルに記述されない場合がありましたが、これを修正しました。

  • (SoundMaker) インポートに関する不具合を修正しました。

    • NITRO-SoundMaker 中間ファイルのインポートで、バンクのリージョン単位のエンベロープ指定が失われる問題がありましたが、これを修正しました。

  • (コンバータ) 波形コンバートに関する不具合を修正しました。

    • 一部サンプリングレートの波形データコンバートに失敗する問題がありましたが、これを修正しました。

Version 0.4.1　2010-01-26

不具合修正点

  • (SoundMaker) サンプルマップの表示に関する不具合を修正しました。

    • サンプルマップの波形ファイルの圧縮方式が PCM8 と ADPCM で逆に表示されていた不具合がありましたが、これを修正しました。

  • (SoundMaker) シーケンスサウンドの新規作成に関する不具合を修正しました。

    • シーケンスサウンドの新規作成でエラーになり、アイテムの追加ができない不具合がありましたが、これを修正しました。

  • (SoundMaker) 対応していない機能に関する不具合を修正しました。

    • 現在、対応できていない機能やサポートしない機能が、GUI上に表示されてしまう問題がありましたが、これを修正しました。
      - 3Dサウンド
      - エフェクト
      - SoundPlayer 連携
      - Viewer 連携
      - プレビュープレイヤーパラメータウィンドウ
      - DLSインポート

Version 0.4.0　2010-01-15

機能追加／変更点

  • (SoundMaker) グループリストの新規追加ダイアログに関する機能を追加しました。 [*]

    • グループリストの新規追加ダイアログに「関連アイテム登録」が選択できるように機能を追加しました。

  • (SoundMaker) インポートに関する機能を追加しました。 [*]

    • 別プラットフォーム（NintendoWare for Revolution SoundMaker, NITRO-SoundMaker）をインポートできるように機能を追加しました。
    [ファイル]→[インポート]→[別プラットフォームのプロジェクト] からインポートが可能です。ファイルオープンダイアログのファイルの種類で「Another Platform Project Files (*.rspj;*.sprj;*.sarc)」を選択して実行します。

  • (コンバータ) csid ファイルの BOM を削除しました。

    • RVCT でのコンパイルに対応するため、csid ファイルの BOM を削除しました。

  • (コンバータ) バイナリ波形ファイルのフォーマットを更新しました。

    • TEG2 対応のため、バイナリ波形ファイル (.bcwav) のフォーマットを更新しました。
    TEG2 でサウンドを再生する場合は、サウンドアーカイブを再コンバートしてください。

不具合修正点

  • (SoundMaker) バンクの新規作成に関する不具合を修正しました。

    • バンクの新規作成ダイアログからバンクの新規作成を行うと、拡張子がrbnkのファイルが作成されてしまう問題がありましたが、これを修正しました。

  • (SoundMaker) インストルメント新規作成に関する不具合を修正しました。

    • インストルメントリストにアイテムが未登録の状態で、インストルメント新規作成を行うと、プログラムナンバーが "0" ではなく "1" から作成される不具合がありましたが、これを修正しました。

  • (SoundMaker) エンベロープ編集に関する不具合を修正しました。

    • エンベロープ設定をインスト単位からリージョン単位に変えると、プロジェクトを開き直す等しない限り、エンベロープが編集できなくなる問題がありましたが、これを修正しました。

  • (SoundMaker) パラメータパネルに関する不具合を修正しました。

    • パラメータパネルからインストルメントのエンベロープを編集すると例外エラーが発生する不具合がありましたが、これを修正しました。

  • (SoundMaker) サウンドセットファイルの保存に関する不具合を修正しました。

    • サウンドセットファイルの保存時に、サウンドのプレイヤー優先度が正しく保存されない問題がありましたが、これを修正しました。

  • (SoundMaker) プロジェクトツリーに関する不具合を修正しました。

    • サウンドセット名の編集中にプロジェクトツリーを最小化すると "応答なし" になる不具合がありましたが、これを修正しました。

  • (SoundMaker) リスト編集に関する不具合を修正しました。

    • グループアイテムに存在しないアイテム名を指定すると、アプリケーションエラーが発生する不具合がありましたが、これを修正しました。

  • (SoundMaker) リスト操作に関する不具合を修正しました。

    • リストアイテムをドラッグ＆ドロップで複数移動した場合、移動先でリストの並びが変わる不具合がありましたが、これを修正しました。

  • (SoundMaker) ファイルオープンダイアログに関する不具合を修正しました。

    • サンプルマップの参照波形の変更で、ファイルオープンダイアログの示すフォルダが、登録されている参照波形のフォルダになっていない不具合がありましたが、これを修正しました。

    リスト項目の「ファイルパス」の変更で、ファイルオープンダイアログの「ファイル名」に、登録されているファイル名が入力されていない不具合がありましたが、これを修正しました。

  • (SoundMaker) サンプルマップに関する不具合を修正しました。

    • サンプルマップの空白部分で、ダブルクリックによるファイル指定をすると例外エラーになる不具合がありましたが、これを修正しました。

  • (SoundMaker) バンクタブに関する不具合を修正しました。

    • バンクリストが編集状態のときに、バンクタブを閉じると例外エラーになる不具合がありましたが、これを修正しました。

  • (SoundMaker) プロジェクト設定に関する不具合を修正しました。

    • プロジェクトファイルに含まれるプロジェクト設定のアイテム名設定が、正しく読み込めない問題がありましたが、これを修正しました。

  • (SoundMaker) コンバートに関する不具合を修正しました。

    • コンバートを実行すると、開いているバンクパネルがすべて閉じられてしまう問題がありましたが、これを修正しました。

  • (SoundMaker) その他の不具合を修正しました。

    • SoundMaker に関する以下の不具合を修正しました。
      - メインウィンドウを極端に小さくしてビューを分割しようとすると例外エラーが発生する
      - メインウィンドウを極端に小さくしてアプリケーションを終了すると、それ以後、起動時にエラーが発生して起動できない

  • (コンバータ) アップデートコンバートに関する不具合を修正しました。

    • 以下の作業を行った後にアップデートコンバートを行ってもコンバート処理が実行されない問題がありましたが、これを修正しました。
      - ストリームサウンドの圧縮方式を変更
      - テキストシーケンスサウンドファイルを変更
      - ベロシティリージョンが参照する波形ファイルを変更

  • (コンバータ) コンバートに関する不具合を修正しました。

    • インストルメントでコンバートエラーが発生した際に、コンバートログから対象箇所へジャンプできない問題がありましたが、これを修正しました。

Version 0.3.0　2009-12-07

機能追加／変更点

  • (SoundMaker) グループ登録に関する仕様を変更しました。 [*]

    • グループアイテムリストに“関連アイテム登録”カラムを追加しました。

    この設定を変更することで、シーケンスサウンドが参照するバンクや波形アーカイブをまとめてグループ登録するなど、関連するアイテムを まとめてグループに含めることができるようになりました。

  • (SoundMaker) プロジェクト設定ファイル(.setting)に関する仕様を変更しました。

    • SoundMakerのサポートするプロジェクト設定ファイルバージョンとロード対象のプロジェクト設定ファイルバージョンが異なる場合、設定を読み込まないよう仕様変更しました。

    この変更は暫定対応であり、将来的には古いバージョンのプロジェクト設定ファイルのロードに対応する予定です。

不具合修正点

  • (SoundMaker) プレビューバンクに関する不具合を修正しました。

    • プレビューバンクにバンクが登録されている状態でプロジェクトを開こうとすると、必ずエラーが発生してプロジェクトが開けなくなる問題がありましたが、これを修正しました。

  • (SoundMaker) グループサイズ表示に関する不具合を修正しました。

    • グループの出力設定を「出力しない」に設定すると、グループサイズが更新されない問題がありましたが、これを修正しました。

  • (SoundMaker) 自動共有波形アーカイブのコンバートに関する不具合を修正しました。

    • 入れ子グループ内に自動共有波形アーカイブ設定のウェーブサウンドセットまたはバンクが含まれる場合に、コンバートエラーが発生する問題がありましたが、これを修正しました。

  • (SoundMaker) マルチバンク変更に関する不具合を修正しました。

    • マルチバンクでバンクを変更しても表示が変わるだけで、内部の状態は変更されない問題がありましたが、これを修正しました。

Version 0.2.0　2009-11-13

機能追加／変更点

  • データの互換性について

    • NintendoWare 0.2.0 で作成したデータを、NintendoWare 0.2.1 で使用する場合、
      - サウンドプロジェクトファイル（.cspj）は、そのまま使用できます。
      - バイナリサウンドアーカイブファイル（.bcsar）は、使用できません。サウンドプロジェクトファイルを再度コンバートしてください。

  • (SoundMaker) プレビューバンク表示ツールボタンを追加しました。 [*]

    • プレビューバンクを表示するためのツールボタンをメインウィンドウに追加しました。

  • (SoundMaker) プロジェクトの読み込みに関する不具合を修正しました。

    • プロジェクトファイルを移動して開きなおすと、エラーメッセージが表示されプロジェクト設定ファイルを削除するまでプロジェクトが開けなくなる問題がありましたが、これを修正しました。

  • (SoundMaker) サウンドセットの作成に関する不具合を修正しました。

    • サウンドセットの新規作成処理に不具合があり、プロジェクトツリーに波形アーカイブが表示されない、保存したプロジェクトが開けない、といった問題を引き起こしていましたが、これを修正しました。

  • (SoundMaker) シーケンスサウンドのリスト操作に関する不具合を修正しました。

    • シーケンスサウンドリストでコピー＆ペーストを行うと、シーケンスサウンドのバンク設定が不正値となり正しく表示されなくなる問題がありましたが、これを修正しました。

  • (SoundMaker) 波形アーカイブの参照検索に関する不具合を修正しました。

    • 波形アーカイブの参照検索において、検索結果が必ず0件になってしまう問題がありましたが、これを修正しました。

  • (SoundMaker) 波形アーカイブの一括編集に関する不具合を修正しました。

    • 波形アーカイブの個別ロードセルの一括編集ができない問題がありましたが、これを修正しました。

  • (SoundMaker) プレビューバンクを使用したMIDI再生に関する不具合を修正しました。

    • MIDIシーケンサー入力に設定されたデバイスから受信したMIDI信号が、プレビューバンクで再生されない問題がありましたが、これを修正しました。

  • (SoundMaker) シーケンスサウンドリストの操作に関する不具合を修正しました。

    • シーケンスサウンドリストで、バンクを変更しても表示のみ変更され内部は変更されない問題がありましたが、これを修正しました。

  • (SoundMaker) グループアイテム作成ダイアログに関する不具合を修正しました。

    • グループアイテム作成ダイアログで、波形アーカイブが選択できない問題がありましたが、これを修正しました。

  • (SoundMaker) その他の不具合を修正しました。

    • SoundMakerについて以下の問題を修正しました。
      - バンクリストに波形ファイルをドロップしたときに作成されるインストルメントの名前が、設定されているプリフィックスで始まらない
      - パーカッションリストのすべてのアイテムに "!" アイコンが表示されてしまう

  • (コンバータ) バイナリストリームサウンドの出力ファイル名を変更しました。

    • バイナリストリームサウンドの出力ファイル名を次の通り変更しました。
      - 変更前：(サウンド名).(圧縮形式).bcstm
      - 変更後：(サウンド名).bcstm

  • (コンバータ) 出力先の変更に関する不具合を修正しました。

    • コンバートの出力先設定を変更してアップデートコンバートすると、一部ファイルが変更後の出力先に出力されない問題がありましたが、これを修正しました。

  • (コンバータ) HTMLサウンドリスト出力に関する不具合を修正しました。

    • HTMLサウンドリストのリスト項目が、出力設定に関わらず、必ず出力されてしまう問題がありましたが、これを修正しました。

Version 0.1.0　2009-10-30

  • CTR版 SoundMaker 初回リリース

NintendoWare for Revolution からの変更点

  • NW4R SoundMaker プロジェクトのインポート機能を追加しました。 [*]

    • NW4R SoundMaker プロジェクトをインポートすることができます。
    インポート前のファイルはそのまま保持され、インポート後のファイルは同じフォルダに拡張子を変更して保存されます。

  • 波形アーカイブノードを追加しました。 [*] [*]

    • プロジェクトツリーに波形アーカイブノードを追加しました。
    波形アーカイブノードをダブルクリックすると波形アーカイブタブを表示することができます。
    波形アーカイブリストは「名前」「個別ロード」「コメント」を表示します。

  • 波形アーカイブ新規作成ダイアログボックスを追加しました。 [*]

    • 波形アーカイブリストでコンテキストメニューの「アイテムの追加」「アイテムの挿入」から「名前」と「個別ロード」を選べるダイアログを表示することができます。

  • グループリストに「出力方式」カラムを追加しました。 [*]

    • グループリストの「グループ出力」「波形共有」カラムを削除し、新規に「出力方式」カラムを追加しました。
    出力方式は、「リンク」「埋め込み」「出力しない」を選択することができます。

  • シーケンスリストにマルチバンクダイアログを追加しました。 [*]

    • シーケンスリストでコンテキストメニューの「マルチバンクの設定」からマルチバンクダイアログを表示することができます。
    マルチバンクは4つまで指定することができます。

  • プレビューバンクウィンドウを追加しました。 [*]

    • プレビュー機能にプレビューバンクウィンドウを追加しました。
    MIDI シーケンサーから入力された MIDI 信号は、このウィンドウに登録されたバンクを使って再生されます。

  • MIDI設定に関する仕様を変更しました。 [*]

    • MIDIキーボード入力とMIDIシーケンサー入力を選択する方式に変更しました。
    MIDIキーボード入力に設定したデバイスから入力されたMIDI信号は、アクティブなバンクタブのバンクを使用して再生されます。
    MIDIシーケンサー入力に設定したデバイスから入力されたMIDI信号は、プレビューバンクウィンドウのバンクを使用して再生されます。

  • MIDIキーボード入力の対象バンクに関する仕様を変更しました。 [*] [*]

    • アクティブなバンクタブをMIDIキーボード入力の対象バンクとしました。
    バンクタブがアクティブでない場合は、音は鳴りません。
    この仕様変更に伴い、ツールバーのバンク、インストルメント表示は削除されました。

  • プレビュー再生仕様を変更しました。 [*] [*] [*]

    • サウンドとインストルメントのプレビュー再生仕様を見直しました。

    • サウンドプレビュー再生の変更点は以下のとおりです。
      ・SPACEキーまたはリスト上の再生ボタンで、プレビュープレイヤーに登録し、プレビュー再生開始
      ・リストのダブルクリックで、プレビュープレイヤーに登録・再生開始が動作しない
    • インストルメントプレビュー再生の変更点は以下のとおりです。
      ・F9 / F10 / リストのダブルクリックが動作しない
      ・SPACE 押し下げ中のみ、ホールド再生
  • (コンバータ) 並列コンバートに対応しました。

    • 依存関係のないサウンドのコンバート処理を並列して実行できるようになりました。
    同時に実行するコンバート数はオプション画面にて設定できます。

  • (コンバータ) 文字列テーブルを出力しない設定が可能になりました。

    • NW4R SoundMaker では、文字列テーブルがサウンドアーカイブに強制的に出力されましたが、プロジェクト設定のサウンドアーカイブタブの「文字列テーブルを出力する」チェックボックスを外すと、出力されないようになりました。
    文字列でサウンドなどをコールしない場合に出力しないようにすれば、サウンドアーカイブのサイズを削減することができます。

  • (コンバータ) キャッシュ出力に関する仕様を変更しました。

    • 中間バイナリファイルは、必ずキャッシュフォルダに出力するようになりました。
    ただし、SMFから作成される中間テキストシーケンスサウンド(.cseq)、バンクのインクルードファイル(.cinl)は、従来通りソースファイルと同じ場所に出力されます。

  • (コンバータ) サウンドアーカイブマップファイルの仕様を変更しました。

    • コンバート時に生成されるサウンドアーカイブマップファイルのフォーマットを、テキスト形式からHTML形式に変更しました。

  • (コンバータ) ウェーブサウンドセット、シーケンスサウンドセットへの ID を付与するようにしました。

    • ウェーブサウンドセットおよびシーケンスサウンドセットにアイテムID が付与されるようになりました。
    この変更に伴い、これらのアイテムを指定したロードが可能になります。

  • (コンバータ) アイテムID の仕様を変更しました。

    • 各種サウンド（シーケンスサウンド、ウェーブサウンド、ストリームサウンド）および、シーケンスサウンドセット、ウェーブサウンドセット、バンク、波形アーカイブ、グループ、プレイヤーの各 ID の上位 8 bit に、アイテムカテゴリを示す情報を埋め込むようになりました。


はじめに

このマニュアルについて

このマニュアルは、NW4C SoundMaker（以下 SoundMaker）の使用方法について解説しています。
SoundMaker を利用する際には、このマニュアルを活用してください。

※ Viewer の機能は現バージョンでは実装されておりません。

マニュアルの表記規則

このマニュアルで記述されている表記規則について説明します。

メニューの表記

メニューとメニュー項目は、[メニュー名]→[メニュー項目名] と表記します。
例として、「ファイル」メニューの「開く」項目を示す場合は、[ファイル]→[開く] となります。

キーバインディングの表記

複数のキーを同時に使うキーバインディングは、＋マークで表記します。
例として、Ctrl キーを押しながら S キーを押す場合は、Ctrl+S となります。


SoundMaker の紹介

SoundMaker は、NintendoWare サウンド開発環境用のサウンドデータを作成する Windows アプリケーションです。

SoundMaker の概要

NintendoWare サウンド開発環境では、サウンドデータは通常、サウンドアーカイブと呼ばれるひとつのバイナリファイルとして扱います。
サウンドアーカイブの素材となるサウンドデータは、使いなれた波形編集ツールや、シーケンサで作成を行います。SoundMaker はこれらの素材から NintendoWare サウンド開発環境のランタイムライブラリが利用可能な、サウンドアーカイブを作成します。
SoundMaker は Viewer と MCS に対応し、PC に接続された実機でサウンドの確認を行う事ができます。また PC 本体でもエミュレーションにより作成中のサウンドの一部を確認する事ができます。

SoundMaker の実機再生は、SoundPlayer と呼ぶサウンド専用のプログラムでも行なう事ができます。

SoundMaker の主な機能

SoundMaker の主な機能を以下に示します。

サウンドプロジェクトの作成とサウンドアーカイブの出力

SoundMaker のプロジェクトをサウンドプロジェクトと呼びます。サウンドプロジェクトにはその参照としてサウンドセットと呼ばれるサウンドの集まりを複数参照として作成できます。ひとつのサウンドプロジェクトはひとつのサウンドアーカイブに対応しています。
サウンドプロジェクトは拡張子 .cspj のファイル（以後サウンドプロジェクトファイルと表記します）に、サウンドセットは拡張子 .csst のファイル（以後サウンドセットファイルと表記します）に、各々保存されます。

ストリームサウンドの作成

サウンドセットで作成します。素材となる波形ファイルは既存の波形編集アプリケーションや DAW ソフトで、AIFF か WAV 形式のファイルを用意してください。
波形データはステレオ、またはモノラルで 16bit と 8bit、サンプリングレートは任意に選択ができます。ストリームサウンドは snd ライブラリ で再生する際に、ディスクから必要最小限のデータを読みながら再生されます。

ウェーブサウンドの作成

サウンドセットで作成します。ウェーブサウンドはウェーブサウンドセットと呼ばれるグループを作成し、各ウェーブサウンドセットに作成を行います。ウェーブサウンドの素材となる波形データはストリームサウンドと同様です。
ウェーブサウンドは snd ライブラリ で再生する際に、波形データをウェーブサウンドセット単位で一度メモリにロードしておく必要があります。

シーケンスサウンドの作成

サウンドセットで作成します。素材となるシーケンスデータは、標準 MIDI ファイルとテキストで書かれたテキストシーケンスファイル（拡張子 .cseq）に対応しています。
標準 MIDI ファイルはお使いのシーケンサで、テキストシーケンスファイルはお使いのテキストエディタで用意してください。各ファイルで対応するコントロールチェンジやシーケンスコマンドと呼ばれるテキストシーケンスファイルの記述方法については、別途用意されているシーケンスデータマニュアルで解説しています。

バンクの作成とシーケンスサウンドへの指定

サウンドセットで作成を行い、作成した各シーケンスサウンドに対して指定します。バンクはシーケンスサウンドが発音する際の音色として機能します。
素材となるバンクデータは、専用のバンクファイル（拡張子 .cbnk）に対応しています。

バンクファイルの編集

バンクタブで編集を行います。バンクタブはバンクの素材となるバンクファイルの編集を専門に行うメインウインドウ内のペインです。バンクファイルにはインストルメントと呼ぶ音色を複数作成可能で、このインストルメントをインストリストと呼ぶリストに配置し、MIDI のプログラムチェンジに対応するプログラム番号を定義します。
インストルメントはその素材として波形ファイルを参照します。素材となる波形データはストリームサウンドやウェーブサウンドと同様です。
ウェーブサウンドと同様に、バンクは snd ライブラリ で再生する際に、波形データをインストリスト単位で一度メモリにロードしておく必要があります。

3D サウンドの作成

サウンドセットで行います。各サウンドに対して、3D サウンドを使って再生された時の動作を設定します。

プレイヤーの作成と各サウンドへの指定

サウンドセットで作成を行い、各サウンドに対して指定します。

グループの作成とグループへのサウンドデータの登録

サウンドセットで作成を行い、作成したグループに対して各サウンドをアイテムとして登録します。
snd ライブラリ は各サウンドが再生に必要な再生データや波形データを、グループ単位でメモリにロードします。

既存ファイルフォーマットのインポート

DLS ファイルと、拡張子 .stxt の効果音定義ファイル（以後 .stxt ファイルと表記します）をサウンドプロジェクト内にインポートします。
.stxt ファイルは、GAMECUBE 向けに提供されていた開発環境である sysdolphin のオーディオライブラリが利用していた効果音定義ファイルの名称です。この機能は sysdolphin で作られたゲームプロジェクトを CTR に移植する際に利用します。

サウンドアーカイブの作成

サウンドプロジェクトと各参照ファイルから、専用のコンバータを使ってサウンドアーカイブを作成します。

PC エミュレーションによる音の確認

SoundMaker はインストルメントの PC エミュレーションによる再生をサポートします。これにより実機開発機材(PARTNER-CTR Debugger) の無い環境でも、ある程度の音の確認が可能となります。
PC エミュレーションは PC に接続された MIDI 信号による再生も可能です。

SoundPlayer を起動して実機での音の確認

SoundMaker は作成したサウンドアーカイブをツール内部から SoundPlayer を起動して確認する事ができます。

Viewer による実機での音の確認

SoundMaker は作成したサウンドアーカイブを Viewer に転送し、確認する事ができます。


動作条件

SoundMaker は、Windows XP SP3 (32-bit) および Windows 7 (64-bit) と Microsoft .NET Framework 3.5 SP1 の動作条件で動作確認を行っています。

SoundMaker を起動するには、Microsoft 社の .NET Framework 3.5 SP1 が必要です。
Ver3.5 SP1 以外の .NET Framework を使用した場合の動作の保証はできませんのでご注意ください。

オペレーティングシステムの画面設定で、「通常のサイズ(96 DPI)」以外のDPIを選択すると、SoundMakerの表示が、正しく行われない可能性があります。
DPIの設定は、コントロールパネルの【画面】から、[設定]→[詳細設定]により確認する事ができます。


準備

このセクションでは、NintendoWare のセットアップ以外に必要な、SoundMaker を使うための準備を解説します。


ハードウェア

PC エミュレーションによるインストルメントの確認を行う場合には、SoundMaker を起動する PC にサウンドカードが必要です。

SoundPlayer による実機での音の確認を行う場合には、別途 PARTNER-CTR Debugger のセッティングを行ってください。
Viewer による実機での音の確認は、現在未対応です。


基本編（クイックスタート）

このセクションでは、SoundMaker を初めて使う人を中心に、必要最小限の知識と、簡単な始め方を解説します。


SoundMaker の起動

SoundMaker の起動方法

%NW4C_ROOT%\tools\SoundMaker\NW4C_SoundMaker.exe を実行し、アプリケーションを起動します。

SoundMaker の起動は、この後で解説するサウンドプロジェクトファイル（拡張子 .cspj）のダブルクリックでも行なうことができます。


初期設定ファイル

初期設定ファイルとは？

SoundMaker は、初めて起動された時に %NW4C_ROOT%\tools\SoundMaker フォルダに NW4C_SoundMaker.xml という名前のファイルを作成します。
このファイルを初期設定ファイルと呼びます。

初期設定ファイルの役割

SoundMaker は作業中の各種動作設定などの情報を、この初期設定ファイルに保存します。
例えば、一度開いたプロジェクトファイルの情報は初期設定ファイルに保存され、次回から[ファイル]→[最近使ったプロジェクト] で同じファイルを開くことができます。

初期設定ファイルを削除してしまった場合など、起動時に初期設定ファイルが無い場合には、SoundMaker は改めて新しい初期設定ファイルを作成し、各種設定は初期状態に戻ります。
再インストールを行う前には初期設定ファイルのバックアップを取ることをおすすめします。


サンプルを利用する

とにかく早く SoundMaker の機能を試したい場合には、サンプルを使うのが良い方法です。

SoundMaker にはサンプルが付属しています。このサンプルには、全てのサウンドと、サウンドアーカイブを作成するのに十分な設定を行った、ごく小さなサウンドプロジェクトで構成されています。

サンプルの使い方

サンプルは %NW4C_ROOT%\SampleData\Sound\Projects にあります。
[ファイル]→[プロジェクトを開く…] を実行し、%NW4C_ROOT%\SampleData\Sound\Projects\simple にある simple.cspj を指定してください。


ウインドウ内のペインの種類と役割

このセクションでは、SoundMaker で表示されるウインドウの各ペインと、その役割について解説します。


メインウインドウ

メインウインドウとは？

SoundMakerの起動直後に現れるウインドウを、メインウインドウと呼びます。
このウインドウが SoundMaker の作業領域となり、各ペインまたはタブを切り替えて作業します。

ステータスバー

メインウインドウの最下部にはステータスバーがあります。

この部分には、SoundMaker上で選択されたアイテムに対応するプロジェクトファイルや、アイテムが参照する波形ファイルなどが、実際に存在するファイルパスを表示します。

パスの表示は以下の場所について行います。

    ○プロジェクトツリー
        ・プロジェクトノード
        ・サウンドセットノード

    ○サウンドセットタブ
        ・ストリームサウンドリスト
        ・ウェーブサウンドリスト
        ・シーケンスサウンドリスト
        ・バンクリスト

    ○バンクタブ
        ・インストリスト
        ・サンプルマップ
        ・パーカッションリスト


プロジェクトツリー

プロジェクトツリーとは？

SoundMaker にサウンドプロジェクトを読み込むと、ウインドウ内左側に最初に現れるペインをこのように呼びます。

プロジェクトツリー内には、サウンドセット毎に

  • ストリームサウンド
  • ウェーブサウンドセット
  • シーケンスサウンド
  • シーケンスサウンドセット
  • バンク
  • 波形アーカイブ
  • プレイヤー
  • グループ

の8つの基本“ノード”が表示されます。

プロジェクトツリーを表示させる

プロジェクトツリーは、SoundMaker にサウンドプロジェクトを読み込むと自動的に表示されます。


プロジェクトタブ

サウンドセットタブ

サウンドセットタブとは？

メインウインドウ内右側にサウンドセットを表示するタブをこのように呼びます。
サウンドセットには 8 種類の構成要素があり、これらのノードをプロジェクトツリーでダブルクリック（サウンドセットタブが開いている時はシングルクリック）することで表示、編集を行います。

サウンドセットタブの役割

サウンドセットファイル（拡張子 .csst）の編集を行います。
サウンドセットタブは、SoundMaker での作業の中心になる部分で、各種サウンド、プレイヤー、グループなどのアイテムを作成します。

サウンドセットタブは、サウンドセット（サウンドセットファイル）毎に対応したタブを開き、タブに表示する内容はそのサウンドセット内で切り替わります。
また、タブのタイトルには、リストの種類とサウンドセット名が表示されます。

    リスト種類の表記は以下のようになります。
      STRM　＝　ストリームサウンド
      WSDSET　＝　ウェーブサウンドセット
      SEQ　＝　シーケンスサウンド
      SEQSET　＝　シーケンスサウンドセット
      BANK　＝　バンク
      WARC　＝　波形アーカイブ
      PLAYER　＝　プレイヤー
      GROUP　＝　グループ


バンクタブ

バンクタブとは？

シーケンスサウンドが利用する、音色データの編集を行うタブをこのように呼びます。

バンクタブを表示させる

バンクタブを表示させるには以下の方法があります。

    ・プロジェクトツリーからバンクノードを選択し、サウンドセットタブ内のバンクリストのインデックスセルをダブルクリックする。
    ・バンクリストで、選択したバンク項目の右クリックにより現れるコンテキストメニューの、「参照ファイルを開く」を実行する。
    ・プロジェクトツリーのバンクノードを展開した、子ノードをダブルクリックする。

バンクタブは、各バンクファイルに対応したタブを開き、タブに表示する内容はサウンドセットタブと異なり、常時固定となります。

バンクタブの役割

バンクファイル（拡張子 .cbnk）の編集を行います。
バンクファイルへのインストルメントの追加やプログラムナンバーの指定。インストルメントのリージョンの作成やエンベロープの指定などを行います。


サブウインドウ

サブウインドウとは？

プレビュープレイヤーウインドウ、パラメータパネルウインドウ、検索結果ウインドウなど、補助的な機能のウインドウをこのように呼びます。

サブウインドウには以下の種類があります。

  • プレビュープレイヤー
  • プレビューバンク
  • シーケンス変数
  • コンバートログ
  • 検索結果
  • パラメータパネル

サブウインドウを表示させる

サブウインドウは、メインウインドウの[表示]メニュー、またはツールバーのボタンから開くことができます。

各種サブウインドウについて、メインウインドウ内（メインフレーム）にくっつけて表示する "ドッキング" と、メインフレームの外に出して表示する "フローティング" の２つの表示方法を自由に切り替えることができます。

ドッキング時、「プレビュープレイヤー」・「プレビューバンク」・「コンバートログ」・「検索結果」はメインウインドウ下部に、「シーケンス変数」・「パラメータパネル」は、サウンドセットタブ（バンクタブ）右側に表示されます。

サブウインドウのタイトルバーまたはタブ部分のコンテキストメニューから、各ウインドウを [フローティング]・[ドッキング]・[非表示] に変えることができます。
また、タイトルバー部分もしくはタブ部分のダブルクリックでも [フローティング]・[ドッキング] の切り替えが行えます。

ドッキング状態の時は、タイトルバー右側のボタンもしくは、境界線をダブルクリックすることにより、タブ表示のみの最小化表示にすることができます。
最小化表示時のタブ部分のダブルクリックでは、[フローティング]・[ドッキング] の切り替えではなく、元のウインドウサイズ表示に戻ります。


サウンドプロジェクトの作成

このセクションでは、SoundMaker を使いはじめる時、最初に必ず必要となるサウンドプロジェクトの作成方法について解説します。
サウンドプロジェクトは、ひとつのサウンドプロジェクトファイル（拡張子 .cspj）、そこに参照登録されたひとつ以上のサウンドセットファイル（拡張子 .csst）によって構成されます。


サウンドプロジェクトの作成

サウンドプロジェクトとは？

サウンドプロジェクトは SoundMaker のプロジェクトファイルです。SoundMaker で作業を始める時に、まず最初にサウンドプロジェクトの作成が必要となります。

サウンドプロジェクトは、ひとつのサウンドプロジェクトファイル（拡張子 .cspj）と、ひとつ以上のサウンドセットファイル（拡張子 .csst）によって構成されます。
サウンドの作成など実際の作業は、主にサウンドセット（サウンドセットファイル）に対して行います。サウンドセットファイル単位でサウンドをカテゴリ毎に分類したり、複数のスタッフが担当したりする事ができます。

サウンドプロジェクトの作り方

[ファイル]→[プロジェクトの新規作成] を実行します。
新規プロジェクト作成ウィザードが開始されますので、ガイダンスに従ってサウンドプロジェクトを作成します。

新規プロジェクト作成ウィザード

最初に「プロジェクト名」と「パス」を指定します。
ここで指定する「プロジェクト名」がサウンドプロジェクトファイル名となり、同時にコンバート時のサウンドアーカイブのファイル名となります。
「サウンドセットを新規に作成する」を選択する事で、サウンドプロジェクトと同時にサウンドセットを作成する事ができます。
既に作成済のサウンドセットファイルを使用する時には「既存のサウンドセットを指定する」を選択してください。

全ての指定が終わったら「完了」ボタンを押して、サウンドプロジェクトを作成します。


サウンドセットの作成

サウンドセットとは？

サウンドアーカイブを作成するために必要な全ての情報を集めた「小規模なまとまり」をサウンドセットと呼びます。サウンドの作成など実際の作業は、主にサウンドセットで行います。
サウンドセットはサウンドセットファイル（拡張子 .csst）に保存され、サウンドプロジェクトには複数のサウンドセットファイルを参照として登録する事ができます。

サウンドセットの作り方

サウンドプロジェクトの作成時に、新規プロジェクト作成ウィザードで「サウンドセットを新規に作成する」を選択していた場合には、既にサウンドセットが作成されていますので、この手順はスキップする事ができます。

サウンドセットファイルを新たに作成する

[プロジェクト]→[サウンドセットの追加]→[新しいサウンドセット…] を実行します。
「サウンドセットの新規作成」ダイアログが表示されますので、サウンドセット名とサウンドセットファイルのパスを指定してください。
入力したサウンドセット名をファイル名として、指定したパスにサウンドセットファイルが作成され、同時に作成したサウンドセットファイルが新たにサウンドプロジェクトに参照として登録されます。

既に存在するサウンドセットファイルを利用する

既に作成してあるサウンドセットファイルを利用する場合には、[プロジェクト]→[サウンドセットの追加]→[既存のサウンドセット…] を実行します。
ダイアログでサウンドプロジェクトに登録したいサウンドセットファイルを選択してください。
指定したサウンドセットファイルが、サウンドプロジェクトに参照として登録されます。

サウンドセット名について

サウンドセット名には、コメントと同様に日本語を含むすべての文字が利用可能です。
（ただし「\, /, :, *, ?, ", <, >, |」これらの文字を除きます）
他のアイテム名は、半角英数字とアンダーバー [a-zA-Z0-9_] のみ使用可能です。
（ただし名前の先頭には数字は使えません）
この名前は、HTMLサウンドリストに出力されます。

プロジェクトツリーにおいてサウンドセット名を変更できます。


サウンドセットの構成要素

サウンドセットの構成要素を解説します。

ストリームサウンド（STRM）

DVD からのソフトウェアストリーミングによって、音を再生するサウンドをこのように呼びます。
素材として外部の波形ファイルを参照します。

ストリームサウンドは、大容量の波形ファイルを使った、BGM などの再生に適しています。

ウェーブサウンド（WAVESOUND）

メモリにロードした波形データを使って、音を再生するサウンドをこのように呼びます。
素材として外部の波形ファイルを参照します。

ウェーブサウンドは、ワンショットの波形ファイルなどを使った、効果音の再生に適しています。

シーケンスサウンド（SEQ）

シーケンス（MIDI）の演奏情報と、メモリにロードした音色（バンク）を使って、音を再生するサウンドをこのように呼びます。
素材としてシーケンサなどで作成した外部の標準 MIDI ファイル、またはテキストエディタで作成したテキストシーケンスファイルを参照します。

シーケンスサウンドは、テンポ変化などの操作に自由度が高く、BGM や音楽的な効果音の再生に適しています。

バンク（BANK）

シーケンスが利用する音色をこのように呼びます。
素材として SoundMaker で作成したバンクファイルを参照します。

波形アーカイブ（WARC）

複数の波形データを 1 つにまとめたものをこのように呼びます。
波形データはバンクデータに比べて、非常にデータサイズが大きくなるため、バンクデータと波形アーカイブは別々に扱います。
別々に扱えるので、メモリを効率的に使うことができます。

プレイヤー（PLAYER）

ストリーム、ウェーブ、シーケンスなどのサウンドの再生をコントロールする概念をこのように呼びます。
全てのサウンドには、プレイヤーの指定が必ず必要です。

プレイヤーにはサウンドリミットを指定する事が可能です。このサウンドリミットの値によって、同じプレイヤーの指定したサウンドの再生数などを制御できます。

グループ（GROUP）

シーケンスサウンド（バンク）やウェーブサウンドなどは、再生時に波形データや再生データをメモリにロードする必要があります。
グループは、サウンドセットに含まれるこれらのアイテムを登録して、ひとまとめにする事ができます。
アプリケーションでは、このグループ単位でメモリへの波形データや再生データのロードを行います。

SoundMaker でのみ音を確認する場合には、グループの作成や、グループへのアイテムの登録は必須ではありません。


サウンドの作成

このセクションでは、実際のサウンドの作成方法を解説します。


各サウンドに共通で必要な手順

このセクションでは、全てのサウンドの作成に共通で必要な手順を解説します。
どのサウンドを利用する場合も、このセクションの内容は必ず必要となります。


プレイヤーの作成

プレイヤーとは？

SoundMaker で作成する全てのサウンドは、最終的にアプリケーションにおいて snd ライブラリ で再生される時に、プレイヤーと呼ばれる仕組みで管理されます。

プレイヤーは SoundMaker で作成します。全てのサウンドに対して必ず何らかのプレイヤーの設定が必要です。このため新たに作成したサウンドプロジェクトとサウンドセットに対して、サウンドを新たに作成する場合には、先に必ずプレイヤーを用意しておく必要があります。

プレイヤーの表示

プレイヤーの作成と編集は、サウンドセットタブのプレイヤーリストで行ないます。
プロジェクトツリーのプレイヤーノードをダブルクリック（サウンドセットタブが開いている時はシングルクリック）してください。この時サウンドセットタブに表示されるのがプレイヤーリストです。

プレイヤーの作り方

サウンドセットタブにプレイヤーリストを表示し、プレイヤーリスト領域をクリックしリスト側にフォーカスを移して、メニューの[プロジェクト]→[アイテムの追加]→[プレイヤー…] を実行します。
「プレイヤーの新規作成」ダイアログが表示されますので、必要な項目を入力します。


素材の用意

SoundMaker は、一般的なフォーマットで作成された波形データや標準 MIDI ファイルを素材として、各サウンドの作成を行います。素材は普段使いなれたシーケンサや波形編集ツールで作成してください。
このセクションでは、SoundMaker が素材として使う事ができる各ファイルの形式について解説します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

波形ファイル

波形ファイルは、全てのサウンドを作る際に必要な素材です。

波形ファイルの形式

以下の条件を満たす波形ファイルを用意してください。

ファイルフォーマット　…　AIFF（拡張子 .aif, .aiff） または WAV(拡張子 .wav)
チャンネル数　…　ステレオ または モノラル
ビット数　…　8bit または 16bit
サンプルレート　…　任意

ループの指定方法

波形ファイルでは、マーカーによって各ファイルに一組のループを指定する事ができます。

MIDI ファイル

MIDI ファイルはシーケンスサウンドを作る際に必要な素材です。

MIDI ファイルの形式

タイプ 0、またはタイプ 1 の標準 MIDI ファイル（拡張子 .mid）を用意してください。
ファイル中で有効なコントロール等については「シーケンスデータマニュアル」（Sound_SequenceFileFormat.pdf）を参照してください。

テキストシーケンスファイル

テキストシーケンスファイル（拡張子 .cseq）は、シーケンスコマンドと呼ばれるテキストによって記述される NintendoWare サウンド開発環境専用のシーケンスファイルです。
MIDI ファイルでは難しい、より高度な制御が必要なシーケンスサウンドを作る際に必要な素材です。

テキストシーケンスファイルの作成方法と、シーケンスコマンドの解説については「シーケンスデータマニュアル」（Sound_SequenceFileFormat.pdf）を参照してください。


ストリームサウンドの作成

このセクションでは、ストリームサウンドの作成方法を解説します。
ストリームサウンドを利用しない方は、このセクションは読み飛ばして構いません。


ストリームサウンドの作成

ストリームサウンドリストの表示

ストリームサウンドの作成と編集は、サウンドセットタブのストリームサウンドリストで行ないます。
プロジェクトツリーのストリームサウンドノードを選択してください。この時に表示されるリストをストリームサウンドリストと呼びます。

ストリームサウンドの新規作成

ストリームサウンドを新規作成、または追加する場合は、ストリームサウンドリストを表示させサウンドセットタブ内のリスト領域にフォーカスを移してから、[プロジェクト]→[アイテムの追加]→[ストリームサウンド…] を実行します。
「ストリームサウンドの新規作成」ダイアログが表示されますので、必要な項目を入力します。
パスにファイルを指定すると、「ファイル名から作成」ボタンがアクティブになります。


ウェーブサウンドの作成

このセクションでは、ウェーブサウンドの作成方法を解説します。
ウェーブサウンドを利用しない方は、このセクションは読み飛ばして構いません。


ウェーブサウンドの作成

ウェーブサウンドセットとウェーブサウンド

ウェーブサウンドの作成は、ウェーブサウンドセットの作成と、作成したウェーブサウンドセットに対するウェーブサウンドの作成の 2 段階の操作で行います。
最初にウェーブサウンドセットを作成し、作成したウェーブサウンドセットに対してウェーブサウンドを作成します。

ウェーブサウンドは、コンバート時に各ウェーブサウンドの使う波形データを、ウェーブサウンドセット単位でまとめます。
実際にサウンドとして再生されるのはウェーブサウンドですが、ウェーブサウンドの波形データは、ウェーブサウンドセット単位でメモリにロードされます。

ウェーブサウンドの表示

ウェーブサウンドの作成と編集は、サウンドセットタブのウェーブサウンドセットリストとウェーブサウンドリストで行ないます。
プロジェクトツリーのウェーブサウンドセットノードをクリックしてください。サウンドセットタブに上下に分割された 2 種類のリストが表示されます。
このうち上領域をウェーブサウンドセットリスト、下領域をウェーブサウンドリストと呼びます。

ウェーブサウンドセットの作成

ウェーブサウンドセットの作成は、サウンドセットタブ内のリスト領域をクリックしフォーカスを移して、メニューの[プロジェクト]→[アイテムの追加]→[ウェーブサウンドセット…] を実行します。
「ウェーブサウンドセットの新規作成」ダイアログが表示されますので、必要な項目を入力します。

ウェーブサウンドの作成

ウェーブサウンドの作成は、ウェーブサウンドリストで行ないます。

プロジェクトツリーでウェーブサウンドセットノードをクリックして、サウンドセットタブの上領域のウェーブサウンドセットリストでウェーブサウンドセットを選択すると、下領域に選択したウェーブサウンドセットに存在するウェーブサウンドが表示されます。

ウェーブサウンドの作成は、作成したいウェーブサウンドセットを選択した状態で、[プロジェクト]→[アイテムの追加]→[ウェーブサウンド…] を実行します。

「ウェーブサウンドの新規作成」ダイアログが表示されますので、必要な項目を入力します。
パスにファイルを指定すると、「ファイル名から作成」ボタンがアクティブになります。


シーケンスサウンドの作成

このセクションでは、シーケンスサウンドの作成方法を解説します。
シーケンスサウンドを利用しない方は、このセクションは読み飛ばして構いません。


バンクの作成

バンクとは？

シーケンスサウンドの作成には、その素材としてシーケンスが参照する音色（プログラム）のセットが必要となります。この音色セットをバンクと呼びます。

バンクはバンクファイル（拡張子 .cbnk）として、SoundMaker 専用の形式で作成し、サウンドセットから参照されます。

バンクには複数のインストルメントを作成し、これらのインストルメントに MIDI のプログラムチェンジに対応する 0 ～ 127 のプログラムナンバーを設定する事ができます。
シーケンスサウンドの作成は、常にバンクの編集と平行して行います。

バンクリストの表示

バンクの新規作成は、サウンドセットタブのバンクリストで行ないます。
プロジェクトツリーのバンクノードを選択してください。この時サウンドセットタブに表示されるリストがバンクリストです。

バンクの新規作成

バンクの新規作成は、バンクリストの表示を選択中に、[プロジェクト]→[アイテムの追加]→[バンク…] を実行します。
「バンクの新規作成」ダイアログが表示されますので、必要な項目を入力します。
パスにファイルを指定すると、「ファイル名から作成」ボタンがアクティブになります。

バンクファイルの編集

バンクファイルの編集は、バンクタブで行ないます。バンクタブはバンクリストで、編集したいバンクの、アイコンが配置されたインデックスセルをダブルクリックして開くか、プロジェクトツリーのバンクファイルをダブルクリックして開く事ができます。

バンクタブは上下に分割されています。上領域をインストリストと呼び、ここでインストルメントの作成やプログラムナンバーの指定などを行ないます。
バンクタブの下領域は、さらに2つのタブで「サンプルマップ」と「パーカッションリスト」に表示を切り替える事ができます。いずれもインストルメントのリージョンの編集を行ないます。

バンクタブの操作については、【応用編】で詳しく解説します。


シーケンスサウンドの作成

シーケンスサウンドリストの表示

シーケンスサウンドの作成と編集は、サウンドセットタブのシーケンスサウンドリストで行ないます。
プロジェクトツリーのシーケンスサウンドノードをダブルクリック（サウンドセットタブが開いている時はシングルクリック）してください。この時サウンドセットタブに表示されるのがシーケンスサウンドリストです。

シーケンスサウンドの作成

シーケンスサウンドの作成は、シーケンスサウンドリストを選択して、[プロジェクト]→[アイテムの追加]→[シーケンスサウンド…] を実行します。
「シーケンスサウンドの新規作成」ダイアログが表示されますので、必要な項目を入力します。
パスにファイルを指定すると、「ファイル名から作成」ボタンがアクティブになります。


シーケンスサウンドセットの作成

このセクションでは、シーケンスサウンドセットの作成方法を解説します。
シーケンスサウンドセットを利用しない方は、このセクションは読み飛ばして構いません。


シーケンスサウンドセットの作成

シーケンスサウンドセットとシーケンスサウンド

シーケンスサウンドセットの作成は、最初にシーケンスサウンドセットを作成し、作成したシーケンスサウンドセットに対してシーケンスサウンドを作成する、2段階の操作で行います。
シーケンスサウンドの作成については 『シーケンスサウンドの作成』 および、『バンクの作成』 を参照してください。

シーケンスサウンドセットの表示

シーケンスサウンドセットの作成と編集は、サウンドセットタブのシーケンスサウンドセットリストとシーケンスサウンドリストで行います。
プロジェクトツリーのシーケンスサウンドセットノードをダブルクリック（サウンドセットタブが開いている時はシングルクリック）してください。サウンドセットタブに上下に分割された 2種類のリストが表示されます。
このうち上領域をシーケンスサウンドセットリスト、下領域をシーケンスサウンドリストと呼びます。

シーケンスサウンドセットの作成

シーケンスサウンドセットの作成は、シーケンスサウンドセットの表示を選択して、[プロジェクト]→[アイテムの追加]→[シーケンスサウンドセット…] を実行します。
「シーケンスサウンドセットの新規作成」ダイアログが表示されますので、名前を入力します。


波形アーカイブの設定

このセクションでは、波形アーカイブの作成方法を解説します。
波形アーカイブは、バンクが使用する波形データを格納しまとめたものです。

デフォルトでは自動の設定となっているため、波形アーカイブの設定を変更しない方は、このセクションは読み飛ばして構いません。


波形アーカイブの設定

波形アーカイブとは？

波形アーカイブとは、複数の波形データを１つにまとめたものです。

波形データはバンクデータに比べて、非常にデータサイズが大きくなるため、バンクデータと波形アーカイブは別々に扱います。
別々に扱えるので、メモリをより効率的に使うことができるようになりますが、１つのバンクを登録するためには、バンクの登録と波形アーカイブの登録が必要になります。

波形アーカイブの表示

波形アーカイブの設定は、サウンドセットタブの波形アーカイブリストで行います。
プロジェクトツリーの波形アーカイブノードを選択してください。このときサウンドセットタブに表示されるリストが波形アーカイブリストです。

波形アーカイブの作成

波形アーカイブの作成は、波形アーカイブリストでコンテキストメニューの [アイテムの追加] または [アイテムの挿入] を実行します。

「波形アーカイブの新規作成」ダイアログが表示されるので、必要な項目を入力します。


グループの設定

このセクションでは、実際のグループの作成方法を解説します。
グループはアプリケーションでサウンドを再生する時に、波形データのメモリへのロードを効率的に行ないます。


グループの設定

グループとは？

グループはサウンドセットの構成要素のひとつで、作成したサウンドなどの各アイテムを登録して、コンバート時に波形データなどをグループ単位でまとめます。

同じシーンやステージで利用するサウンドを上手くグループに分類して登録する事により、アプリケーションで行なう波形データのメモリへのロードを効率的に行ない、同時にメモリを効率的に利用する事ができます。

グループの設定

グループの設定は、サウンドセットタブのグループリストとグループアイテムリストで行ないます。
設定は最初にグループの作成を行い、次に作成したグループへのアイテムの登録の 2 種類の作業を行います。

グループの表示

プロジェクトツリーのグループノードをダブルクリック（サウンドセットタブが開いている時はシングルクリック）してください。サウンドセットタブに上下に分割された 2種類のリストが表示されます。
分割された上領域にグループの一覧が表示されます。この上領域でグループを選択すると、下領域に登録されたアイテムの一覧が表示されます。
上領域をグループリスト、下領域をグループアイテムリストと呼びます。

グループの作成

グループの作成は、プロジェクトツリーでグループを選択し、サウンドセットタブ側をクリックしてフォーカスを移して、[プロジェクト]→[アイテムの追加]→[グループ…] を実行します。
「グループの新規作成」ダイアログが表示されますので、必要な項目を入力します。

グループへのアイテムの登録

サウンドセットタブの上領域のグループリストでアイテムを登録したいグループを選択します。この状態で、[プロジェクト]→[アイテムの追加]→[グループアイテム…] を実行します。
「グループアイテムの新規作成」ダイアログが表示されますので、登録したいアイテムを選択します。


コンバート

このセクションでは、ここまでの手順で作成したサウンドプロジェクトから、snd ライブラリが利用するバイナリファイルを作成する手順について解説します。


コンバート

コンバートの実行

コンバートの実行

[プロジェクト]→[コンバート] を実行します。
作成したサウンドプロジェクトから、NintendoWare サウンド開発環境用の各種サウンドデータファイルを作成することができます。
この操作で生成されたファイルが、アプリケーションにおいて、NintendoWare サウンド開発環境のランタイムライブラリが扱う全てのサウンドデータとなります。

コンバート中はコンバートダイアログが現れ、コンバータのログメッセージを表示します。
正常なコンバート中は、ダイアログ左上部のアイコンがアニメーションします。

コンバートの警告表示

コンバート時に未参照のアイテムなど不適切と思われる設定があった場合、コンバートダイアログおよびコンバートログウインドウに警告表示をします。

コンバートダイアログでは、エラーの内容が表示され「対象アイテムへ移動」ボタンが有効になります。
「対象アイテムへ移動」ボタンをクリックすると、エラーの起きた選択アイテムの場所に移動します。

コンバートログウインドウについては、「コンバートログ」を参照してください。
また、この警告機能は「プロジェクト設定ダイアログ」において、有効・無効の設定が行えます。


生成されるファイル

このページではコンバートによって生成されるファイルの種類と、それらの出力先を解説します。
ここで解説するファイル一式が、アプリケーションがプログラムでサウンドを鳴らす時に必要なファイルとなります。（html ファイルを除く）

出力先フォルダは、デフォルトで"output"という名前でプロジェクトフォルダ内に作成されますが、「プロジェクト設定ダイアログ」において出力先を変更できます。

サウンドアーカイブファイル

サウンドアーカイブを収めたサウンドデータの本体です。
出力先パスで指定されたフォルダと output フォルダに、サウンドプロジェクトファイルと同名で、拡張子 .bcsar として出力されます。

ストリームファイル

サウンドアーカイブに含まれるストリームサウンドの波形データです。
出力先パスで指定されたフォルダにある output 以下の設定したディレクトリに、ストリームサウンドの参照する波形ファイルと同名で、拡張子 .bcstm として出力されます。

サウンドアーカイブファイルにはストリームファイルの場所が相対パスとして保持されています。output 以下のディレクトリ（パス）は、実際の ROM に配置された場合のパスとなり、サウンドアーカイブがストリームサウンドを鳴らす時に必要な情報となります。

サウンド ID ファイル

サウンドアーカイブに含まれる、全てのアイテム名の一覧を収めたテキストファイルです。
出力先パスで指定されたフォルダに、サウンドプロジェクトファイルと同名で、拡張子 .csid として出力されます。

「プロジェクト設定ダイアログ」で [アイテム別ラベルを出力する] のチェックを ON にすると、ID のヘッダを種類別のファイルに分けて出力します。
個別に出力されるファイルは、以下の 7 種類です。

  • *.BANK.csid
  • *.GROUP.csid
  • *.PLAYER.csid
  • *.SEQSET.csid
  • *.SOUND.csid
  • *.WAVEARCHIVE.csid
  • *.WSDSET.csid

中間バイナリファイル

コンバート時に作成される .bcstm, .bcwar 等の中間バイナリファイルです。
サウンドプロジェクトフォルダ内の "cache"フォルダにまとめて出力されます。

プロジェクト設定により、中間バイナリファイルをキャッシュフォルダに出力するかどうかを設定できます。

再コンバート時には、キャッシュフォルダ内のファイルはすべて削除されます。

HTMLサウンドリスト

コンバートを行ったプロジェクトの内容から、html形式のサウンドリストを自動生成します。
サウンドリストに出力する項目は、プロジェクト設定から自由に選ぶ事ができます。
サウンドプロジェクトフォルダに、サウンドプロジェクトファイルと同名で、拡張子 .html として出力されます。

インストルメントリストのhtml形式ファイルは、コンバート時には出力されません。「HTMLインストルメントリストの出力」を参照してください。

MAPファイル

コンバート時に作成されるサウンドアーカイブマップファイルです。

output フォルダに、サウンドプロジェクトファイルと同名の xml 形式のファイルと、サウンドプロジェクトファイル名の後ろに"Map"を付加した名前の html 形式のファイルとして出力されます。

ファイル内の構成は

  • グループリスト
  • ファイルリスト
  • バイナリマップ

の 3 種類です。

マップファイルから、ROM サイズ、ヘッダサイズ、バンク容量、波形容量（波形アーカイブ容量）などがわかります。
以下に "Binary Map" 項目の Name と各容量の関係の例を示します。

Name | 種類
SoundArchiveBinaryFile | ROM サイズ
InfoBlock | ヘッダサイズ
../cache/BANK_BGM.bcbnk | バンクサイズ
../cache/WARC_SAMPLE.bcwar | 波形アーカイブサイズ


応用編

このセクションでは、SoundMaker の細部にわたる操作方法を解説します。


共通の操作

このセクションでは、SoundMaker で行う各作業における共通の操作や、動作概念を解説します。


リストの操作

サウンドプロジェクトが取り扱うアイテムは、全てサウンドセットタブにリストとして表示され、リストの一行が、ひとつのアイテムに対応します。
ここでは、リストにおける共通の操作について解説します。

インデックスセルの操作

リストの先頭には、アイコンを配置したセルがあります。このセルをインデックスセルと呼びます。

インデックスセルは、リストの行が対応するアイテムの種類を示しています。
リスト自体は表計算ソフトに似た操作でセル単位での操作も可能ですが、インデックスセルにより行単位（アイテム単位）での操作も同時に可能にしています。

インデックスセルをダブルクリックする事により、SoundMaker はアイテムの参照するファイルのタブを開いたり、サウンドのプレビュー再生を行います。
バンクの場合、参照するファイルを新しくタブを開いたり切り替えて表示します。
ストリームサウンドや、ウェーブサウンド、シーケンスサウンドでは、プレビュー機能が働き、PCエミュレーションやViewerへの転送が行われサウンドが再生されます。

インデックスセルをクリックするとその行が選択され、選択行のインデックスセルをドラッグする事により、リスト内で行の移動（並び替え）を行う事ができます。

未選択の行に対してインデックスセルをクリックしたままドラッグすると、その範囲の行が選択状態になります。

グループへの登録／解除

グループに登録可能なアイテムのリストでは、リストのコンテキストメニューからの操作でも、グループにアイテム登録を行なう事ができます。

グループに登録したいアイテムのリストで、右クリックして現れるコンテキストメニューから[グループに登録]を実行します。
専用のダイアログが現れ、全てのグループの一覧が表示されるので、登録したいグループにチェックを入れて、OK を押してください。

既に登録済みのグループには、あらかじめチェックが入っており、そのチェックを外すことによりグループ登録を解除できます。

また、複数アイテムを選択してグループ登録を行った場合、グループに登録されているものと、されていないものが混在したグループには、グレーのチェック表示がされます。
一度グレーのチェックを外すと、キャンセルしない限り、元の混合状態には戻せません。

セルの一括編集

一括編集ダイアログを利用して、複数のセルを一括して編集する事ができます。
編集したい複数のセルを選択して Shift + F2 の操作で、一括編集ダイアログを開く事ができます。

セルに適用したい数値と、数値の適用方法を選択します。

    直接指定　…　指定した数値がそのまま適用されます。
    増減で指定　…　-20 や +150 など、指定した数値が元の値に加算されます。
    割合で指定　…　0.01 や 20.0 など、指定した数値が元の値に倍率として適用されます。

それぞれのセルの上限を超える、または下限を下回る値となる設定は結果に反映されません。

圧縮方式、プレイヤー、バンク等、コンボボックスで編集する項目は、コンボボックスに表示される値をそのまま直接指定で入力することにより、一括編集が可能です。

アイテムの名前については、重複を避けるため複数選択してあっても一番上のセルしか編集できません。

アイテム名の補完

リスト上でプレイヤー、バンク、グループの項目を編集する際に、直接アイテム名を入力できます。
また直接入力時は、前方一致補完が利用できます。

リストの操作

リストは、一般的な表計算ソフトに似た操作が可能です。
主な操作を以下に示します。

リスト操作一覧

キー操作 | 動作
方向キー上 [Up] | 1つ上のセルへフォーカスを移動
方向キー下 [Down] | 1つ下のセルへフォーカスを移動
方向キー左 [Left] | 1つ左のセルへフォーカスを移動
方向キー右 [Right] | 1つ右のセルへフォーカスを移動
Tab | [Right] と同じ
Shift + Tab | [Left] と同じ
Enter | [Down] と同じ
Shift + Enter | [Up] と同じ
スペース | サウンド、インストルメントの再生（再生可能なリストで選択状態時）
F2 | （テキスト入力が可能なセルで）セルを入力状態にする
Shift + F2 | セル（複数セル）の一括編集ダイアログを表示する
Ctrl + A | 全て選択
Ctrl + C | 選択行をコピー
Ctrl + Shift + C | 選択セルをコピー
Ctrl + X | 選択行を切り取り
Ctrl + V | 行の貼り付け または選択セルを基点としてセル貼り付け
Ctrl + Up | 画面表示内の一番端のセルへフォーカスを移動 ただし、既にそのセルにフォーカスがある場合は、PageUp/PageDownと同じ仕様でスクロールする
Ctrl + Down
Ctrl + Left
Ctrl + Right
Shift + Up | 現在のフォーカス位置を基点として、行・セルの矩形選択の終点を移動する （同じ動作をする操作： Shift + 左クリック、またはインデックスセル以外の場所のドラッグによる範囲選択）
Shift + Down
Shift + Left
Shift + Right
Ctrl + Shift + Up | 現在のフォーカス位置を基点として、行・セルの矩形選択の終点を移動する ただし、移動の動作は Ctrl + カーソルキーと同様
Ctrl + Shift + Down
Ctrl + Shift + Left
Ctrl + Shift + Right
Home | 一番左のセルへフォーカスを移動
End | 一番右のセルへフォーカスを移動
Ctrl + Home | 一番上のセルへフォーカスを移動
Ctrl + End | 一番下のセルへフォーカスを移動
Shift + Home | 現在のフォーカス位置を基点として、一番左のセルまでセルを範囲選択
Shift + End | 現在のフォーカス位置を基点として、一番右のセルまでセルを範囲選択
Ctrl + Shift + Home | 現在のフォーカス位置を基点として、一番上のセルまで範囲選択
Ctrl + Shift + End | 現在のフォーカス位置を基点として、一番下のセルまで範囲選択
PageUp | ページ戻し
PageDown | ページ送り
Shift + PageUp | ページ戻し + 現在のフォーカス位置を基点として、セルを範囲選択
Shift + PageDown | ページ送り + 現在のフォーカス位置を基点として、セルを範囲選択
Ctrl + E | 行（アイテム）の参照ファイルを開く
Ctrl + N | アイテムの新規作成
Ctrl + Shift + N | アイテムを挿入して新規作成
Ctrl + D | アイテムの削除
Delete | アイテムの削除
F12 | リストの表示を更新
Ctrl + 左クリック | クリック位置にある行・セルの追加選択
Shift + 左クリック | クリック位置を基点として、行・セルの範囲選択
Shift + マウスホイール | 左右スクロール動作

※ コピー・貼り付け・削除等、一部の操作は、リスト上で右クリックにより現れるコンテキストメニューからも同様に行えます。

タブ操作ショートカット一覧

サブウインドウのショートカットキー操作も含んでいます。
数字キーは、キーボードのテンキーには対応していません。

キー操作 | 動作
Ctrl + TAB | アクティブなタブの順次切り替え（サウンドセットタブの全ビュー、全タブを対象） ビューを分割している場合、ビューをまたいでタブの選択が切り替わる
Ctrl + Shift + TAB | アクティブなタブの逆順次切り替え（サウンドセットタブの全ビュー、全タブを対象） ビューを分割している場合、ビューをまたいでタブの選択が切り替わる
Ctrl + PageUp | アクティブなタブの順次切り替え 同じビュー内でタブの選択が切り替わる
Ctrl + PageDown | アクティブなタブの逆順次切り替え 同じビュー内でタブの選択が切り替わる
Ctrl + 1～8 | アクティブビュー内の左からn番目のタブをアクティブにする
Ctrl + 9 | アクティブビュー内の一番右側のタブをアクティブにする
Ctrl + F4, Ctrl + W | アクティブビューにある選択タブを閉じる
Ctrl + Shift + 1 | プロジェクトツリーにフォーカスを移す
Ctrl + Shift + 2 | サウンドセットタブのアクティブビューにフォーカスを移す ひとつのタブ内で2種類のリストが分割表示されている場合は、上側のリストがフォーカスされる （ビュー分割時のビュー間の切り替えではない）
Ctrl + Shift + 3 | サウンドセットタブのアクティブビューに、ひとつのタブ内で2種類のリストが分割表示されている場合は、下側のリストがフォーカスされる （ビュー分割時のビュー間の切り替えではない）
Ctrl + Shift + 4 | プレビュープレイヤーにフォーカスを移す
Ctrl + Shift + 5 | プレビュープレイヤーパラメータにフォーカスを移す
Ctrl + Shift + 6 | シーケンス変数にフォーカスを移す
Ctrl + Shift + 7 | エフェクトにフォーカスを移す
Ctrl + Shift + 8, Ctrl + I | パラメータパネルにフォーカスを移す
Ctrl + Shift + 9 | コンバートログにフォーカスを移す
Ctrl + Shift + 0 | 検索結果にフォーカスを移す

リスト項目の並び替えと表示／非表示切り替え

並び替え

リストの [名前] や [データサイズ] などの項目は、各項目名をドラッグ＆ドロップすることにより、表示順序を並び替えることができます。

また、下記の【リスト表示項目設定ダイアログ】上での各項目のドラッグ＆ドロップでも同様の並び替え操作が行えます。

表示項目設定

リストの各項目について、各項目の表示／非表示を選択できます。
利用頻度の低い項目を非表示にする事により、リスト項目が多く、横に長くなり一覧性に難が生じてしまうアイテムを見易くします。

サウンドセットタブのリスト項目名の部分を右クリックすることにより現れるコンテキストメニューから、表示・非表示にしたい項目をクリックすることにより、リストの表示に反映されます。

コンテキストメニュー上段の「リスト表示項目の設定...」を選択すると 【リスト表示項目設定ダイアログ】が表示され、表示／非表示の設定を一括して行うことができます。

また、ダイアログリスト内の各項目をドラッグ、もしくは「上へ移動」、「下へ移動」ボタンを押すことにより、表示順序の並び替えを行うことが可能です。

非表示の項目は、セルの範囲選択の対象となりません。
選択セルが非表示にされた場合、選択は解除されます。

表示項目の既定値設定

リストの表示項目について、現在の表示設定をデフォルトの設定とすることができます。

リスト項目名の部分の右クリックにより現れるコンテキストメニューから、「リスト表示項目の既定値に設定」を選択することにより、その時の表示設定を保存します。
保存情報は、"項目の表示/非表示"と"項目の並び順" です。
情報はリスト毎に保存され、設定が行われたプロジェクトで、サウンドセットを追加または新規作成した時に適用されます。

リスト幅の最適化

リストの項目名のセル幅を調整する場所（右境界）でダブルクリックをすると、リストの表示内容に応じてセル幅を最適に調整します。

リストのソート表示

リストの項目名をクリックすると、各項目の内容でリストをソートします。
クリックする度に、昇順・降順・ソート無し(本来の並び) の順で切り替わりソートされ直します。

『インデックスセル』の項目でのソートは、「本来の並び」で表示されます。

「本来の並び」とは、新規に作成したり、インデックスセルをドラッグで並び替えてユーザーが作成した並び順を指します。

ここでの各項目のソートは、表示上の並び替えだけなので、プロジェクトに保存される並びは、「本来の並び」順です。

また、ファンクションキーの F12 で、リストの表示を更新する事ができます。
特定の項目でソートして表示している時に、アイテムの挿入や新規作成を行った場合などに利用します。
この操作で行うのはリストの表示の更新のみです。プロジェクトファイルの更新が必要なケースでは、ファイルメニューの「プロジェクトの再読込」を利用してください。

コピー＆ペースト

キー操作やリスト上の右クリックにより現れるコンテキストメニューから、セル単位または行単位にコピー＆ペースト操作が行えます。

セル単位

セル単位でのコピーは、コンテキストメニューの「セルのコピー」または Ctrl + Shift + C で行います。
コピーしたセルは、破線で囲まれます。

行単位

行単位でコピーした場合は、コンテキストメニューの「項目を選択して貼り付け」が有効になります。
コピー元とペースト先が異なるリストの場合、または複数行をコピーしている場合は、「項目を選択して貼り付け」は無効になります。

貼り付けを実行すると、項目を選択するためのダイアログが表示されます。
上書きしたい項目にチェックを入れ実行します。

アイテムの一時無効化

リスト上でアイテム（行）を無効化することにより、プロジェクトからアイテムを削除することなく、一時的に必要のないものを無効にすることができます。
無効化したアイテムは、コンバートの対象となりませんが、アイテムのパラメータはファイルに保存されますので、簡単に復元させることができます。

設定を行いたい行で、右クリックによるコンテキストメニューから、またはメインウインドウの[編集]メニューから、「アイテムを無効にする」、「アイテムを有効にする」を選択します。
無効化されたアイテムは、テキストがグレー表示に変わります。

無効化の対象は、各種サウンド（ウェーブサウンドセット、シーケンスサウンドセットを含む）、バンク、プレイヤー、グループ、及びインストリストです。

アイテムの色付け

リスト上でアイテム（行）単位に色付けすることができます。

色指定は、選択された行での右クリックによるコンテキストメニューから、またはメインウインドウの[編集]メニューから、「アイテムのカラー」を選択し、サブメニューで色を決定します。

配色の情報は、HTMLサウンドリスト、HTMLインストルメントリストにも反映します。

色付けが行えるのは以下のリストです。
  ・ストリームサウンドリスト
  ・ウェーブサウンドセットリスト
  ・ウェーブサウンドリスト
  ・バンクリスト
  ・シーケンスサウンドセットリスト
  ・シーケンスサウンドリスト
  ・波形アーカイブリスト
  ・プレイヤーリスト
  ・グループリスト
  ・インストリスト

グループアイテムリストは、各アイテムに本来設定されている色が表示されます。

更新点の有無

リストで編集を行い、未保存の更新点があるサウンドセットでは、プロジェクトツリーのサウンドセットノードの右側に 、またバンクはバンクタブのバンクファイル名右側に"＊" を表示して、更新の有無を示します。

アイテムの警告表示

アイテムの参照ラベルのリンクが切れていたり、アイテム名が重複している場合など、リスト上に警告アイコンを表示して注意を促します。


ビューの分割

サウンドセットタブ内のビューは2分割して表示することができます。
ここではビューの分割機能について解説します。

用語解説

・［ビュー］　…　サウンドセットタブとバンクタブのタブコントロールを含む編集画面です。

・［上ビュー、下ビュー、左ビュー、右ビュー］　…　ビューを分割した際の各ビューを指します。

・［アクティブビュー］　…　操作対象となるビューです。最後にフォーカスを持ったビューがアクティブビューとなります。

・［アクティブタブ］　…　アクティブビュー内の選択タブです。ビュー分割時、選択タブは上下（左右）ビューにひとつずつあります。

ビューの分割

ビュー分割

ビューを 上下 または 左右 に２分割できます。

分割は、[ウインドウ]→[上下に分割]、[左右に分割] 、またはツールバーの[上下に分割]、[左右に分割]ボタンにより行います。

シングルビューからのビュー分割直後の動作は、ビューを分割して、新たに開いたビューにアクティブタブと同じタブをもうひとつ開きます。

分割した各ビューは、それぞれ全て同じ仕様かつ独立して動作します。

［上下に分割］

    分割されていない状態　…　現在のビューを上、新しいビューを下に表示します。
    左右分割している状態　…　左ビューを上、右ビューを下に表示します。

［左右に分割］

    分割されていない状態　…　現在のビューを左、新しいビューを右に表示します。
    上下分割している状態　…　上ビューを左、下ビューを右に表示します。

分割解除

ビューの分割を解除するには、消したいビューにあるタブをすべて閉じることにより行います。

タブ上のコンテキストメニューから「すべてのタブを閉じる」を実行することにより、簡易に行うことができます。

タブの操作

タブ操作

同じビュー内で複数のタブが開かれている場合、タブのドラッグ＆ドロップにより、並び替えが可能です。
また、他のビューへの移動はできません。

タブ上を右クリックして現れるコンテキストメニューから、そのタブを 「閉じる」 またはそのビュー内の 「他のタブをすべて閉じる」と 「タブをすべて閉じる」ことができます。
メインメニュー [ウインドウ]→[タブをすべて閉じる] からの操作では、分割表示されている両方の全タブが同時に閉じられます。

マウスの中ボタンクリックで、コンテキストメニューの 「閉じる」 と同操作が可能です。

ショートカットキー

"共通の操作 － リストの操作" の「タブ操作ショートカット一覧」を参照してください。

操作の対象

プロジェクトツリーや検索ウインドウ等にて、タブ表示を切り替える操作が行われた場合、アクティブビューが表示切替の対象となります。

ビューの最小化

分割されたビューを閉じずに最小化することができます。

ビューを分割するとタブ表示エリアの端に現れる [最小化]ボタンを クリックすると、対象のビューはタブ部分の表示だけに縮小されます。
最小化されたビューは、[最小化]ボタンから切り替わった [元に戻す]ボタンをクリックすることにより、元のサイズに戻ります。

[最小化] と [元に戻す] 切り替え動作は、以下の方法でも行えます。

・ビュー分割の境界のスプリッタをダブルクリックする。
・上下分割中に [上下に分割] ボタンをクリックする。
・左右分割中に [左右に分割] ボタンをクリックする。

最小化は、アクティブビューでない方のビューが最小化されます。

最小化されたビューがある状態で、以下の操作を行った場合、ビューは元のサイズに戻ります。

・最小化したビューのタブをダブルクリックする。
・上下分割中に [左右に分割] ボタンをクリックする。
・左右分割中に [上下に分割] ボタンをクリックする。


ファイルについて

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

ディレクトリ名は248文字未満、ファイル名まで含めたパスは260文字未満である必要があります。

プロジェクトファイルの種類

SoundMaker が扱うプロジェクトファイルには、以下の種類があります。

  • サウンドプロジェクトファイル
  • サウンドセットファイル
  • バンクファイル

参照ファイルの種類

SoundMaker がアイテムに参照ファイルとして登録し、再生・コンバートできるファイルには、以下の種類があります。

  • wav ファイル（波形）
  • aiff ファイル（波形）
  • 標準 MIDI ファイル（シーケンス）
  • テキストシーケンスファイル（シーケンス）

上記以外の種類のファイルもアイテムとして登録することができますが、SoundMakerでの再生やコンバートはできません。
アイテムリストのコンテキストメニューから [参照ファイルを開く] を選択することにより、可能であれば対応アプリケーションが開きます。

参照ファイルパスの保存方法

アイテムが参照するファイルパスの保存は、参照するファイルが「サウンドプロジェクトファイルと同じドライブの時」には相対パスで、同じく参照するファイルが「サウンドプロジェクトファイルと違うドライブの時」には絶対パスで行われます。


プロジェクトツリー

このセクションでは、サウンドプロジェクトの概念と、プロジェクトツリーの解説を行います。


概要

プロジェクトツリーの役割

プロジェクトツリーでは、サウンドプロジェクトへのサウンドセットの登録を行います。

また、サウンドセット内の各ノードを選択することにより、タブペインにそのリストを表示します。

サウンドプロジェクトの構造

サウンドプロジェクトには、複数のサウンドセットを登録することができます。
サウンドセットには更にバンクファイルと、各サウンドの素材となる波形ファイル、標準 MIDI ファイルなどを参照として登録することができます。

また、サウンドプロジェクトに未登録のバンクファイルをバンクタブで開き、編集することができます。
SoundMaker上には、登録されて実際にコンバートされるバンクファイルと、ファイルが開かれていても未登録で、コンバートはされないバンクファイルがあることになります。
前者の実際にコンバートされる範囲をプロジェクト、後者の未登録でも表示されているものを含む範囲を、ワークスペースと呼びます。

プロジェクト未登録のバンクファイルの読み込み方法については、「プロジェクト外バンクファイルの読み込み」を参照してください。


キー操作

プロジェクトツリーのキーボード操作

Ctrl + Shift + 1 のショートカットキー操作により、プロジェクトツリーにフォーカスを移すことができます。

プロジェクトツリー内では、キーボード操作により以下の操作が可能です。

  • カーソル上下で、現在選択されているノードの上下移動
  • カーソル左で、ノードを閉じる
    既に閉じていれば、親ノードへ移動
  • カーソル右で、ノードを開く
    既に開いていれば、子ノード1つめに移動
  • Backspace で、ノードを開いたまま親ノードへ移動
  • PageUp/PageDown で、上下スクロール
  • Home/End で、一番上/一番下のノードへ移動
  • Enter で、ダブルクリックと同動作
  • Delete で、選択されたサウンドセットを削除
  • Shift+マウスホイール操作により、左右スクロール動作
  • アプリケーションキーで、コンテキストメニューを表示 （キーボードの種類によります）


ツリー表示

タブとの同期

[表示]→[ツリーをタブに同期] を実行することにより、プロジェクトツリーのノード選択をタブに同期させることができます。

サウンドセットタブがアクティブな時の動作

アクティブなサウンドセットタブで現在表示されているリストに対応するプロジェクトツリーのノードを、選択状態にします。
操作を行った後のフォーカスは、ツリーに移動します。
対応するツリーのノードが、閉じていたり、プロジェクトツリーで非表示の位置にある場合、ノードを開き、スクロールして画面内に表示します。
対応するツリーのノードが特定出来ない場合（タブを１つも開いていない時）は、何も起きません。

バンクタブがアクティブな時の動作

アクティブなバンクタブを開いた場所に対応するプロジェクトツリーのノードを選択状態にします。
バンクタブを開いたまま、もとのバンクアイテムがサウンドセットから削除された場合は、何も起きません。
同じバンクファイルを参照するバンクから、タブを開き直した場合は、後から開いた方に同期します。（最も直前にアクセスされたバンクノードに同期）
その他の動作は、サウンドセットタブと同様です。

表示フィルタ

サウンドセットの子ノードについて、未使用のノードをプロジェクトツリー上で非表示にできます。

プロジェクトツリーのサウンドセットノードで、右クリックによるコンテキストメニューから「空のノードを隠す」を選択することにより、トグルで表示/非表示の設定を行います。

非表示の設定中、未使用のノードにアイテムが追加された場合、該当するノードのツリー表示は直ちに復活します。
ただし、表示を復活する時、該当するノードの親ノードが閉じていたり、画面外にある場合、自動的にノードを開いたり、スクロールしたりはしません。
表示/非表示の設定は、サウンドセット単位で、プロジェクトのsettingファイルに保存されます。

全ノードを閉じる

プロジェクトツリー内で、右クリックによるコンテキストメニューから「すべて折りたたむ」を選択することにより、プロジェクトツリーの全ノードが閉じて折りたたまれます。

プロジェクトツリーは、デフォルト設定ではすべて展開して表示されるため、サウンドセットが数多くある場合、作業が煩雑になることがあります。
そのような時に、「すべて折りたたむ」で一度全ノードを閉じ、必要なサウンドセットのみ開いて作業を行うようにしてください。

最小化表示

プロジェクトツリーのタイトルバー右側にある最小化ボタンをクリックすることにより、プロジェクトツリーをタブ部分のみの表示に最小化することができます。

元のサイズに戻すには、タブの上にあるボタンをクリックするか、タブのダブルクリックにより行います。


サウンドプロジェクトの応用例

サウンドプロジェクトを使った共同作業の例

サウンドプロジェクトを使った共同作業の例

サウンドプロジェクトとサウンドセットの利用方法は自由です。ひとりでプロジェクトの作成を行う場合には、ひとつのサウンドプロジェクトとひとつのサウンドセットで作業を行っても問題はありません。

ひとりで進めるプロジェクトの場合でも、サウンドの目的別にサウンドセットを分類したり、また複数のスタッフで進める大規模なプロジェクトでは、サウンドセットファイルを他の SoundMaker の利用者と共有する事で、共同作業を行う事もできます。

サウンドプロジェクトによる共同作業の例

以下に複数のサウンドプロジェクトにおいて、サウンドセットファイルを共有した共同作業の概念図を例として示します。


サウンドセットタブ

このセクションでは、サウンドセットの概念とサウンドセットタブの解説を行います。


概要

サウンドセットタブの役割

サウンドセットタブは、サウンドセットファイル（拡張子 .csst）の編集を行うペインです。
各サウンドの作成など、SoundMaker の主な作業はほとんど全てこのタブ(ペイン)で行われます。

サウンドセットの構造

サウンドセットには、サウンドアーカイブに必要な全ての要素が含まれています。各要素はプロジェクトツリーのノード選択によって表示を切り替える事ができます。
ここから後のセクションで、各要素の詳しい解説を行います。


ストリームサウンド

プロジェクトツリーで、ストリームサウンドのノードを選択することで、サウンドセットタブにストリームサウンドを表示することができます。
この時表示されるリストを、ストリームサウンドリストと呼びます。

ストリームサウンドの新規作成と追加

ストリームサウンドを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[ストリームサウンド…] を実行します。

ストリームサウンドリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、ストリームサウンドを新規作成または追加することができます。

ストリームサウンドの編集

ストリームサウンドの編集はストリームサウンドリストで行います。
ストリームサウンドリストの各列はストリームサウンドに必要な定義要素で、サウンドアーカイブのストリームサウンドのデータに必要な各要素に対応しています。

ストリームサウンドリストの定義要素

ここではストリームサウンドリストの各定義要素の意味を解説します。

再生

ボタンをクリックすると、プレビュープレイヤーに登録され、ストリームサウンドがトリガ再生されます。

名前

ストリームサウンドの名前を指定します。この名前は最終的に作成されたサウンドアーカイブを利用して、プログラムが snd ライブラリ でストリームサウンドを鳴らす時の名前になります。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

圧縮方式

コンバータが参照波形ファイルをコンバートする際の圧縮方法を指定します。

  • ADPCM

    • 波形ファイルを専用のADPCM形式にコンバートします。
    圧縮によりループの先頭が、ブロックの先頭に自動的に移動されますので、ループ位置のタイミングを利用した再生制御を行う場合などには注意が必要です。
  • PCM16

    • 16bitのPCMデータにコンバートします。
  • PCM8

    • 8bitのPCMデータにコンバートします。

ファイルパス

ストリームサウンドを作成する際に参照する波形ファイルを指定します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

再生時間

サウンドの再生時間（波形データ長の時間）を表示します。
表示単位は［分：秒．ミリ秒］で、「ミリ秒」は 3 桁目を四捨五入し、2 桁表示となります。

音量

ストリームサウンドを snd ライブラリ が鳴らす時のボリュームを 0 ～ 255 の範囲で指定します。

サウンドデータの音量を 127 にすると、元データと等倍の音量 (1.0倍) で再生されます。

ただし、音量は、いろいろな場面 (データやプログラム) で設定されます。
すべての設定値が掛け合わされた結果、元音量から比べて、0.0 倍 ～ 2.0 倍にクランプされます。
詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

プレイヤー優先度

ストリームサウンドのプレイヤープライオリティを 0 ～ 127 の範囲で指定します。数値が大きい程優先順位が高く（強く）なります。
プレイヤープライオリティは、プレイヤーのサウンドリミットの値を超えて再生しようとしたときや、サウンドやトラックなどについてシステムで設定した最大数を越えて再生しようとしたときに、再生を行う（止める）サウンドを選ぶ時に利用されます。
詳しくはサウンドシステムマニュアルをご覧ください。

プレイヤー

ストリームサウンドが発音する際に使用するプレイヤーを指定します。

アクタープレイヤー

再生するアクタープレイヤーの4種類の番号を 0 ～ 3の値で指定します。
アクタープレイヤーは、実世界の音源、具体的にはボイスに対する声帯に相当し、アクタープレイヤーごとに同時に再生できるサウンド数を制限することができます。
プレイヤーと同様に、設定したサウンド数を超えた場合には、各サウンドに設定されたプレイヤープライオリティを比較して、最も優先度が低いサウンドが停止します。各アクタープレイヤーのサウンド制限数の初期値は、0 番は無制限で、1 ～ 3番は 1 に設定されています。

アクタープレイヤーは、主に3Dサウンドのアクターと組み合わせて利用します。例としては、同じサウンドを、3Dサウンドの複数のアクターで同時に再生する可能性がある状況において、各アクター単位で、それらのサウンドの再生を制御したい場合などに有効です。

3D Vol

3D サウンドによるボリュームの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのボリューム制御を無効にすることができます。

3D Pan

3D サウンドによるパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのパン制御を無効にすることができます。

3D SPan

3D サウンドによるサラウンドパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのサラウンドパン制御を無効にすることができます。

3D Pri

3D サウンドによる発音プライオリティの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドの発音プライオリティ制御を無効にすることができます。

3D Filter

3D サウンドによるBiquadフィルタの制御を受けるかどうかを設定します。
このチェックを入れることにより、サウンドに対する 3D サウンドのBiquadフィルタ制御を有効にすることができます。

3D 減衰カーブ

3D サウンドによって行われる、ボリューム減衰の方式を選択します。

3D 減衰率

3D サウンドによって行われる、ボリューム減衰の減衰率を設定します。

3D ドップラーファクター

3D サウンドによって行われる、ドップラー効果を設定します。
ドップラー効果による音程の変化度合いを 0 ～ 255 の範囲で設定します。
デフォルト値は 0で、値が大きくなると音程の変化が急になり、0の時は全く変化しません。

パンモード

ステレオの波形に対する、パンの動作モードを、Dual と Balance から選択します。
Balance は左右の音量バランスを調整するモード、Dual は左右を個別のモノラルボイスとして、パンを設定するモードです。

パンモードの設定と動作についての詳細は、サウンドシステムマニュアルの「パンの動作」のセクションをご覧ください。

パンカーブ

パンの動作において、左右チャンネルの音量を決定する減衰カーブの種類を設定します。

パンカーブの設定と動作についての詳細は、サウンドシステムマニュアルの「パンの動作」のセクションをご覧ください。

フロントバイパス

3D サラウンドで、フロントバイパスするかどうかを設定します。
このチェックを ON にするとフロントバイパスモードになります。

フロントの L/R の音を「物理スピーカーの位置」から鳴らすのが、フロントバイパスモードです。
通常の 3D サラウンドの場合は、フロント L/R の音も、「仮想スピーカー位置」（物理スピーカー位置よりも広がりがある）で鳴ります。

ユーザー設定

ユーザーが自由に利用可能な 32bit の数値を設定します。

マルチトラックストリームの設定

ストリームサウンドではマルチトラックの指定が可能です。

ひとつのストリームサウンドに対して、合計で最大 4 個のトラックを設定することができます。

マルチトラックに設定する波形ファイルは、全て同じサンプリングレートにする必要があります。

コンバート後のデータ長及びループ指定については、トラック 0 の波形ファイルの情報が使用されます。

設定したいストリームサウンドリスト上で、右クリックにより現れるコンテキストメニューから設定ダイアログを開きます。

「追加」ボタンをクリックして、波形ファイルを追加します。
トラックを削除する場合は、リストを選択して「削除」ボタンをクリックします。

複数ファイルが指定されたストリームサウンドは、ストリームサウンドリストの「ファイルパス」の欄に " * "が表示され、ここからファイルパスは編集できないようになります。


ウェーブサウンド

プロジェクトツリーで、ウェーブサウンドのノードを選択することで、サウンドセットタブにウェーブサウンドのリストを表示することができます。
この時表示されるリストは、サウンドセットタブ内を上下に分割して表示されます。
分割されたタブのうち、上をウェーブサウンドセットリストと呼び、下をウェーブサウンドリストと呼びます。

ウェーブサウンドセットの役割

ウェーブサウンドは、参照する波形データをメモリにロードして再生します。ウェーブサウンドは主に効果音に利用されることを想定していますが、このような用途では非常に沢山のウェーブサウンドが必要となり、メモリへのロードを個別に行うのは効率的ではありません。
ウェーブサウンドセットは、この時一度にメモリにロードする波形データの組み合わせを定義します。
通常、効果音の波形データは、使われるシーン毎にまとめてメモリへロードされます。ウェーブサウンドセットを使って、同じシーンで使われる効果音（ウェーブサウンド）を効率的に集めることで、このような動作を前提としたサウンドデータの作成ができます。

ウェーブサウンドセットの新規作成と追加

ウェーブサウンドセットを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[ウェーブサウンドセット…] を実行します。

ウェーブサウンドセットリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、ウェーブサウンドセットを新規作成または追加することができます。

ウェーブサウンドセットリストの定義要素

ここではウェーブサウンドセットリストの各定義要素の意味を解説します。

名前

ウェーブサウンドセットの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

波形アーカイブ

波形アーカイブとの紐付けの設定（共有したい波形アーカイブの選択）をします。

  • 自動（共有）
    【自動】で波形アーカイブが生成されます。
    また、グループ内のほかのウェーブサウンドセットやバンクの波形アーカイブが【1 つにまとめられます】。
    （波形そのものを共有し、まとめて 1 つの波形アーカイブが生成されるわけではありません。）
    波形アーカイブは波形データの【個別ロード】はできず、【一括ロード】されます。
  • 自動（個別）
    【自動】で波形アーカイブを生成します。
    しかし、グループに属してもグループ内のほかのウェーブサウンドセットやバンクとは波形アーカイブが【1 つにはまとめられません】。
    この波形アーカイブは、ほかのどのバンクとも共有されません。【一括ロード】となります。
  • 波形アーカイブを明示指定
    波形アーカイブ内の波形ファイルの【個別ロード】【一括ロード】は、波形アーカイブリストで指定できます。
    しかし、【個別ロード】かつグループに【埋め込み】の場合は、【一括ロード】になります。

グループの「出力方式」と組み合わせた波形アーカイブの解説は波形アーカイブの自動(共有, 個別)設定も参照してください。

ウェーブサウンドの新規作成と追加

ウェーブサウンドを新規作成または追加する場合は、最初にウェーブサウンドセットリストでウェーブサウンドを追加したいウェーブサウンドリストを選択します。
この状態で[プロジェクト]→[アイテムの追加]→[ウェーブサウンド…] を実行します。

ウェーブサウンドリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、ウェーブサウンドを新規作成または追加することができます。

ウェーブサウンドの編集

ウェーブサウンドの編集はウェーブサウンドリストで行います。
ウェーブサウンドリストの各列はウェーブサウンドに必要な定義要素で、サウンドアーカイブのウェーブサウンドのデータに必要な各要素に対応しています。

ウェーブサウンドリストの定義要素

ここではウェーブサウンドリストの各定義要素の意味を解説します。

再生

ボタンをクリックすると、プレビュープレイヤーに登録され、ウェーブサウンドがトリガ再生されます。

名前

ウェーブサウンドの名前を指定します。この名前は最終的に作成されたサウンドアーカイブを利用して、プログラムが snd ライブラリ でウェーブサウンドを鳴らす時の名前になります。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

圧縮方式

コンバータが参照波形ファイルをコンバートする際の圧縮方法を指定します。

  • ADPCM

    • 波形ファイルを専用のADPCM形式にコンバートします。
    圧縮によりループの先頭が、ブロックの先頭に自動的に移動されますので、ループ位置のタイミングを利用した再生制御を行う場合などには注意が必要です。
  • PCM16

    • 16bitのPCMデータにコンバートします。
  • PCM8

    • 8bitのPCMデータにコンバートします。

ファイルパス

ウェーブサウンドを作成する際に参照する波形ファイルを指定します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

再生時間

サウンドの再生時間（波形データ長の時間）を表示します。
表示単位は［分：秒．ミリ秒］で、「ミリ秒」は 3 桁目を四捨五入し、2 桁表示となります。

データサイズ

圧縮変換後の波形データのサイズを表示します。
表示内容は、コンバートのタイミングで更新されます。

音量

ウェーブサウンドを snd ライブラリ が鳴らす時のボリュームを 0 ～ 255 の範囲で指定します。

サウンドデータの音量を 127 にすると、元データと等倍の音量 (1.0倍) で再生されます。

ただし、音量は、いろいろな場面 (データやプログラム) で設定されます。
すべての設定値が掛け合わされた結果、元音量から比べて、0.0 倍 ～ 2.0 倍にクランプされます。
詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

チャンネル優先度

ウェーブサウンドのチャンネルプライオリティを 0 ～ 127 の範囲で指定します。数値が大きい程優先順位が高く（強く）なります。チャンネルプライオリティはウェーブサウンドが実際に発音する際に、AX に渡されるボイス優先順位となります。

プレイヤー優先度

ウェーブサウンドのプレイヤープライオリティを 0 ～ 127 の範囲で指定します。数値が大きい程優先順位が高く（強く）なります。
プレイヤープライオリティは、プレイヤーのサウンドリミットの値を超えて再生しようとしたときや、サウンドやトラックなどについてシステムで設定した最大数を越えて再生しようとしたときに、再生を行う（止める）サウンドを選ぶ時に利用されます。
詳しくはサウンドシステムマニュアルをご覧ください。

プレイヤー

ウェーブサウンドが発音する際に使用するプレイヤーを指定します。

アクタープレイヤー

再生するアクタープレイヤーの4種類の番号を 0 ～ 3の値で指定します。
アクタープレイヤーは、実世界の音源、具体的にはボイスに対する声帯に相当し、アクタープレイヤーごとに同時に再生できるサウンド数を制限することができます。
プレイヤーと同様に、設定したサウンド数を超えた場合には、各サウンドに設定されたプレイヤープライオリティを比較して、最も優先度が低いサウンドが停止します。各アクタープレイヤーのサウンド制限数の初期値は、0 番は無制限で、1 ～ 3番は 1 に設定されています。

アクタープレイヤーは、主に3Dサウンドのアクターと組み合わせて利用します。例としては、同じサウンドを、3Dサウンドの複数のアクターで同時に再生する可能性がある状況において、各アクター単位で、それらのサウンドの再生を制御したい場合などに有効です。

パン

ウェーブサウンドを snd ライブラリ が鳴らす時のパンを 0 ～ 127 の範囲で指定します。

Sパン

ウェーブサウンドを SoundLib が鳴らす時のサラウンドパンを 0 ～ 127 の範囲で指定します。

ピッチ

ウェーブサウンドを snd ライブラリ が鳴らす時のピッチを倍率で指定します。

入力可能な数値の下限は 0.00001 です。
また、一括編集で0.00001未満の数値になる時は、0.00001に修正されます。

Env R

リリースエンベロープの、リリースタイムを 0 ～ 127 の範囲で指定します。

センド AUX_A

補助バス A に対するセンド量を 0 ～ 127 の範囲で指定します。

センド AUX_B

補助バス B に対するセンド量を 0 ～ 127 の範囲で指定します。

センド MAIN

メインバスのセンド量を 0 ～ 127 の範囲で指定します。

各補助バスとメインバスに対するセンド量は、以下に示す概念図に従ってミキシングされます。
センド MAINを 0 にすることで、補助バス（エフェクト）成分のみのサウンドを作成できます。

リリース時優先度固定

チェックを入れたサウンドは、リリース中も、発音プライオリティが下がらなくなります。

3D Vol

3D サウンドによるボリュームの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのボリューム制御を無効にすることができます。

3D Pan

3D サウンドによるパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのパン制御を無効にすることができます。

3D SPan

3D サウンドによるサラウンドパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのサラウンドパン制御を無効にすることができます。

3D Pri

3D サウンドによる発音プライオリティの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドの発音プライオリティ制御を無効にすることができます。

3D Filter

3D サウンドによるBiquadフィルタの制御を受けるかどうかを設定します。
このチェックを入れることにより、サウンドに対する 3D サウンドのBiquadフィルタ制御を有効にすることができます。

3D 減衰カーブ

3D サウンドによって行われる、ボリューム減衰の方式を選択します。

3D 減衰率

3D サウンドによって行われる、ボリューム減衰の減衰率を設定します。

3D ドップラーファクター

3D サウンドによって行われる、ドップラー効果を設定します。
ドップラー効果による音程の変化度合いを 0 ～ 255 の範囲で設定します。
デフォルト値は 0で、値が大きくなると音程の変化が急になり、0の時は全く変化しません。

パンモード

ステレオの波形に対する、パンの動作モードを、Dual と Balance から選択します。
Balance は左右の音量バランスを調整するモード、Dual は左右を個別のモノラルボイスとして、パンを設定するモードです。

パンモードの設定と動作についての詳細は、サウンドシステムマニュアルの「パンの動作」のセクションをご覧ください。

パンカーブ

パンの動作において、左右チャンネルの音量を決定する減衰カーブの種類を設定します。

パンカーブの設定と動作についての詳細は、サウンドシステムマニュアルの「パンの動作」のセクションをご覧ください。

フロントバイパス

3D サラウンドで、フロントバイパスするかどうかを設定します。
このチェックを ON にするとフロントバイパスモードになります。

フロントの L/R の音を「物理スピーカーの位置」から鳴らすのが、フロントバイパスモードです。
通常の 3D サラウンドの場合は、フロント L/R の音も、「仮想スピーカー位置」（物理スピーカー位置よりも広がりがある）で鳴ります。

ユーザー設定

ユーザーが自由に利用可能な 32bit の数値を設定します。


バンク

プロジェクトツリーで、バンクのノードを選択することで、サウンドセットタブにバンクを表示することができます。
この時表示されるリストを、バンクリストと呼びます。

バンクとバンクファイル

バンクはバンクファイルを参照します。シーケンスサウンドが実際に発音するインストルメントは、バンクファイルで定義されます。
バンクファイルはこの後で解説するバンクタブで編集を行います。

バンクの新規作成と追加

バンクを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[バンク…] を実行します。

バンクリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、バンクを新規作成または追加することができます。

バンクの編集

バンクの編集はバンクリストで行います。
バンクとバンクファイルの章で解説したとおり、音色の本体はバンクから参照されるバンクファイルで定義されます。バンクリストでは、バンクの名前と、参照するバンクファイル程度の編集しか行いません。

バンクリストの定義要素

ここではバンクリストの各定義要素の意味を解説します。

名前

バンクの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

波形アーカイブ

波形アーカイブとの紐付けの設定（共有したい波形アーカイブの選択）をします。

  • 自動（共有）
    【自動】で波形アーカイブが生成されます。
    また、グループ内のほかのウェーブサウンドセットやバンクの波形アーカイブが【1 つにまとめられます】。
    （波形そのものを共有し、まとめて 1 つの波形アーカイブが生成されるわけではありません。）
    波形アーカイブは波形データの【個別ロード】はできず、【一括ロード】されます。
  • 自動（個別）
    【自動】で波形アーカイブを生成します。
    しかし、グループに属してもグループ内のほかのウェーブサウンドセットやバンクとは波形アーカイブが【1 つにはまとめられません】。
    この波形アーカイブは、ほかのどのバンクとも共有されません。【一括ロード】となります。
  • 波形アーカイブを明示指定
    波形アーカイブ内の波形ファイルの【個別ロード】【一括ロード】は、波形アーカイブリストで指定できます。
    しかし、【個別ロード】かつグループに【埋め込み】の場合は、【一括ロード】になります。

グループの「出力方式」と組み合わせた波形アーカイブの解説は波形アーカイブの自動(共有, 個別)設定も参照してください。

ファイルパス

バンクファイルのパスを指定します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

HTMLインストルメントリストの出力

HTMLサウンドリストの出力と同様に、インストルメントリストをHTML形式でファイル出力することができます。

バンクリスト上で、右クリックによるコンテキストメニューから [HTMLインストルメントリストの出力] を実行すると、設定ダイアログが表示されます。

出力項目を選択してファイル出力します。

HTMLサウンドリストと違い、コンバート時には出力されません。
HTMLインストルメントリストは、バンクファイル毎にバンクファイルと同じディレクトリに出力されます。
インストルメントのラベル名やコメントを表で一覧することができ、項目毎のソートなども行えます。


シーケンスサウンド

プロジェクトツリーで、シーケンスサウンドのノードを選択することで、サウンドセットタブにシーケンスサウンドを表示することができます。
この時表示されるリストを、シーケンスサウンドリストと呼びます。

シーケンスサウンドの新規作成と追加

シーケンスサウンドを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[シーケンスサウンド…] を実行します。

シーケンスサウンドリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、シーケンスサウンドを新規作成または追加することができます。

シーケンスサウンドの編集

シーケンスサウンドの編集はシーケンスサウンドリストで行います。
シーケンスサウンドリストの各列はシーケンスサウンドに必要な定義要素で、サウンドアーカイブのシーケンスサウンドのデータに必要な各要素に対応しています。

シーケンスサウンドリストの定義要素

ここではシーケンスサウンドリストの各定義要素の意味を解説します。

再生

ボタンをクリックすると、プレビュープレイヤーに登録され、シーケンスサウンドがトリガ再生されます。

名前

シーケンスサウンドの名前を指定します。この名前は最終的に作成されたサウンドアーカイブを利用して、プログラムが snd ライブラリ でシーケンスサウンドを鳴らす時の名前になります。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

ファイルタイプ

参照ファイルのタイプを選択します。標準 MIDI ファイルの場合には SMF を、テキストシーケンスファイルを利用する場合にはテキスト（ダイアログでは Text）を選択します。

ファイルパス

シーケンスサウンドを作成する際に参照するファイルを指定します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

再生開始位置

参照ファイルとしてテキストシーケンスファイルを利用する場合に、テキストシーケンスファイルの中で、シーケンスサウンドが再生するシーケンスのラベルを指定します。

この指定を行なわない場合には、テキストシーケンスファイルの中で、最も先頭にあるシーケンスを再生します。

バンク

シーケンスサウンドが再生時に使用するバンクを指定します。

プレイヤー

シーケンスサウンドが発音する際に使用するプレイヤーを指定します。

音量

シーケンスサウンドを snd ライブラリ が鳴らす時のボリュームを 0 ～ 255 の範囲で指定します。

サウンドデータの音量を 127 にすると、元データと等倍の音量 (1.0倍) で再生されます。

ただし、音量は、いろいろな場面 (データやプログラム) で設定されます。
すべての設定値が掛け合わされた結果、元音量から比べて、0.0 倍 ～ 2.0 倍にクランプされます。
詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

チャンネル優先度

シーケンスサウンドのチャンネルプライオリティを 0 ～ 127 の範囲で指定します。数値が大きい程優先順位が高く（強く）なります。

この値は参照するシーケンスファイルの各チャンネルに設定された発音プライオリティと足し合わされ、各ボイスを発音する際の最終的な発音プライオリティとなります。
シーケンスファイルに対する発音プライオリティの設定方法については、シーケンスデータマニュアル（$SoundMaker/docs/SequenceData_Manual.pdf）を参照してください。

プレイヤー優先度

シーケンスサウンドのプレイヤープライオリティを 0 ～ 127 の範囲で指定します。数値が大きい程優先順位が高く（強く）なります。
プレイヤープライオリティは、プレイヤーのサウンドリミットの値を超えて再生しようとしたときや、サウンドやトラックなどについてシステムで設定した最大数を越えて再生しようとしたときに、再生を行う（止める）サウンドを選ぶ時に利用されます。
詳しくはサウンドシステムマニュアルをご覧ください。

アクタープレイヤー

再生するアクタープレイヤーの4種類の番号を 0 ～ 3の値で指定します。
アクタープレイヤーは、実世界の音源、具体的にはボイスに対する声帯に相当し、アクタープレイヤーごとに同時に再生できるサウンド数を制限することができます。
プレイヤーと同様に、設定したサウンド数を超えた場合には、各サウンドに設定されたプレイヤープライオリティを比較して、最も優先度が低いサウンドが停止します。各アクタープレイヤーのサウンド制限数の初期値は、0 番は無制限で、1 ～ 3番は 1 に設定されています。

アクタープレイヤーは、主に3Dサウンドのアクターと組み合わせて利用します。例としては、同じサウンドを、3Dサウンドの複数のアクターで同時に再生する可能性がある状況において、各アクター単位で、それらのサウンドの再生を制御したい場合などに有効です。

リリース時優先度固定

チェックを入れたサウンドは、リリース中も、発音プライオリティが下がらなくなります。

3D Vol

3D サウンドによるボリュームの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのボリューム制御を無効にすることができます。

3D Pan

3D サウンドによるパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのパン制御を無効にすることができます。

3D SPan

3D サウンドによるサラウンドパンの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドのサラウンドパン制御を無効にすることができます。

3D Pri

3D サウンドによる発音プライオリティの制御を受けるかどうかを設定します。
このチェックを外すことにより、サウンドに対する 3D サウンドの発音プライオリティ制御を無効にすることができます。

3D Filter

3D サウンドによるBiquadフィルタの制御を受けるかどうかを設定します。
このチェックを入れることにより、サウンドに対する 3D サウンドのBiquadフィルタ制御を有効にすることができます。

3D 減衰カーブ

3D サウンドによって行われる、ボリューム減衰の方式を選択します。

3D 減衰率

3D サウンドによって行われる、ボリューム減衰の減衰率を設定します。

3D ドップラーファクター

3D サウンドによって行われる、ドップラー効果を設定します。
ドップラー効果による音程の変化度合いを 0 ～ 255 の範囲で設定します。
デフォルト値は 0で、値が大きくなると音程の変化が急になり、0の時は全く変化しません。

フロントバイパス

3D サラウンドで、フロントバイパスするかどうかを設定します。
このチェックを ON にするとフロントバイパスモードになります。

フロントの L/R の音を「物理スピーカーの位置」から鳴らすのが、フロントバイパスモードです。
通常の 3D サラウンドの場合は、フロント L/R の音も、「仮想スピーカー位置」（物理スピーカー位置よりも広がりがある）で鳴ります。

ユーザー設定

ユーザーが自由に利用可能な 32bit の数値を設定します。

マルチバンクの設定

シーケンスサウンドではマルチバンクの指定が可能です。

ひとつのシーケンスサウンドに対して、合計で最大 4 個のバンクを設定することができます。

設定したいシーケンスサウンドリスト上で、右クリックにより現れるコンテキストメニューから設定ダイアログを開きます。

「追加」ボタンをクリックして、バンクを追加します。
バンク設定を削除する場合は、リストを選択して「削除」ボタンをクリックします。

複数バンクが指定されたシーケンスサウンドは、シーケンスサウンドリストの「バンク」の欄に " * "が表示され、ここからバンクは変更できないようになります。


シーケンスサウンドセット

プロジェクトツリーで、シーケンスサウンドセットのノードを選択することで、サウンドセットタブにシーケンスサウンドセットのリストを表示することができます。
この時表示されるリストは、サウンドセットタブ内を上下に分割して表示されます。
分割されたタブのうち、上をシーケンスサウンドセットリストと呼び、下をシーケンスサウンドリストと呼びます。

シーケンスサウンドセットの役割

シーケンスサウンドセットには、シーケンスサウンドと同様のデータを登録できますが、複数のシーケンスサウンドを１つのシーケンスサウンドセットにまとめることができます。
グループへの登録は、シーケンスサウンドセット単位でも行うことができますので、シーケンスサウンドセットを使うことで、シーケンスデータのグループ管理が楽になります。
（シーケンスサウンドセット内のシーケンス単位では、グループに登録できませんので、グループ登録に選べるラベルが、無駄に増えることは無くなります。）
シーケンスサウンドは主にBGM用、シーケンスサウンドセットは主にSE用というような使い方が考えられます。

シーケンスサウンドセットの新規作成と追加

シーケンスサウンドセットを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[シーケンスサウンドセット…] を実行します。

シーケンスサウンドセットリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、シーケンスサウンドセットを新規作成または追加することができます。

シーケンスサウンドの新規作成と追加および編集

シーケンスサウンドの新規作成と追加、および編集については、『シーケンスサウンド』 のページの各項目を参照してください。

シーケンスサウンドリストの定義要素

シーケンスサウンドの定義要素については、『シーケンスサウンド』 のページの定義要素を参照してください。

グループへの登録

グループに登録できるアイテムは、シーケンスサウンドセットのみです。
この中で作成したシーケンスサウンドを個別に登録することはできません。


波形アーカイブ

プロジェクトツリーで、波形アーカイブのノードを選択することで、サウンドセットタブに波形アーカイブを表示することができます。
この時表示されるリストを、波形アーカイブリストと呼びます。

波形アーカイブの役割

バンクやウェーブサウンドセットに関連付けられた複数の波形データを1つにまとめたものを波形アーカイブと呼びます。

1つの波形アーカイブに対して、複数のバンクや複数のウェーブサウンドセットを関連付けることができます。

波形アーカイブの新規作成と追加

波形アーカイブを新規作成または追加する場合は、まずプロジェクトツリーで波形アーカイブを選択し、サウンドセットタブを波形アーカイブの表示にします。

ダイアログ内で名前と個別ロードの設定を行い波形アーカイブを作成します。

また、波形アーカイブリストで削除したい行を、右クリックコンテキストメニューから削除することもできます。
削除する波形アーカイブが既にバンク、ウェーブサウンドセットから参照されている場合には、その旨を確認するアラートが現れます。
この操作は、サウンドセットが参照しているファイルへのリンクを解除するものであって、参照しているファイルそのものを削除するわけではありません。

波形アーカイブリストの定義要素

ここでは波形アーカイブリストの各定義要素の意味を解説します。

名前

波形アーカイブの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

個別ロード

このチェックが ON の場合、波形データをロードするとき、波形アーカイブをそのままロードせずに、波形アーカイブ中にある必要な波形データのみを、個別にロードします。

これは、次のように１つの波形アーカイブを複数のバンクで共有しているときに、有効に働きます。

この時、共有波形アーカイブには、バンクＡのみで使用している波形データが含まれている場合があります。そのような場合、バンクＢを使うときに必要のない波形データもロードすることになり、メモリ効率が悪くなります。
そこで、この共有波形アーカイブに個別ロード設定をつけておけば、バンクＢを使うときには、バンクＢが使っていない波形データが共有波形アーカイブに含まれていたとしても、それらはロードされません。

消費メモリとロード時間のオーバーヘッド

個別ロードを ON にした場合、波形データを個々に扱うので、一括で扱った場合と比べて、消費メモリとロード時間のオーバーヘッドが発生します。
不要なデータがロードされないことによる消費メモリの削減とロード時間の短縮によって、ほとんどの場合無視できますが、不要なデータが無い、もしくは少ない場合は、かえって効率が悪くなります。


プレイヤー

プロジェクトツリーで、プレイヤーのノードを選択することで、サウンドセットタブにプレイヤーを表示することができます。
この時表示されるリストを、プレイヤーリストと呼びます。

プレイヤーの新規作成と追加

プレイヤーを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[プレイヤー…] を実行します。

プレイヤーリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、プレイヤーを新規作成または追加することができます。

プレイヤーの編集

プレイヤーの編集はプレイヤーリストで行います。

プレイヤーリストの定義要素

ここではプレイヤーリストの各定義要素の意味を解説します。

名前

プレイヤーの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

サウンドリミット

プレイヤーで同時に再生できるサウンドの数を指定します。
プレイヤーはこの値で指定された最大再生数を超えるサウンドのリクエストを受けた場合には、各サウンドのプレイヤープライオリティによって再生するサウンドを選別します。この選別にもれたサウンドは実際の発音の有無に関わらず停止されます。
サウンドの最大再生数の指定は仮想ボイスの優先順位で、物理ボイスを規定する設定ではない点に注意してください。
この値はシーケンスサウンドやウェーブサウンドのような「サウンド」の最大再生数を指定します。各サウンドには複数の MIDI チャンネルやボイスが存在しますが、これら個別のボイスに対する優先順位の設定はチャンネルプライオリティによって行います。チャンネルプライオリティは各サウンドの再生が、物理ボイスとして発音される段階で、そのボイス単位に適用されます。

ヒープサイズ

プレイヤーが使用する、プレイヤーヒープのサイズを指定します。

プレイヤーヒープについての詳しい解説は、「プレイヤーヒープについて」をご覧ください。


グループ

プロジェクトツリーで、グループのノードを選択することで、サウンドセットタブにグループを表示することができます。
この時表示されるリストは、サウンドセットタブ内を上下に分割して表示されます。
分割されたタブのうち、上をグループリストと呼び、下をグループアイテムリストと呼びます。

グループの役割

グループには同じサウンドセットのアイテムを登録します。ここで登録されたアイテムをグループアイテムと呼びます。

プログラマが、アプリケーションでサウンドアーカイブから波形データなどをメモリにロードする際に、このグループ単位でロードを行うことで、特定のシーンなどで必要なアイテムをまとめてロードすることができます。

サウンドデザイナは、特定のシーンやタイミングで必要なアイテムを、効率的なグループへの分類と登録をすることにより、メモリの効率的な利用を設計することができます。

グループリストとグループアイテムリスト

グループの作成はグループリストで行います。グループアイテムリストには、選択したグループに現在登録されているアイテムの一覧を表示します。

グループの新規作成と追加

グループを新規作成または追加する場合は、サウンドセットタブのリスト領域を選択して、[プロジェクト]→[アイテムの追加]→[グループ…] を実行します。

グループリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、グループを新規作成または追加することができます。

グループへのアイテムの登録

グループへのアイテムの登録は、グループアイテムリストで行います。

グループリストでアイテムの登録を行いたいグループを選択した状態で、[プロジェクト]→[アイテムの追加]→[グループアイテム…] を実行します。

また、サウンドリストや検索結果ウインドウからグループアイテムリストに対して、アイテムをドラッグ＆ドロップすることでも、アイテムをグループに登録することができます。

グループリストの定義要素

ここではグループリストの各定義要素の意味を解説します。

名前

グループの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

データサイズ

グループリストのデータサイズに、グループがサウンドヒープにロードされた場合のサイズが表示されます。

データサイズの表示は、コンバートの実行時に自動的に更新されます。

グループのデータサイズは表示のみで、値を編集する事はできません。

出力方式

グループアイテムに登録したサウンドデータのサウンドアーカイブへの出力方式を設定します。

  • 埋め込み
    サウンドデータをグループに埋め込みます。
    メリットは、アクセス回数が減ります。デメリットとして、データの重複が起こる可能性があります。
    用途として、ROMに大きな余裕がある場合、メディアへのアクセス回数を減らしたい場合、RAMに余裕がある場合に向いています。
  • リンク
    サウンドデータをグループに含まず、サウンドアーカイブに含めます。
    メリットは、データの重複はありません。デメリットとして、アクセス回数が増えます。
    用途として、RAMやROMを節約したい場合、メディアへのランダムアクセスが速い場合に向いています。
  • 出力しない
    グループファイルを出力しません。サウンドバイナリアーカイブファイルにも含まれません。
    用途として、ほかのグループに入れるアイテムをまとめるための仮想的なフォルダとしてなどに利用できます。

グループアイテムリストの定義要素

ここではグループアイテムリストの各定義要素の意味を解説します。

名前

グループに登録されているアイテムの名前を表示します。
コンボボックスからサウンドセット内にある他のアイテムに変更できます。

サウンドセット

アイテムが含まれているサウンドセット名を表示します。

関連アイテム登録

アイテムのロード時に、関連する波形アーカイブのロードをどのように行うかを設定します。

初期設定では、シーケンスサウンド, ウェーブサウンド, バンクをロードする際、関連する波形アーカイブも一緒にロードしますが、関連アイテム登録を設定することにより、「シーケンスサウンドとバンクのみ」, 「波形アーカイブのみ」のような個別のロード指定ができます。

ウェーブサウンドセットやバンクにおいて、波形アーカイブ設定が「自動(共有)」または「自動(個別)」のときは、[ALL] しか選択することができません。

グループの動作について補足

ファイルとの関係

グループにはバンクやシーケンスなどのアイテムを登録しますが、実際にグループに登録されるのはそのアイテムが参照するファイルであり、snd ライブラリ がグループをサウンドヒープにロードした場合には、ファイル単位でロードが行なわれる点に注意が必要です。

テキストシーケンスファイルを参照するシーケンスサウンドを例として解説をします。

シーケンスサウンドが参照ファイルとして利用するテキストシーケンスファイルは、ひとつのテキストシーケンスファイルに複数のシーケンスを記述する事ができます。

このような「複数のシーケンスを持つテキストシーケンスファイル」を参照するシーケンスサウンドを、グループでサウンドヒープにロードした場合には、テキストシーケンスファイルの内容が全てロードされ、実際にはグループに登録していないシーケンスサウンドでも、同じテキストシーケンスファイルを参照するものは再生する事ができます。

なお、同じファイルを参照する複数のアイテムを、同じグループにアイテム登録する事ができますが、このようなグループのロードを行なっても、内容が重複してロードされる事はありません。

ウェーブサウンドセットについては、参照ファイルを持たずにサウンドセットウインドウで編集を行ないますが、 内部的にはウェーブサウンドセット単位で別ファイルとして扱われています。

波形アーカイブの自動(共有, 個別)設定とグループの出力方式の関係

バンク、ウェーブサウンドセットの「波形アーカイブ」とグループの「出力方式」の関係について、例を挙げて説明します。

以下では説明の簡単にするため、バンクとグループの関係について説明します。 ウェーブサウンドセットとグループの関係については、バンクの部分をウェーブサウンドセットと読み替えるとそのままあてはまります。

「リンク」グループと「自動(共有)」バンク

まずは、「リンク」のグループの挙動について説明します。

下記のように「リンク」のグループに、 3 つの「自動(共有)」のバンクを登録した場合、

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_0 [リンク] | BANK_0 [自動(共有)]
 | BANK_1 [自動(共有)]
 | BANK_2 [自動(共有)]

BANK_0 ～ BANK_2 まで、それぞれ別々に波形アーカイブが (暗黙的に) 自動で生成されます。
BANK_0 ～ BANK_2 間で同じ波形を参照していても共有されず、ROM 上で重複して配置されることになります。 グループ内でまとめて 1 つの波形アーカイブが生成されたり、 その波形アーカイブ内で重複した波形がまとめられるわけではありません。

波形を共有したいのであれば、「埋め込み」グループと「自動(共有)」バンクを利用するか、 以下のように、バンクの波形アーカイブを明示的に指定する必要があります。

バンクの波形アーカイブを明示的に指定

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_0 [埋め込み or リンク] | BANK_0 - WARC_0
 | BANK_1 - WARC_0
 | BANK_2 - WARC_0

上記の構成の場合、WARC_0 には、BANK_0 ～ BANK_2 に含まれる波形が重複無く含まれる （ひとつの波形が複数のバンクから共有される）ことになります。

波形アーカイブの個別ロードフラグは ON / OFF どちらでもかまいません。

「リンク」グループと「自動(個別)」バンク

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_0 [リンク] | BANK_0 [自動(個別)]
 | BANK_1 [自動(個別)]
 | BANK_2 [自動(個別)]

この場合は、「リンク」グループと「自動(共有)」バンクのケースと同じく、 BANK_0 ～ BANK_2 までそれぞれ別々に波形アーカイブが (暗黙的に) 自動で生成されます。 各バンクで共通な波形がひとつの波形アーカイブにまとめられるといったこともありません。

つまり、「リンク」グループに登録されたバンクは、 「自動(共有)」であっても「自動(個別)」であっても、 1 つのバンクに対して、1 つの波形アーカイブ生成され、 グループ内で重複した波形が共有されることはない、ということになります。

「自動(個別)」バンクの用途

一見「自動(個別)」のバンクには有用な用途が無いように見えますが、 次のような構成の場合、

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_1 [埋め込み or リンク] | BANK_0 [自動(個別)]
GROUP_2 [リンク] | BANK_0 [自動(個別)]

BANK_0 用に自動生成される波形アーカイブは 1 種類になり、 ROM サイズを節約することが可能です。

ただし、GROUP_1 と GROUP_2 とも [埋め込み] の場合は、 BANK_1 の波形アーカイブは、ROM 上の 2 か所に生成されてしまいます。

「埋め込み」グループと「自動(共有)」バンク

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_0 [埋め込み] | BANK_0 [自動(共有)]
 | BANK_1 [自動(共有)]
 | BANK_2 [自動(共有)]

この場合は、BANK_0 ～ BANK_2 について、 まとめてひとつの波形アーカイブが生成されます。 この波形アーカイブには、3 つのバンクで参照されている波形が重複無く含まれる （ひとつの波形が複数のバンクから共有される）ことになります。

この構成は 波形アーカイブを明示的に指定する場合 と比べて、 波形アーカイブをわざわざ作らなくてよくなるメリットがある一方、 グループ内でしか波形が共有できなくなるデメリットがあります。 また、上記の構成に加えて、

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_1 [埋め込み] | BANK_0 [自動(共有)]
 | BANK_3 [自動(共有)]

のように、「埋め込み」グループである GROUP_0 にも GROUP_1 にも BANK_0 が含まれている場合、 GROUP_0 用の波形アーカイブおよび GORUP_1 用の波形アーカイブそれぞれに、 BANK_0 で参照される波形が含まれる (ROM 上に波形が重複して配置される) ため、 ROM サイズが大きくなるデメリットがあります。

「埋め込み」グループと「自動(個別)」バンク

グループ - 出力方式 | バンク - 波形アーカイブ
GROUP_0 [埋め込み] | BANK_0 [自動(個別)]
 | BANK_1 [自動(個別)]
 | BANK_2 [自動(個別)]

この場合は、BANK_0 ～ BANK_2 まで、それぞれ別々に波形アーカイブが (暗黙的に) 自動で生成されます。

この構成の場合は、「自動(個別)」バンクの用途 にあるような使い方をすると、メリットが出てきます。


バンクタブ

このセクションでは、バンクの概念とバンクタブの解説を行います。


概要

バンクタブの役割

バンクタブは、バンクファイル（拡張子 .cbnk）の編集を行うペインです。
バンクファイルは、サウンドセットのバンクから参照され、シーケンスサウンドが再生に使用する音色として機能します。

バンクファイルの構造

バンクファイルは、楽器に対応するインストルメントと、これらの楽器をセットにして、プログラムナンバーを割り当てたインストリストから構成されています。
ここから後のセクションで、各要素の詳しい解説を行います。

バンクタブのタブテキスト

通常、プロジェクトに属するバンクファイルの場合、タブテキストにバンク名が含まれて「バンク名 - ファイル名」のように表示されますが、[ファイル]メニューからプロジェクト未登録のバンクファイルを読み込んだ場合などは、 ファイル名のみの表示となります。


インストルメントのパラメータについて

ここではインストルメントのパラメータの種類と、その概念を解説します。

インストパラメータとリージョンパラメータ

SoundMaker のバンクタブでは、内部的にインストルメントが持つパラメータ（全てのリージョンに共通）と、リージョンが持つパラメータを区別しています。

前者をインストパラメータ、後者をリージョンパラメータと呼びます。

各パラメータの扱い方

ここではバンクタブで設定する各パラメータについて、インストパラメータとリージョンパラメータのどちらで扱うことが可能かをまとめます。

エンベロープ

インストパラメータかリージョンパラメータの何れかで設定が可能です。

エンベロープの値をインストパラメータとして扱う（インストルメント単位で設定）か、リージョンパラメータとして扱う（リージョン単位で設定）かは、インストルメントごとに設定することができます。
エンベロープは通常インストパラメータとして扱いますが、マルチリージョンのインストルメントに対して、リージョンパラメータのエンベロープを設定することにより、リージョン単位で個別にエンベロープの値を設定することができます。
適用対象の設定は、エンベロープの適用対象の選択を参照してください。

現在のエンベロープの適用対象は、インストリストのエンベロープの表示で知ることができます。
インストリストの表示が数値で表示されているものは「インストルメント単位」、表示が "*" になっているものは「リージョン単位」となっています。

ひとつのインストルメントに対して、インストパラメータとリージョンパラメータのエンベロープを同時に設定することはできません。

パン

リージョンパラメータとしてのみ扱い、常にリージョン単位で指定を行います。

音量

インストパラメータとリージョンパラメータの両方で、独立して設定が可能です。

ピッチ

インストパラメータとリージョンパラメータの両方で、独立して設定が可能です。


インストリスト

バンクタブは上下に分割されて表示されます。この上の領域をインストリストと呼びます。

インストリストの役割

インストリストはインストルメントの作成と、プログラムナンバーの指定を行います。インストリストは、シーケンスがバンクを参照する際の音色セットとして機能します。
リージョンをひとつしか持たないシングルリージョンのインストルメントについては、インストリストのみでインストルメントの編集も行うことができます。

インストルメントの作成

バンクタブがアクティブな状態で、[プロジェクト]→[アイテムの追加]→[インストルメント] を実行します。

インストリストで、右クリックを行うと現れるコンテキストメニューによる操作でも、インストルメントを新規作成することができます。

新規作成時のデフォルト状態でのオリジナルキーについて、指定した波形ファイルのファイル名や付加情報に基づいて、自動的に適切と思われる値に設定されます。
（例えば "Test_A3.aif"というファイル名の "A3"という部分）

ファイル名に書かれるノートの表記は、シーケンスコマンドの規則に従います。
設定される順序は、以下のようになります。

  1. 波形ファイル名に、キーを表す文字列があれば、それをオリジナルキーに変換します。
  2. キーを表す文字列が見つからない場合は、波形ファイル内のオリジナルキー情報を取得します。
  3. 2.に失敗したときは、cn4 とします。

エンベロープの適用対象の選択

エンベロープについての解説はインストルメントのパラメータを参照してください。

適用対象の設定は、インストルメントごとに個別に行なうことができます。
切り替えは、インストリストのコンテキストメニューによって行ないます。

リージョン単位からインストルメント単位への切り替え

インストルメント単位からリージョン単位への切り替え

フォルダを開く・参照ファイルを開く

コンテキストメニューの「フォルダを開く」または「参照ファイルを開く」を選択することで、そのファイルに対するそれぞれの動作を行えます。

インストリストの編集

ここではインストリストの各定義要素の意味を解説します。

プログラムナンバー

シーケンスからバンクが参照される際に、プログラムチェンジの番号に対するインストルメントの割り当てを指定します。
MIDI のプログラムチェンジでは 128 個のプログラムナンバーしか指定できませんが、テキストシーケンスによる指定も考慮し、インストリストではこの制限を越えたプログラムナンバーを指定することができます。

名前

インストルメントの名前を指定します。
名前に使用できる文字には制限があり、以下の文字が使えます。
  ・先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・先頭以外は、半角英数字とアンダーバー [a-zA-Z0-9_]

圧縮方式

コンバータが参照波形ファイルをコンバートする際の圧縮方法を指定します。

  • ADPCM

    • 波形ファイルを専用のADPCM形式にコンバートします。
    圧縮によりループの先頭が、ブロックの先頭に自動的に移動されますので、ループ位置のタイミングを利用した再生制御を行う場合などには注意が必要です。
  • PCM16

    • 16bitのPCMデータにコンバートします。
  • PCM8

    • 8bitのPCMデータにコンバートします。

ファイルパス

インストルメントが参照する波形ファイルを指定します。
シングルリージョンのインストルメントについてのみ、インストリストからこの指定を行うことができます。マルチリージョンのインストルメントの場合には、この項目は"*"と表示され、編集を行うことはできません。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

再生時間

サウンドの再生時間（波形データ長の時間）を表示します。
表示単位は［分：秒．ミリ秒］で、「ミリ秒」は 3 桁目を四捨五入し、2 桁表示となります。

ティック数

必要なノートコマンドの長さを表示します。
ティックは、テキストシーケンスでノートや休符の長さを指定するための単位です。

ティック数は、テンポや四分音符分解能の値に依存して値が変わりますが、テンポのデフォルト値 120 (1 分間あたり四分音符 120 回) および、テキストシーケンスの四分音符分解能のデフォルト値 48 (これはプロジェクト設定の「SMFの四分音符分解能」で設定するものとは異なります)で考えた場合、

  • 1 分 ＝ 120 * 48 ＝ 5760 ティック
  • 1 秒 ＝ 120 * 48 / 60 ＝ 96 ティック

にそれぞれ相当します。

テキストシーケンスを書く際に、ティック数がわかると有用です。

ただし、インストの音程を変えた場合、実際の波形再生時間が長くなったり短くなったりしますが、これにあわせて実際の再生ティック数も変化してしまうので、注意が必要です。

データサイズ

圧縮変換後の波形データのサイズを表示します。
マルチリージョンのインストルメントなど、複数の波形ファイルを参照する場合は、参照ファイルの合計サイズを表示します。
表示内容は、コンバートのタイミングで更新されます。

オリジナルキー

参照する波形ファイルのオリジナルキー（鍵盤のどの位置で波形ファイルが元のピッチで鳴るか？）を指定します。
シングルリージョンのインストルメントについてのみ、インストリストからこの指定を行うことができます。マルチリージョンのインストルメントの場合には、この項目は"*"と表示され、編集を行うことはできません。

Env A

エンベロープのアタックタイムを 0 ～ 127 で指定します。
インストルメント単位にエンベロープの適用対象を設定している時にのみ、インストリストからこの指定を行うことができます。適用対象がリージョン単位に設定されている時には、この項目は "*" と表示され、編集を行うことはできません。
この動作は、以降のエンベロープの各フェーズの指定も同様です。

Env H

エンベロープのホールドタイムを 0 ～ 127 で指定します。

Env D

エンベロープのディケイタイムを 0 ～ 127 で指定します。

Env S

エンベロープのサスティンレベルを 0 ～ 127 で指定します。

Env R

エンベロープのリリースタイムを 0 ～ 127 で指定します。

音量

インストルメントの音量を 0 ～ 255 で指定します。

サウンドデータの音量を 127 にすると、元データと等倍の音量 (1.0倍) で再生されます。

ただし、音量は、いろいろな場面 (データやプログラム) で設定されます。
すべての設定値が掛け合わされた結果、元音量から比べて、0.0 倍 ～ 2.0 倍にクランプされます。
詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

ピッチ（半音）

インストルメントのピッチを半音単位で指定します。

ピッチ（セント）

インストルメントのピッチをセント単位（半音の 1 / 100）で指定します。

補間タイプ

インストルメント単位で補間タイプを指定します。

ボイスの補間方法を設定し、「4 点補間」,「線形補間」,「補間なし」が選べます。
デフォルト値は 4 点補間 (INTERPOLATION_TYPE_POLYPHASE) です。

以下は、サンプルレート変換時に用いる補間アルゴリズムで、プログラム上での設定および取得は nn::snd::Voice::SetInterpolationType 関数、nn::snd::Voice::GetInterpolationType 関数を用います。

  • 補間なし (INTERPOLATION_TYPE_NONE) を指定すると、補間時に近接するサンプル値を用います。補間結果にノイズが生じることがあります。
  • 線形補間 (INTERPOLATION_TYPE_LINEAR) を指定すると、線形補間を行います。
  • 4 点補間 (INTERPOLATION_TYPE_POLYPHASE) を指定すると、4 点補間を行います。補間に用いられる polyphase フィルタは、設定されたサンプルレートとピッチから、適したものが選択されます。3 つのアルゴリズムの中で最も音質が優れています。


サンプルマップ

バンクタブは上下に分割されて表示されます。上領域はインストリストで、下領域にはサンプルマップとパーカッションリストのタブが配置されています。
この下領域で、サンプルマップのタブを選択した時に表示されるのがサンプルマップです。

サンプルマップの役割

サンプルマップはインストルメントを編集する専用のエディタです。
インストリストで選択したインストルメントの編集を行います。

サンプルマップは、鍵盤の表示と、その上にリージョンの領域をブロックで視覚的に示すオーソドックスなスタイルを採用したインストルメントのエディタで、主にマルチリージョンのインストルメントの作成に適しています。

サンプルマップの操作

ここではサンプルマップで可能な操作を解説します。

リージョンの表示

リージョンが表示される領域には、上部に薄い水色のバーが付属しています。このバーをリージョンヘッダーと呼びます。
ベロシティリージョンをまとめて操作する場合には、このリージョンヘッダーをクリックして利用します。

キーリージョン・ベロシティリージョンの作成

リージョンの領域（リージョンヘッダーを含む）で右クリックして現れるコンテキストメニューで、キーリージョンの分割またはベロシティリージョンの分割ができます。

キーリージョンの削除や移動などでできた、ブランク（空）の領域をダブルクリックする操作でも、新しいキーリージョンを作成することができます。

また、ベロシティリージョンはキーリージョンの一部として扱われます、キーリージョンの無い場所に、ベロシティリージョンだけを作成することはできません。

リージョン分割の制限

リージョンヘッダーをクリックして、ベロシティリージョンを複数選択した状態からのベロシティリージョンの分割や、同一キーリージョン内でベロシティリージョン分割されていて、全ベロシティリージョンが選択されていない状態からのキーリージョンの分割などは行えません。

リージョンの参照波形ファイルの指定

リージョンの領域をダブルクリックするか、右クリックして現れるコンテキストメニューから「参照波形の変更」を選択することで、リージョンの参照波形ファイルを指定できます。

フォルダを開く・参照ファイルを開く

右クリックして現れるコンテキストメニューから「フォルダを開く」または「参照ファイルを開く」を選択することで、そのファイルに対するそれぞれの動作を行えます。

キーリージョンの操作

リージョンヘッダーをドラッグ＆ドロップすることで、キーリージョンの内容を他のキーリージョンと入れ替えることができます。この時、入れ替えるキーリージョンにベロシティリージョンが存在すれば、その情報も同時に入れ替わります。

リージョンヘッダーを Ctrl + ドラッグ＆ドロップすることで、キーリージョンの内容を他のキーリージョンにコピーすることができます。入れ替えと同様に、コピー元のキーリージョンにベロシティリージョンが存在すれば、その情報も同時にコピーされます。

ベロシティリージョンの操作

リージョンヘッダー以外の領域（ベロシティリージョン自体）をマウスでドラッグした場合には、ベロシティリージョンに対する操作として扱われます。

リージョンヘッダーを使った操作と同様の操作で、通常のドラッグ＆ドロップでは移動、もしくは入れ替え、Ctrl + ドラッグ＆ドロップでコピーを行います。

ベロシティリージョンの境界をドラッグ中には、その時の値がツールチップに表示されます。

リージョンの圧縮方式の指定

リージョンが参照する波形ファイルの圧縮方式の指定は、鍵盤の下のスペースにある、圧縮方式の項目で行ないます。

  • ADPCM

    • 波形ファイルを専用のADPCM形式にコンバートします。
    圧縮によりループの先頭が、ブロックの先頭に自動的に移動されますので、ループ位置のタイミングを利用した再生制御を行う場合などには注意が必要です。
  • PCM16

    • 16bitのPCMデータにコンバートします。
  • PCM8

    • 8bitのPCMデータにコンバートします。

リージョンのオリジナルキーの指定

リージョンのオリジナルキーの編集は、リージョンの表示領域と鍵盤の間にあるバーで行います。
バーのある鍵盤の位置の時、選択中のリージョンの波形ファイルが元のピッチで再生されます。

ベロシティの指定

リージョンの表示領域の左にあるスライダーで、鍵盤による再生時のベロシティを指定できます。


パーカッションリスト

バンクタブは上下に分割されて表示されます。上領域はインストリストで、下領域にはサンプルマップとパーカッションリストのタブが配置されています。
この下領域で、パーカッションリストのタブを選択した時に表示されるのがパーカッションリストです。

パーカッションリストの役割

パーカッションリストはインストルメントを編集する専用のエディタです。
インストリストで選択したインストルメントの編集を行います。

パーカッションリストは、サンプルマップと同様にマルチリージョンのインストルメントを編集するエディタですが 、サンプルマップとは対照的に鍵盤を縦にリストにして表示します。
パーカッションリストはサンプルマップに比べ、非常に狭い範囲に、小さなキーマップを沢山作るケースの多い、パーカッションタイプのインストルメントの作成に適しています。
パーカッションリストでは、ベロシティリージョンを扱うことはできません。

パーカッションリストの操作

ここではパーカッションリストで可能な操作を解説します。

キーリージョンの作成

キーリージョンの作成は、リスト上で右クリックにより現れるコンテキストメニューの「キーリージョンの分割」を選択して行います。 パーカッションリストは、上から順に低音から高音の鍵盤に対応しています。キーリージョンは、分割操作を行った行から、より高い音に対して、次のキーリージョンがある行までの領域に作成されます。

ベロシティリージョンの作成

パーカッションリストではベロシティリージョンを作成することはできません。

フォルダを開く・参照ファイルを開く

右クリックして現れるコンテキストメニューから「フォルダを開く」または「参照ファイルを開く」を選択することで、そのファイルに対するそれぞれの動作を行えます。

パーカッションリストの編集

ここではパーカッションリストの各定義要素の意味を解説します。

圧縮方式

参照波形ファイルをコンバートする際の圧縮方式を指定します。

  • ADPCM

    • 波形ファイルを専用のADPCM形式にコンバートします。
    圧縮によりループの先頭が、ブロックの先頭に自動的に移動されますので、ループ位置のタイミングを利用した再生制御を行う場合などには注意が必要です。
  • PCM16

    • 16bitのPCMデータにコンバートします。
  • PCM8

    • 8bitのPCMデータにコンバートします。

ファイルパス

リージョンが参照する波形ファイルを指定します。

ファイル名、およびパス名に使用できる文字には制限があり、以下の文字が使えます。
  ・ファイル名の先頭は、半角英字とアンダーバー [a-zA-Z_]
  ・ファイル名の先頭以外およびパス名は、半角英数字とアンダーバー [a-zA-Z0-9_]

再生時間

サウンドの再生時間（波形データ長の時間）を表示します。
表示単位は［分：秒．ミリ秒］で、「ミリ秒」は 3 桁目を四捨五入し、2 桁表示となります。

ティック数

必要なノートコマンドの長さを表示します。
ティックは、テキストシーケンスでノートや休符の長さを指定するための単位です。

ティック数は、テンポや四分音符分解能の値に依存して値が変わりますが、テンポのデフォルト値 120 (1 分間あたり四分音符 120 回) および、テキストシーケンスの四分音符分解能のデフォルト値 48 (これはプロジェクト設定の「SMFの四分音符分解能」で設定するものとは異なります)で考えた場合、

  • 1 分 ＝ 120 * 48 ＝ 5760 ティック
  • 1 秒 ＝ 120 * 48 / 60 ＝ 96 ティック

にそれぞれ相当します。

テキストシーケンスを書く際に、ティック数がわかると有用です。

ただし、インストの音程を変えた場合、実際の波形再生時間が長くなったり短くなったりしますが、これにあわせて実際の再生ティック数も変化してしまうので、注意が必要です。

データサイズ

圧縮変換後の波形データのサイズを表示します。
マルチリージョンのインストルメントなど、複数の波形ファイルを参照する場合は、参照ファイルの合計サイズを表示します。
表示内容は、コンバートのタイミングで更新されます。

オリジナルキー

リージョンのオリジナルキーを指定します。

Env A

エンベロープは、インストルメント単位またはリージョン単位で設定できます。
エンベロープについての解説はインストルメントのパラメータを参照してください。

マルチリージョンのインストルメントの場合のみ、リージョンに対してエンベロープのアタックタイムを 0 ～ 127 で指定します。
以降のエンベロープの各フェーズの指定も同様です。

Env H

エンベロープのホールドタイムを 0 ～ 127 で指定します。

Env D

エンベロープのディケイタイムを 0 ～ 127 指定します。

Env S

エンベロープのサスティンレベルを 0 ～ 127 で指定します。

Env R

エンベロープのリリースタイムを 0 ～ 127 で指定します。

音量

リージョンの音量を 0 ～ 255 の範囲で指定します。

サウンドデータの音量を 127 にすると、元データと等倍の音量 (1.0倍) で再生されます。

ただし、音量は、いろいろな場面 (データやプログラム) で設定されます。
すべての設定値が掛け合わされた結果、元音量から比べて、0.0 倍 ～ 2.0 倍にクランプされます。
詳しくは、サウンドシステムマニュアルの「サウンドパラメータ制御の動作」の章をご覧ください。

ピッチ（半音）

リージョンのピッチを半音単位で指定します。

ピッチ（セント）

リージョンのピッチをセント単位（半音の 1 / 100）で指定します。

パン

リージョンのパンを指定します。

パーカッションモード

リージョンに対してパーカッションモードを指定します。
チェックが入った状態が、パーカッションモードが有効な状態を示します。

パーカッションモードを指定したリージョンでは、ノートオフは無視され、ノート長に関わらず波形ファイルの最後まで再生されます。
ノート高に対応したピッチの計算は、通常通り行われます。

ループする波形ファイルを設定したリージョンへの適用は、十分ご注意ください。

キーグループ

リージョンに対して、キーグループを0～15の範囲で指定します。

値に0を指定した状態では、キーグループは動作を行いません。キーグループのデフォルトには、0が設定されています。

0以外の同じキーグループを設定したリージョンでは、新しいノートが発音される毎に、同じキーグループで発音中の再生を停止します。
この機能は、例えばクローズハイハットとオープンハイハットの演奏エミュレーションなどに利用する事ができます。

キーグループの動作は、シーケンス内の同一トラック内でのみ有効です。
複数のシーケンスから同じインストルメントを利用するケースや、シーケンス内の複数のトラックから同じインストルメントを同時に利用するケースでは、キーグループの機能を利用する事はできません。

補間タイプ

インストルメント単位で補間タイプを指定します。

ボイスの補間方法を設定し、「4 点補間」,「線形補間」,「補間なし」が選べます。
デフォルト値は 4 点補間 (INTERPOLATION_TYPE_POLYPHASE) です。

以下は、サンプルレート変換時に用いる補間アルゴリズムで、プログラム上での設定および取得は nn::snd::Voice::SetInterpolationType 関数、nn::snd::Voice::GetInterpolationType 関数を用います。

  • 補間なし (INTERPOLATION_TYPE_NONE) を指定すると、補間時に近接するサンプル値を用います。補間結果にノイズが生じることがあります。
  • 線形補間 (INTERPOLATION_TYPE_LINEAR) を指定すると、線形補間を行います。
  • 4 点補間 (INTERPOLATION_TYPE_POLYPHASE) を指定すると、4 点補間を行います。補間に用いられる polyphase フィルタは、設定されたサンプルレートとピッチから、適したものが選択されます。3 つのアルゴリズムの中で最も音質が優れています。


パラメータパネル

このセクションでは、パラメータパネルの概念と操作方法の解説を行います。


概要

パラメータパネルとは？

パラメータパネルは、バンクファイルに対するエンベロープとパンの入力を行う専用パネルです。
エンベロープとパンの値をグラフで視覚的に確認しながら、専用のスライダーで操作することができます。

パラメータパネルの役割

パラメータパネルは、バンクタブと連動して動作します。
インストリストやパーカッションリストと組み合わせて利用することで、数値表示ではイメージしにくいエンベロープなどの設定を補助します。
サンプルマップと一緒に使うことによって、サンプルマップでは編集できないエンベロープやパンの指定を行うことができます。

パラメータパネルはフローティングダイアログとして表示され、SoundMaker のメインウインドウの外に移動することができます。


パラメータパネルの操作

パラメータパネルを開く

[表示]→[パラメータパネル] またはメインウインドウのツールバーにあるパラメータパネルアイコン により、パラメータパネルを開くことができます。
この操作には Ctrl + I および Ctrl + Shift + 8 のショートカットキーが割り振られています。

インストリストがアクティブな状態でないとパラメータパネル内の各設定値は表示されません。

パラメータパネルが操作する対象

パラメータパネルは、常にアクティブなバンクタブに対してパラメータの表示と編集を行います。

なお、スペースキーを押すことにより、対象のインストルメントを再生できます。

パラメータの編集

エンベロープの編集

バンクタブ内の任意の場所でインストルメントかリージョンを選択し、パラメータパネルでエンベロープの操作を行うことで、選択したインストルメントまたはリージョンのエンベロープの値を編集することができます。

値の編集は、各フェーズのスライダーの操作で行います。
作成したエンベロープカーブは、パラメータパネル内に表示されるグラフで確認する事ができます。アタック、ディケイ、リリースの各時間については、グラフの上部にミリ秒単位で正確に表示されます。

マルチリージョンのインストルメントをインストリストで選択しているなど、エンベロープが編集不可能な時は、スライダーの操作は受け付けません。

音量の編集

音量の値は、インストルメントとリージョンに各々独立して指定する事ができます。

バンクタブ内の任意の場所でインストルメントかリージョンを選択し、パラメータパネルで音量の操作を行うことで、選択したインストルメントまたはリージョンの音量の値を編集することができます。

ピッチの編集

ピッチの値は、インストルメントとリージョンに各々独立して指定する事ができます。

バンクタブ内の任意の場所でインストルメントかリージョンを選択し、パラメータパネルでピッチの操作を行うことで、選択したインストルメントまたはリージョンのピッチの値を編集することができます。

ピッチの操作は半音単位、セント単位（半音の 1 / 100）の何れか、またはこれらを組み合わせて指定を行ないます。

パンの編集

バンクタブ内の任意の場所でリージョンを選択し、パラメータパネルでパンの操作を行うことで、選択したリージョンのパンの値を編集することができます。
値の編集は、パンのスライダーの操作で行います。

マルチリージョンのインストルメントをインストリストで選択しているなど、パンが編集不可能な時は、スライダーの操作は受け付けません。


PC エミュレーション

このセクションでは、PC エミュレーションの解説を行います。


概要

PC エミュレーションとは？

SoundMaker では、PC エミュレーションにより PC のオーディオアウトからサウンドの再生をサポートしています。
PC エミュレーションは SoundMaker の GUI とは独立したプログラムとして動作し、サウンドプロジェクトにあるストリームサウンド、シーケンスサウンド、ウェーブサウンドと、バンクファイルにあるインストルメントを再生することができます。

インストルメントの再生方法

PC エミュレーションによるインストルメントの再生には 2 通りの方法があります。
ひとつは GUI の操作による再生で、こちらは下の概念図で「再生情報の経路 1」に示したバンクウインドウから行われる再生です。もうひとつは同じ概念図の「再生情報の経路 2」に示した外部 MIDI 機器からの MIDI 信号による再生です。

これら 2 種類の再生は、PC エミュレーションでは全く別の動作として処理されますのでご注意ください。GUI によるインストルメントの選択が、特定の MIDI チャンネルの再生に影響を与えることはありません。

PCエミュレーションの概念図


GUI による再生

GUI によるサウンドの再生

GUI によるサウンドの再生は、サウンドセットタブで選択してから行います。

操作方法については、プレビュー機能の「サウンドの再生操作」を参照してください。

GUI によるインストルメントの再生

GUI によるインストルメントの再生は、バンクタブから行います。複数のバンクタブが開かれている場合には、常にアクティブなバンクタブのインストルメントを再生します。

以下にバンクタブの、PC エミュレーションによるインストルメントの再生方法を示します。

インストリスト

PC キーボードのスペースキーの操作により行います。
スペースキーを押す操作と戻す操作が、各々 MIDI のノートオンとノートオフに対応します。
この動作はバンクタブで行われる全てのスペースキーによる再生で共通です。
インストリストでは、スペースキーの操作で選択しているインストルメントを、サンプルマップの鍵盤で選択中のキー（通常 C4 のキー）で再生します。

サンプルマップ

GUI に配置された鍵盤をクリックする動作と、PC キーボードのスペースキーを押す操作により行います。
鍵盤のクリックにより編集中のインストルメントを対応するキーで再生します。
スペースキーはリージョンの再生を行います。スペースキーの操作では選択しているリージョンの波形を、その波形のオリジナルキーで再生します。

鍵盤の左にあるスライダーで、鍵盤による再生時のベロシティを指定できます。

パーカッションリスト

PC キーボードのスペースキーの操作により行います。スペースキーの操作により、編集中のインストルメントを選択しているリストに該当するキーで再生します。


MIDI による再生

MIDI によるインストルメントの再生

PC エミュレーションは、設定された MIDI ポートからの MIDI 入力に対して、16 チャンネルのマルチティンバー音源として動作します。
MIDI 入力により発音するチャンネルは、全てのチャンネルにアクティブなバンクタブのインストルメントが対応し、インストリストで設定されたプログラム番号によってインストルメントの切り替えを行います。

各チャンネルには MIDI プログラムチェンジで再生を行いたいインストルメントのプログラム番号を指定してください。

インストリストでインストルメントの選択動作を行った時には、MIDI のチャンネル１に対してのみ、対応するインストルメントのプログラムチェンジが送信されます。

複数の MIDI チャンネルで同時に別のバンクのインストルメントを再生することはできません。
バンクの切り替えはバンクタブがアクティブになった時に行われます。
チャンネルに対して一度指定されたプログラム番号は、アクティブなバンクタブの切り替えを行ってもリセットされませんのでご注意ください。

MIDI 再生

MIDI キーボードデバイスと MIDI シーケンサーの2系統を分けて、それぞれの MIDI 入力にどれを割り当てるかオプションダイアログで設定しておきます。

キーボード割り当ての MIDI 再生

主に、バンクに登録されてたインストルメントの確認に利用します。

バンクタブをアクティブにし、かつインストリストを選択した場合に、そのインストルメントを使って音が再生されます。
別のインストルメントを選択すると、選択したインストルメントで音が鳴ります。

現在アクティブなインストルメントが再生されるので、バンクタブがアクティブでないとき、 インストルメントがアクティブでないときは、キーボードMIDI 再生はできません。

インストルメントを選択している・いないに関わらず、「プログラムチェンジ」MIDI コマンドを受信すると、そのプログラムに対応するインストルメント行が選択されます。
「バンクセレクト」コマンドは無視されます。

シーケンサー割り当ての MIDI 再生

主に、市販のシーケンサーソフトウェアで作った MIDI を SoundMaker に取り込んで、当該バンクで確認します。

プレビューバンクに登録したバンクを使って、MIDI を再生します。

シーケンスサウンドは、4つまでバンクをセットすることができます。


PC エミュレーションの状態を知る

PC エミュレーションは、メインウインドウの右上に、「MIDI 受信」「実際の発音」の各ステータスを常に表示します。

MIDIキーボード入力は、アクティブなバンクパネルを対象として発音します。
バンクパネルがアクティブでない場合は、音は鳴りません。

各表示の意味

各表示の意味を以下に示します。

MIDI

PC エミュレーションが何らかの MIDI 信号を受信した時に緑色に点灯します。

SOUND

PC エミュレーションが何らかの音を出力した時に緑色に点灯します。

表示の更新について

ここで表示される各種の情報は、1 / 30sec に一度、その瞬間の状態で更新します。このため非常に短い発音などでは緑色の点灯を確認できない場合がありますのでご注意ください。


全発音停止

[ツール]→[全発音停止] を実行することで、PC エミュレーションで再生中の音を全て強制的に止めることができます。

この機能はエンベロープで極端に長いリリース・タイムを設定したインストルメントの再生を止めたい時などに使います。


MIDI リセット

[ツール]→[MIDI リセット] を実行することで、PC エミュレーションの MIDI パラメータを全てリセットすることができます。
この操作は、これまでに外部 MIDI 入力から指定された音量などのパラメータを全てリセットします。

この機能は、PC エミュレーションで別の MIDI シーケンスを鳴らす場合や MIDI シーケンスを途中から再生する場合などで、コントロールチェンジなどの MIDI メッセージによるパラメータ指定が残ると困る場合に使います。


注意と補足

このページでは、PC エミュレーションについての補足説明として、利用する際の注意や利用時に有用と思われる情報を解説します。

同じ PC で動作するシーケンサ等から PC エミュレーションを利用する方法について

SoundMaker を起動している PC と同じ PC で動作しているシーケンサの MIDI 出力で、PC エミュレーションの再生を行うためには、シーケンサから出力された MIDI を一度 PC の MIDI 入力に逆流させる必要があります。

このような MIDI 信号を逆流させる動作を「ループバック」と呼び、ループバックの実現は通常、フリーウェアなどの仮想的な MIDI デバイスドライバを使ってソフトウェア上で行います。

PC エミュレーションによる音の再現性能について

PC エミュレーションにより再生される音は、ADPCM 等の波形データの圧縮による音質の劣化や、CTR 本体のオーディオ回路の特性などは再現しません。
このため出力の音質については実機とは誤差が生じます。

MIDI についても同様に、ループなど原理的に不可能なものや、シーケンスコマンドの再生には PC エミュレーションは対応していません。

各サウンドの最終的な確認には、必ず CTR 本体をご使用ください。

PC エミュレーションは AX の機能など、一部のエミュレーション再生に対応していません。


実機によるサウンドの再生

このセクションでは、SoundMaker で行なうことができる、実機(PARTNER-CTR Debugger) での音の確認方法を解説します。


SoundPlayer

このセクションでは、SoundPlayer を使った実機(PARTNER-CTR Debugger) での音の確認方法を解説します。


概要

SoundPlayer とは？

SoundPlayer は、NW4C SoundMaker で作成したデータを CTR の実機(PARTNER-CTR Debugger) で確認するためのツールです。
PARTNER-CTR Debugger のセッティングが行われている PC では、SoundPlayer を使って作成したサウンドアーカイブを実機で確認することができます。

SoundPlayer は、[プレビュー]メニューからサウンドアーカイブを抱え込んだ形の cci ファイルを作成して実機で再生する方法 (SoundPlayer) と、サウンドアーカイブを cci ファイルから切り離して、実機側からコンバートしたアーカイブを読み込んで再生する方法 (HioSoundPlayer) の 2 通りがあります。

注意事項

SoundPlayer で再生するサウンドデータのサイズには制限があります。

  • サウンドデータ用のヒープサイズは、 12MB です。
    （nw::snd::SoundHeap::Create 関数に渡されるメモリサイズ）
    これより大きなサイズのデータが必要なサウンドは再生できません。


SoundPlayer の作成

SoundPlayer の作成には、NintendoWare for CTR と対応したバージョンの CTR_SDK をインストールしておく必要があり、同時に環境変数 CTRSDK_ROOT を設定しておく必要があります。
CTR_SDK 導入の手順については、別途リリースされている CTR-StartupGuide.pdf に記載がありますのでそちらを参照してください。

現在 SoundMaker のメニュー操作から行えるのは、サウンドアーカイブを含めた SoundPlayer の cci ファイルを作成するところまでです。
サウンドを再生するには、cci ファイルを PARTNER-CTR でロード、実行を行ってください。

SoundPlayer の作成方法

[プレビュー]→[SoundPlayer の作成] を実行し、cci ファイルを作成します。

「SoundPlayer の作成」の動作

[プレビュー]→[SoundPlayer の作成] を実行すると、SoundMaker は以下の一連の動作を自動的に行います。

  • サウンドアーカイブの作成（コンバート）
  • SoundPlayer 実行ファイル (SoundPlayer-TS.cci) の作成
  • 作成されたファイルのあるフォルダをエクスプローラで開く


HioSoundPlayer

HioSoundPlayer (HostIO 対応 SoundPlayer)

HostIO 経由で SoundPlayer を実行できます。
サウンドアーカイブのみをリロードできるため、サウンドデータ変更後の実機（PARTNER-CTR Debugger）での確認作業が、[プレビュー]→[SoundPlayer の作成] から SoundPlayer を丸ごと作り直すよりも軽快に行えます。

HioSoundPlayer の動作手順

PARTNER-CTR デバッガ起動直後は、NintendoWare のパッケージ内にある HioSoundPlayer.cci ファイルを読み込む必要があります。

  1. PARTNER-CTR デバッガで %NW4C_ROOT%\tools\SoundPlayer\HioSoundPlayer.cci をロードし実行する。
  2. SoundMaker でサウンドプロジェクトをコンバートする。
  3. PARTNER-CTR Debugger で [START] ボタンを押し、コンバートしたサウンドアーカイブをロードする。

以後、2, 3 を繰り返すことで、SoundMaker での修正・変更結果を、随時 PARTNER-CTR Debugger で確認できます。

※SoundMaker でコンバートを行うと、SoundMaker フォルダ内にテンポラリ用として _tmpForSoundPlayer フォルダを作成します。

注意事項

  • PARTNER-CTR HIO-Daemon が起動していない場合は起動してください。
  • NW4C_ROOT 環境変数を設定、あるいは変更した場合には HIO-Daemon、PARTNER-CTR デバッガ と SoundMaker の再起動が必要です。
    （NW4C の setup.wsf を実行した場合も含まれます。）


SoundPlayer の操作

操作

SoundPlayer の操作は PARTNER-CTR Debugger のコントローラから行います。

各機能の操作別に 3 つの画面モード（ウィンドウ）があります。

SoundPlayer 操作

各ウィンドウでの操作方法および再生状態の説明は、実機の下画面に表示されます。
ウィンドウの切り替えは L/R ボタンで行います。

START ボタンで、コンバートしたサウンドアーカイブのロードを行います。 (HioSoundPlayer のみ)

プレイヤーウィンドウ

サウンド設定

キー操作 | 説明
上ボタン、下ボタン | カーソルの移動
右ボタン、左ボタン | サウンドの選択
Ａ ボタン | カーソル行のサウンドを再生
Ｂ ボタン | カーソル行のサウンドを停止
Ｙ ボタン | カーソル行のサウンドを一時停止、再開
Ｘ ボタン | サウンドパラメータ設定画面へ切り替え
Ｌ ボタン、Ｒ ボタン | ウィンドウの切り替え
START ボタン | コンバートしたサウンドアーカイブのロード (HioSoundPlayer のみ)

上画面では、指定したサウンドアーカイブに入っているサウンド一覧やその再生状態、またDSP 処理負荷、使用ボイス数などが表示されます。

サウンドパラメータ設定

キー操作 | 説明
上ボタン、下ボタン | カーソルの移動
右ボタン、左ボタン | 値の変更
Ａ ボタン | カーソル行のサウンドを再生
Ｂ ボタン | カーソル行のサウンドを停止
Ｙ ボタン | 値のリセット
Ｘ ボタン | サウンド設定画面へ切り替え
Ｌ ボタン、Ｒ ボタン | ウィンドウの切り替え
START ボタン | コンバートしたサウンドアーカイブのロード (HioSoundPlayer のみ)

X ボタンにより、上画面をサウンド設定画面からサウンドパラメータ設定画面に切り替えることができます。

サウンドパラメータ設定画面では、以下の各値を設定できます。

  ・音量
  ・ピッチ
  ・パン
  ・サラウンドパン
  ・メインセンド
  ・エフェクトセンド

出力モードウィンドウ

キー操作 | 説明
上ボタン、下ボタン | カーソルの移動
右ボタン、左ボタン | 値の変更
Ｌ ボタン、Ｒ ボタン | ウィンドウの切り替え
START ボタン | コンバートしたサウンドアーカイブのロード (HioSoundPlayer のみ)

出力モード（3D サラウンド）切り替え

出力モード（3D サラウンド）切り替え機能は、次の 4 タイプから選択できます。

  ・モノラル
  ・ステレオ
  ・3D サラウンド（スクエア）
  ・3D サラウンド（ワイド）

「スクエア」と「ワイド」は、仮想スピーカーの位置が異なります。
詳しくは、CTR-SDK の関数リファレンスにある nn::snd::SetSurroundSpeakerPosition を参照してください。

プログラム的には、下表のような設定で切り替わります。

タイプ | NW4C SetOutputMode | CTR-SDK SetOutputMode | CTR-SDK SetSurroundSpeakerPosition
MONO | mono | mono | -
STEREO | stereo | stereo | -
SURROUND[SQUARE] | 3d surround | 3d surround | SQUARE
SURROUND[WIDE] | 3d surround | 3d surround | WIDE

サラウンドデプス値

0 - 100 の値を設定します。100 が最も効果があります。

サラウンドモード時に設定できるサラウンドデプス値について、詳しくは CTR-SDK の関数リファレンスにある nn::snd::SetSurroundDepth を参照してください。

クリッピングモード

サウンド出力時にオーバーフローした際のクリッピング処理の方法を設定します。
通常クリッピング (NORMAL) またはソフトクリッピング (SOFT) が指定できます。

クリッピングモードについて、詳しくは CTR-SDK の関数リファレンスにある nn::snd::SetClippingMode を参照してください。

エフェクトウィンドウ

キー操作 | 説明
上ボタン、下ボタン | カーソルの移動
右ボタン、左ボタン | 値の変更
Ａ ボタン | エフェクトの適用
Ｂ ボタン | エフェクトの解除
Ｘ ボタン | バス選択モードとパラメータ設定モードの切り替え
Ｌ ボタン、Ｒ ボタン | ウィンドウの切り替え
START ボタン | コンバートしたサウンドアーカイブのロード (HioSoundPlayer のみ)

AUX_BUS_A, AUX_BUS_B にエフェクトを指定すると、対応するパラメータが表示されます。

プレビューバンクウィンドウ

キー操作 | 説明
上ボタン、下ボタン | カーソルの移動
右ボタン、左ボタン | シーケンスサウンド、バンクの変更および音量の変更
Ａ ボタン | バンクのロード
Ｂ ボタン | バンクのアンロード
Ｌ ボタン、Ｒ ボタン | ウィンドウの切り替え
START ボタン | コンバートしたサウンドアーカイブのロード (HioSoundPlayer のみ)

MIDIデバイスからの入力をどのバンクで再生するかを指定します。
シーケンスサウンドと結びつけられたバンクもロードされます。

ロード済みのバンクには '#' が表示されます。

上画面最下段の "volume" を大きくすると、MIDI プレビュー時の音量が大きくなります。

上画面最上段の "SEQ" 表示行の下に、選択したシーケンスサウンドの SoundMaker 上のボリュームが表示されます。
（表示する値は、0 ～ 255 の音量と 127 を元データと等倍の音量 1.0 とする 0.0 ～ 2.0 にマップした値です。）

カーソルが SEQ にある状態でバンクをロードすると、選択したシーケンスサウンドの音量が、MIDI プレビュー時の音量（上画面最下段の "volume"）に反映されます。


プレビュー機能

このセクションでは、SoundMaker のプレビュー機能について解説します。


概要

プレビュー機能とは？

プレビュー機能は、Viewer または SoundPlayer の各種ウインドウでコントローラを使って行う設定と同じ操作を、SoundMaker 上で行い、設定をViewer に転送して実機での再生やPCエミュレーション再生に反映したり、設定の保存を行う、各種ウインドウおよびペインです。

SoundArchivePlayer, SeqVariable, Effect ウインドウの各種設定、およびSoundSystem ウインドウの一部設定に対応しています。

※ Viewer の機能は現バージョンでは実装されておりません。

OutputModeの操作

ツールバー上のプレビュー項目内のOutputMode選択プルダウンリストから、ViewerでのOutputModeの切り替えと同様の操作が行えます。

サウンドの再生操作

SoundMakerからサウンドを再生するには、メインウインドウの[プレビュー]メニューやツールバーのボタンによる操作と、プレビュープレイヤーからの操作、およびPCキーボードからのキー操作による方法があります。
また、サウンドセットタブとバンクタブでは、再生操作に一部違いがあります。

サウンドセットタブでは、各リストから選択したサウンドに対して操作が行えます。
バンクタブでは、アクティブなバンクタブのインストルメントに対して操作が行えます。

サウンドセットタブでの操作

各リストでサウンドを選択した状態で、メインウインドウの[プレビュー]メニュー内やツールバーにある、 [再生], [一時停止], [停止] の各項目およびボタンにより操作を行います。
再生は、各リストのダブルクリックや項目にある [再生ボタン] または [F9]キーの操作で、また停止は[F10]キーの操作でも行えます。

キー入力に対する動作の関係は、以下のようになります。

入力 | 動作
F9 キー | 再生
F10 キー | すべて停止
スペースキー | 再生
再生ボタンクリック | 再生

※バンクタブの操作については、「GUIによるインストルメントの再生」を参照してください。


プレビュープレイヤー

プレビュープレイヤーとは？

プレビュープレイヤーは、Viewer や SoundPlayer での SoundArchivePlayer のプレイペインに相当する操作を SoundMaker 上で行い、設定を転送して実機でのサウンドの確認を行うペインです。

プレビュープレイヤーで再生を行うと、PCエミュレーション または Viewer に接続中はViewer上にてサウンド再生されます。

プレビュープレイヤーの操作

プレビュープレイヤーを開く

[表示]→[プレビュープレイヤー] または、ツールバーの「プレビュープレイヤーの表示」ボタンにより、プレビュープレイヤーを開く（アクティブにする）ことができます。
またこの操作には Ctrl + Shift + 4 のショートカットキーが割り振られています。

プレビュープレイヤーは、メインウインドウ下部のペインにドッキングウインドウとして現れます。

ウインドウ下部にある"プレビュープレイヤー"タブ部分またはタイトルバーのコンテキストメニューから、検索結果ウインドウを [フローティング]、[ドッキング]、[非表示] に変えることができます。
タイトルバー部分のダブルクリックでも [フローティング]、[ドッキング] の切り替えが行えます。

また、ドッキングウインドウ時は、タイトルバー右側の最小化アイコンをクリックするか、スプリッタ(境界線)をダブルクリックすることにより、タブのみの最小化表示になります。

プレビュープレイヤーの操作

プレビュープレイヤーのプレイリストにサウンドを登録または入れ替えを行うには、以下の方法があります。

  • サウンドセットタブの選択状態のインデックスセルをクリックし、プレビュープレイヤーのプレイリスト内にドラッグ＆ドロップすることにより、サウンドが登録できます。
  • サウンドセットタブ内のリストで登録するサウンドを選択し、リスト内やツールバーの「再生」ボタンをクリック、または [F9]・スペースキーを押下することにより、プレイリスト内の選択されている場所にサウンドが登録され、再生することができます。

サウンドが登録されたプレイリストでは、それぞれ「再生」、「一時停止」、「停止」ボタンを押下することにより、サウンドの確認を行います。

また、「ループ再生」ボタンを押下して有効にすることにより、サウンドのループ再生を行えます。ボタンをクリックする毎にON, OFFのトグル動作をします。


プレビューバンク

プレビューバンクとは？

プレビューバンクは、MIDI シーケンサーから入力された MIDI 信号を、どのバンクで再生するのかを定めるペインです。
このペイン（ウインドウ）に登録されたバンクを使用して MIDI 再生します。

プレビューバンクの操作

プレビューバンクを開く

[表示]→[プレビューバンク] または、ツールバーの「プレビューバンクの表示」ボタンにより、プレビューバンクを開く（アクティブにする）ことができます。

プレビューバンクは、メインウインドウ下部のペインにドッキングウインドウとして現れます。

ウインドウ下部にある"プレビューバンク"タブ部分またはタイトルバーのコンテキストメニューから、検索結果ウインドウを [フローティング]、[ドッキング]、[非表示] に変えることができます。
タイトルバー部分のダブルクリックでも [フローティング]、[ドッキング] の切り替えが行えます。

また、ドッキングウインドウ時は、タイトルバー右側の最小化アイコンをクリックするか、スプリッタ(境界線)をダブルクリックすることにより、タブのみの最小化表示になります。

プレビューバンクの操作

プレビューバンクのリストにバンクを登録または入れ替えを行うには、以下の方法があります。

  • サウンドセットタブのシーケンスサウンドリストまたはバンクリストから選択状態のインデックスセルをクリックし、プレビューバンクのリスト内にドラッグ＆ドロップすることにより、バンクの登録ができます。
  • サウンドセットタブのシーケンスサウンドリストまたはバンクリストから、右クリックによるコンテキストメニューを開き、[プレビューバンクに登録] でバンクの登録ができます。
    この場合は、バンクはプレビューバンクの 0 番に固定で登録されます。

シーケンスサウンドリストからバンクを登録すると、シーケンスサウンドに紐づけられたバンクが登録されます。
プレビューバンクの 0～3 の数字は、シーケンスサウンドのマルチバンク設定における 0～3 に相当します。

プレビューバンクに登録したアイテムを削除するには、削除したいアイテムを選択し、メインメニューの [表示]→[削除] を実行、または Delete, Ctrl+D キーを押下します。


シーケンス変数

シーケンス変数とは？

シーケンス変数ウインドウは、Viewer や SoundPlayer での SeqVariable ウインドウに相当する操作を SoundMaker 上で行い、PCエミュレーション再生を行うウインドウです。

シーケンス変数の操作

シーケンス変数ウインドウを開く

[表示]→[シーケンス変数] または、ツールバーの「シーケンス変数の表示」ボタンにより、シーケンス変数ウインドウを開く（アクティブにする）ことができます。
またこの操作には Ctrl + Shift + 6 のショートカットキーが割り振られています。

シーケンス変数の操作

シーケンス変数ウインドウ上部にある「自動書き込み」のポップアップメニュー項目の設定により、変更時に自動書き込みをするかしないかを設定できます。
［しない］に設定した場合、ウインドウ右下の「書き込み」ボタンがアクティブになり、任意のタイミングで書き込みができます。

値の編集時に、小さいスライダーボタンをクリックすると、スライダーがポップアップ表示されます。

「反転」、「クリア」ボタンはそれぞれ、チェックボックスの現在の状態を一括反転、一括クリアします。


オプション設定

このセクションでは、SoundMaker のオプション設定について解説します。


概要

オプション設定の種類

SoundMaker のオプション設定には、ツール設定（以後こちらの設定をオプションと呼びます）とプロジェクト設定の 2 種類が用意されています。

オプションの指定は、[ツール]→[オプション] ダイアログで行います。
オプションはツール全体の動作設定を行います。この設定は初期設定ファイルに保存されますので、同じ PC で起動する SoundMaker では常に有効です。

プロジェクト設定の指定は、[プロジェクト]→[プロジェクトの設定] ダイアログで行います。
プロジェクト設定はサウンドプロジェクト単位での動作設定を行います。この設定はサウンドプロジェクトファイルに保存されますので、別の PC で実行している SoundMaker で、同じサウンドプロジェクトファイルを開いた場合にも有効となります。


オプションダイアログ

オプションダイアログは、SoundMaker 全体の動作設定を行うダイアログです。

オプションダイアログの開き方

[ツール]→[オプション] を実行します。

オプションダイアログの操作

オプションダイアログにはタブが配置されています。このタブで設定を行いたいカテゴリを選択してください。
以下にカテゴリ毎に設定の意味を解説します。

全般

[プロジェクト]エリアでは、SoundMaker起動時に、最後に開いていたプロジェクトを開くかどうかの設定をすることができます。
チェックが入っていると、起動時に前回アプリケーションを閉じた時に開いていたプロジェクトを自動的に開きます。

また、タイトルバーのプロジェクト名表記をフルパスで表示するかどうかの設定ができます。

[リスト表示]エリアでは、参照ファイルパスのフルパス表示、行番号の表示／非表示の動作を設定することができます。

[コンバート]エリアでは、並列コンバート処理の設定をすることができます。
依存関係のないサウンドのコンバート処理を並列して実行できます。プロセスの最大数は、1 ～ 99 の間で自由に設定可能です。

オーディオ

PC エミュレーションの出力に使用するオーディオ出力デバイスを選択することができます。

MIDI

SoundMaker が MIDI の受信に使う MIDIキーボード入力と MIDIシーケンサー入力を選択することができます。

[MIDIキーボード入力] に設定したデバイスから入力されたMIDI信号は、アクティブなバンクタブのバンクを使用して再生されます。
割り当ては1つのみです。

[MIDIシーケンサー入力] に設定したデバイスから入力されたMIDI信号は、プレビューバンクウィンドウのバンクを使用して再生されます。
割り当ては複数可能です。

[MIDIキーボード入力] に設定されている MIDI デバイスは、[MIDIシーケンサー入力] のリスト上ではグレーアウトして無効になります。
[MIDIシーケンサー入力] でデバイスを有効にしたい場合は、[MIDIキーボード入力] で同一のデバイスを選択しないようにしてください。


プロジェクト設定ダイアログ

プロジェクト設定ダイアログは、開いているサウンドプロジェクトに対して、サウンドプロジェクト単位での動作設定を行うダイアログです。

プロジェクト設定ダイアログの開き方

[プロジェクト]→[プロジェクトの設定] を実行します。

プロジェクト設定ダイアログの操作

プロジェクト設定ダイアログにはタブが配置されています。このタブで設定を行いたいカテゴリを選択してください。
以下にカテゴリ毎に設定の意味を解説します。

・コンバート
・コンバートイベント
・サウンドアーカイブ
・HTMLサウンドリスト
・アイテム名

コンバート

コンバートの動作設定を行います。

全般

「SMFの四分音符分解能」で、SMF をコンバートする際の四分音符分解能を選択します。

出力

「サウンドアーカイブの出力先」で、サウンドアーカイブファイル等の出力先を指定します。
空白の場合、サウンドプロジェクトと同階層に出力されます。

「ストリームファイルの出力先パス」で、コンバート時にストリームファイルを出力する dvddata 以下のディレクトリを指定します。
存在しないディレクトリを指定した場合には、コンバート時に自動的に作成されます。

「アイテム別ラベルを出力する」のチェックが ON の場合、全てのアイテム名 (ID) の一覧を収めたファイル（サウンドプロジェクト名.csid）の他に、ID のヘッダの種類別にファイルを分けて出力します。

ファイル出力については『生成されるファイル』も参照してください。

キャッシュ

中間バイナリファイルは、「キャッシュの出力先」に指定したフォルダに出力されます。
ただし、SMFから作成される中間テキストシーケンスサウンド(.cseq)、バンクのインクルードファイル(.cinl)は、ソースファイルと同じ場所に出力されます。

「SMFファイルから変換されたテキストシーケンスファイル(.cseq)を残す」のチェックが ON の時、SMFと同階層に作成された .cseqファイルをコンバート後にも残します。

警告

「未使用のアイテムがあったら警告する」のチェックボックスは、コンバート時にコンバートログウインドウにおいて、警告を行うかどうかを指定します。

コンバートイベント

「コンバート前コマンド」と「コンバート後コマンド」については、別セクション（その他の機能）の『コンバート前後の自動処理』で解説します。

サウンドアーカイブ

コンバートで作成する、サウンドアーカイブファイルの設定を行ないます。

「文字列テーブルを出力する」のチェックを OFF にすると、サウンドアーカイブに文字列テーブルが出力されなくなります。
文字列でサウンドなどをコールしない場合に出力しないようにすれば、サウンドアーカイブのサイズを削減することができます。

[サウンドアーカイブプレイヤー]エリアで設定する各数値は、作成したサウンドアーカイブを再生する時に、snd ライブラリ が用意するサウンドやチャンネルの上限になります。

全く使わないサウンドの数を 0 にしたり、チャンネル数を必要最小限にする事で、snd ライブラリ が消費するメモリを節約する事ができます。
ただし、例えば「ストリームサウンドの数」などを設定した場合には、その数以上のストリームサウンドは同時に再生する事ができなくなりますので、数値の変更は慎重に行なってください。

HTMLサウンドリスト

HTMLサウンドリストの設定を行います。

HTMLサウンドリストの設定を行っておくと、サウンドデータコンバート時に、自動的にHTML形式のサウンドリストを出力することができます。

サウンドのラベル名やコメントを表で一覧することができ、項目毎のソートなども行えます。

※HTML形式のファイル出力については、インストルメントリストも行えますが、コンバート時には出力されません。
    インストルメントリストについては「HTMLインストルメントリストの出力」を参照してください。

新規作成ボタンをクリックすると「サウンドリスト出力設定の新規作成」ダイアログが表示されますので、出力設定名などを入力します。

出力設定名を1つ以上設定すると、「基本設定」と「出力項目」のタブが現れます。

複数サウンドセットを持ったプロジェクトでは、サウンドセット毎にリストを出力するか、全てのサウンドセットを１つのリストにまとめて出力するかを、「サウンドセット毎にリストを出力する」チェックボックスで選ぶことができます。

サウンドリストに書き出す項目にチェックを付けてください。
サウンドリストへは、このリストに並んでいる順で書き出されます。「上へ移動」「下へ移動」ボタンを押すと、リスト中の選択されたアイテムを並べ替えることができます。

また、設定リストは「設定リストの編集」ボタンにより現れるダイアログで編集することが可能です。

アイテム名

アイテムの名前について、デフォルトの接頭語の設定を行います。

各種アイテムの新規作成ダイアログにおいて、デフォルトで表示される名前について、接頭語を自由に設定できます。
ただし、サウンドセットについては、設定はできません。

また、デフォルト名には元のファイル名が使用されます。
ファイル名の大文字・小文字への変換やアイテム名に使えない文字の扱いについての設定を【ファイル名からの作成】エリアで行います。

波形ファイルのドラッグ＆ドロップによる新規作成時には、アイテム名は常にファイル名を元に作成されます。


その他の機能

このセクションでは、SoundMaker が持つ、やや特殊な機能の解説を行います。


ファイル操作

フォルダを開く

[ファイル]→[フォルダを開く] で、Windows のエクスプローラを起動し、フォルダを開くことができます。

この操作は、サウンドセットで波形ファイルや標準 MIDI ファイルなどの外部参照ファイルを持つ各アイテム、波形ファイルを参照するインストルメントやリージョンを選択中に行うことで、それらの参照ファイルのフォルダをエクスプローラで開くことができます。

SoundMaker でのファイルの新規作成は、サウンドプロジェクトファイル、サウンドセットファイル、バンクファイルのみ可能です。SoundMaker は、新規作成時に上書きするケースを除きファイルの削除は行いません。
プロジェクトファイルを別名で保存しておきたい時や、波形ファイルを整理、確認したい時などに利用します。

プロジェクトファイルの再読み込み

[ファイル]→[プロジェクトの再読み込み] から、操作中のSoundMaker以外で編集・更新されたプロジェクトファイルを読み込み直すことができます。
読み込み対象ファイルは、サウンドセットファイル(.csst)、バンクファイル(.cbnk)です。

再読み込みは、サウンドプロジェクトで参照する、対象となるファイルすべてに対して個別に確認を行います。
更新を確認したファイルが変更されている場合は、以下の各ケースに応じた動作をします。

  ケース１：　SoundMaker上で更新（未保存の編集）が無い場合

    最新のファイルを読み込みます。

  ケース２：　SoundMaker上で更新（未保存の編集）が有る場合

    ダイアログで確認して、最新のファイルを読み込みます。
    読み込んだ場合は、SoundMaker上にある未保存の編集は失われます。
    またこの場合、対応するペインのアンドゥの履歴はクリアされます。

    ダイアログでキャンセルした場合や、ファイルが更新されていない場合は、何もしません。
    （次回SoundMakerで保存を行った時に、変更されたファイルはSoundMakerに上書きされます）

「プロジェクトの再読み込み」には、Ctrl+L のショートカットが割り当てられています。

プロジェクト外バンクファイルの読み込み

[ファイル]→[ファイルを開く] から、プロジェクト未登録のバンクファイル(.cbnk)をタブで開き、編集可能にします。
[ファイルを開く] は、プロジェクトを開いている時のみ可能です。

また、バンクリスト以外のビューに、バンクファイルをドラッグ＆ドロップすることでも、未登録のバンクファイルを開くことができます。
バンクリストにバンクファイルをドラッグ＆ドロップした時には、バンクファイルを追加します。

外部からのファイルドロップ読み込み

アプリケーションウインドウ（サブウインドウを含む）へのプロジェクトファイルや波形ファイルなどのドロップ読み込みに対応しています。

外部からファイルをドロップする場合は、マウスカーソルに[+]が表示されます。
リストやサンプルマップ上にファイルをドロップしようとすると、挿入位置がハイライト表示されます。

また、リストに登録できないファイルをドロップした場合には、エラーが表示されます。
複数ファイルを選択しての読み込み時、不正ファイルが混ざっている場合は、有効なファイルのみが登録され、不正ファイルはまとめてエラー表示されます。


外部ファイルのインポート

このセクションでは、SoundMaker が行うことのできる、外部ファイルのインポートについて解説を行います。


stxt ファイルのインポート

stxt ファイルとは？

stxt ファイルは、GAMECUBE 向けに提供されていた開発環境である sysdolphin のオーディオライブラリが利用していた効果音定義ファイルです。
この機能は sysdolphin で作られたゲームプロジェクトを CTR に移植する際に利用します。

stxt ファイルのインポートの方法

サウンドセットタブにウェーブサウンドセットが開かれ、フォーカスがある時にのみ実行が可能です。
[ファイル]→[インポート]→[Stxt...] を実行して、インポートしたい stxt ファイルを指定してください。

stxt ファイルのインポートの動作

指定された stxt ファイルのファイル名を使って、ウェーブサウンドセットを作成します。
stxt ファイルの中に定義された効果音名は、その効果音名をウェーブサウンド名としてウェーブサウンドに変換します。

ウェーブサウンドには stxt ファイルに記述された再生情報から、以下の情報をインポートします。

  • 参照波形ファイル名とパス
  • ボリューム (AVOL コマンド)
  • プライオリティ (APRI コマンド)

    • 　stxt ファイルに記載されたプライオリティは、チャンネルプライオリティに変換されます。
  • ピッチ (ATUNE コマンド)
  • パン (APAN コマンド)
  • サラウンドパン (ASPAN コマンド)
  • エフェクトミックス (AMIXA, AMIXB コマンド)
  • コメント (// で始まる記述)

    • 　stxt ファイルにおいて、効果音の記述を行なった {} 内の、一番最初のコメントのみをインポートします。

    stxt ファイルにおいて設定されていた各パラメータの値は、SoundMaker の値に自動的にスケーリングされます。ただしプライオリティの値のみは、スケーリングを行なわず、stxt ファイルの値がそのまま使用されます。

    本リリースの時点では、stxt ファイルのインポートは、stxt ファイル内で効果音の先頭に指定されたパラメータのみに対応しています。


別プロジェクトのインポート

NW4C SoundMaker プロジェクト以外の別プラットフォームのプロジェクトファイルをインポートすることができます。

別プラットフォームプロジェクトのインポートの方法

[ファイル]→[インポート]→[別プラットフォームのプロジェクト] からファイル選択ダイアログを開き、「ファイルの種類」で "別プラットフォームプロジェクト (*.rspj;*.sprj;*.sarc)" を選択することにより、NW4C 以外のサウンドプロジェクトを読み込ませることができます。

NintendoWare for Revolution SoundMaker からのインポート

対象ファイルは、プロジェクトファイル(rspj)、サウンドセットファイル(rsst)、バンクファイル(rbnk)、テキストシーケンスサウンドファイル(rseq)です。

インポート前のファイルはそのまま保持され、インポート後のファイルは同じフォルダに拡張子を変更して保存されます。

テキストシーケンスサウンドファイルインポートの具体的な処理内容は以下の通りです。

  • ファイル内に含まれる文字列 "rseq", "rinl" を "cseq", "cinl" に一括置換します。
  • "rseq"ファイルについては、再帰的にインポート処理を行います。

NITRO-SoundMaker からのインポート

インポートするには、NITRO-SoundMaker でコンバート後のデータが必要です。

mus ファイル内の @SEQ_TABLE で参照されているバンク ID やプレイヤー ID は、NITRO でのコンバート後に作成されるラベルファイル (spdl) を参照しており、インポート時にこの情報が必要なので、インポート前に、一度 NITRO-SoundMaker でコンバートしておく必要があります。

また、インポートには NITRO-SoundMaker のコードを一部流用しているため、NITRO-SoundMaker で読み込めないプロジェクトは、NW4C SoundMaker でもインポートできません。

インポート前後のファイルの関係は以下のようになります。

NITRO | NW4C
sprj | cspj
sarc | csst
bnk | cbnk
mus | csst のシーケンスサウンドセットに @SEQ_TABLE 部分がコンバートされる
 | cseq に @SEQ_DATA 部分が組み込まれる
smft | cseq

これらの拡張子は、一般的なものの例です。その他の拡張子がインポート対象外となるわけではありません。

波形アーカイブ

NITRO-SoundMaker ではバンクに複数の波形アーカイブを設定できましたが、このうち 1 つめの波形アーカイブがインポートされます。

2～4 つめに設定された波形アーカイブで、どこからも参照されない波形アーカイブは、波形アーカイブリストにインポートされません。

バンク

SWAV 波形、PSG 波形および NOISE 波形は、インポートされません。
バンクのインストルメントとして、自分で aiff / wav 形式の波形ファイルを用意する必要があります。
当該インストルメントのコメント欄には、"[ERR] NOISE not supported."のような注意書きが追加されます。

NITRO-Composer ではインストの音量は設定できませんでしたが、既定値として 127 に設定されます。

インポートで追加・削除される項目については、サウンドシステムマニュアルの "移行ガイド" の章も参考にしてください。


波形ファイル出力機能

プロジェクト内にある各種サウンドを、波形ファイルとして出力することができます。

出力可能なサウンドは、以下の種類です。

  • ストリームサウンド
  • ウェーブサウンド
  • シーケンスサウンド

波形ファイルの出力

サウンドセットタブの各種リストから任意のサウンドを選択 して、[プレビュー]→[波形ファイルの出力] を実行します。
「波形ファイルの出力」ダイアログが表示されるので、出力先のファイル名や最大出力時間などを指定して、「OK」ボタンをクリックすることで波形ファイルが出力されます。

リスト上でのコンテキストメニューの [波形ファイルの出力] からも同様の操作が行えます。

出力するファイルは、複数選択が可能です。

波形ファイルは、16bit / 32KHz、ステレオの wav ファイルとして出力されます。

注意点

「ハードディスク録音機能」と比べ、高速に波形ファイルを出力することができますが、エフェクトは反映されません。


コンバート前後の自動処理

コンバート前後に起動するバッチファイルの設定

コンバートの前と後に、指定したバッチファイル（拡張子 .bat）を起動させる事ができます。

コンバートで出来上がったバイナリファイルを、常に別の場所にコピーしたい場合や、名前の変更を行いたい場合などに利用する事ができます。

このセクションでは、コンバート前後にバッチファイルを起動する手順を解説します。

起動するバッチファイルの設定

起動するバッチファイルの設定は、プロジェクト設定ダイアログで行います。

[プロジェクト]→[プロジェクトの設定...] でプロジェクト設定ダイアログを開きます。

プロジェクト設定ダイアログでコンバートイベントのタブを有効にし、ここで「コンバート前コマンド」と「コンバート後コマンド」に、各々コンバート前と後に実行したいバッチファイルを記入してください。

パスは、絶対パス・相対パスのどちらでも構いません。相対パスで指定した場合は、プロジェクトファイルのあるディレクトリからの相対パスとして解釈されます。

それぞれのチェックボックスを OFF にすることにより、一時的にコマンドを無効化することができます。

次回のコンバートから、チェックボックスが ON のコマンドについて、指定したバッチファイルが実行されます。

※ コンバート前コマンド・コンバート後コマンドでは、実行時に入力を求めるような対話的な入力には対応していませんので、ご注意ください。


検索機能

検索ウインドウを使い、文字列や特殊な条件からサウンドプロジェクト内のアイテムを検索することや、リスト上から参照の検索をすることができます。

検索ウインドウの開き方

[編集]→[検索] で検索ウインドウを開きます。
この操作は Ctrl + F のショートカットキーでも行うことができます。

検索ウインドウの使い方

検索範囲

検索する範囲をプルダウンリストから選択します。

プロジェクト全体

プロジェクト全体を対象とします。

現在のサウンドセット または 現在のバンク

サウンドセットタブがアクティブの場合、「現在のサウンドセット」が選択可能になり、バンクタブがアクティブの場合、「現在のバンク」が選択可能になります。
アクティブタブが無い場合は、項目が現れません。

現在のリスト

アクティブタブにて表示中のリストを対象とします。
アクティブタブが無い場合は、項目が現れません。

検索対象

検索対象として「検索する文字列」に指定した文字列を、名前に含むアイテムか、コメントに含むアイテムかをチェックボックスにより指定します。

オプション

「検索文字列にワイルドカードを使用する」にチェックを入れることにより、ワイルドカード "*" の使用が可能となります。

  ・チェックなしの場合

    "*" は文字列として扱われて、部分一致検索となります。

  ・チェックありの場合

    "*" はワイルドカードとして扱われて、完全一致検索となります。

検索ボタン

次を検索（前を検索）

アクティブタブの選択位置から、条件に一致する次の(前の)アイテムを検索し、サウンドセットタブまたはバンクタブで、アイテムの場所を選択表示します。
このボタンを押しても検索ウインドウは閉じません。

すべて検索

検索結果を「検索結果ウインドウ」に一覧表示します。
このボタンを押すと検索ウインドウを閉じます。

検索結果ウインドウ

検索ウインドウで「すべて検索」を実行すると、検索条件に一致したアイテムリストを検索結果ウインドウに一覧表示します。

メニューの[表示]→[検索結果] またはツールバーの「検索結果の表示」ボタンから検索結果ウインドウを開きます。
この操作は Ctrl + Shift + 0 のショートカットキーでも行うことができます。

検索結果として表示されたリストのインデックスセルをダブルクリックすると、サウンドセットタブまたはバンクタブでアイテムの場所を選択表示することができます。

検索結果ウインドウの上部にある各種類のボタンにより、検索結果に種類別のフィルタをかけることができます。
「すべて表示」をクリックすることにより、一括でチェックがついた状態になります。

検索結果ウインドウは、メインウインドウ下部のペインにドッキングウインドウとして現れます。

ウインドウ下部にある"検索結果"タブ部分またはタイトルバーのコンテキストメニューから、検索結果ウインドウを [フローティング]、[ドッキング]、[非表示] に変えることができます。
タイトルバー部分のダブルクリックでも [フローティング]、[ドッキング] の切り替えが行えます。

また、ドッキングウインドウ時は、タイトルバー右側の最小化アイコンをクリックするか、スプリッタ(境界線)をダブルクリックすることにより、タブのみの最小化表示になります。

参照検索

プレイヤー(バンク)を使っているアイテムを検索するには、プレイヤーリスト(バンクリスト)のコンテキストメニューから「すべての参照を検索」を選択して実行します。

対象アイテムを参照しているアイテムをプロジェクト全体から検索し、検索結果ウインドウに一覧表示します。

参照されないアイテムについては、コンバート時に「コンバートログウインドウ」において警告表示され検出できます。


コンバートログ

[表示]→[コンバートログ] で、コンバートログウインドウを開く（アクティブにする）ことができます。
この操作は Ctrl + Shift + 9 のショートカットキーでも行うことができます。

コンバートログウインドウでは、コンバート時のログを表示します。
コンバートに失敗した時だけでなく、成功した後もログが残っているので、コンバート処理による登録アイテムの更新状況の確認などができます。

コンバートログウインドウは、メインウインドウ下部のペインにドッキングウインドウとして現れます。
ウインドウ下部にある"コンバートログ"タブ部分またはタイトルバーのコンテキストメニューから、コンバートログウインドウを [フローティング]、[ドッキング]、[非表示] に変えることができます。
タイトルバー部分のダブルクリックでも [フローティング]、[ドッキング] の切り替えが行えます。

また、ドッキングウインドウ時は、タイトルバー右側の最小化アイコンをクリックするか、スプリッタ(境界線)をダブルクリックすることにより、タブのみの最小化表示になります。

コンバート中にエラーが発生した場合は、コンバートログウインドウの中のエラー項目を選択して、「対象アイテムへ移動」ボタンを押下することにより、サウンドセットタブで警告/エラー箇所を選択表示できます。
また、エラー項目をダブルクリックするか、エラー項目上で右クリックのコンテキストメニューから「対象アイテムへ移動」を選択することにより、同様の動作が行えます。

警告表示されるのは、以下のケースです。

  • グループに登録されていないアイテムがある（対象はサウンド、バンク、サブグループ）
  • 未使用のアイテムがある（対象はプレイヤー、グループ、バンク）

警告機能は「プロジェクト設定ダイアログ」において、有効・無効の設定が行えます。

正常動作、エラー発生に関わらず、コンバートログ上で選択した項目は、右クリックのコンテキストメニューからログの「コピー」を行うことができます。


プロジェクトの修復機能

[プロジェクト]→[プロジェクトの修復] で、プロジェクトの参照ファイルパスが変更された場合などに、これらの有無をチェックして、プロジェクトファイルを自動的に修復します。

修復のための設定項目は無いので、ダイアログ上で『はい』をクリックするだけで実行されます。

参照ファイルが見つからない場合の対処としては、新たなファイルパスを指定したり、指定したパス以下から、対象ファイルを検索する方法を選択する事ができます。


付録

このセクションでは、SoundMaker使用時における付加情報や、作業においてのテクニック等について解説します。


プレイヤーヒープについて

このセクションでは、プレイヤーヒープの動作と使い方について解説を行います。

プレイヤーヒープとは？

NW4Cサウンド開発環境では、snd ライブラリが行うメモリ管理の方法として、通常サウンドヒープを使います。 サウンドヒープを使う場合、あらかじめシーン毎に必要なサウンドデータをグループという単位でまとめておく必要があります。 例えば、あるシーンで再生される可能性があるBGM用シーケンスデータが数十曲あった場合、 グループに全てのシーケンスデータを含めておく必要があり、大量のメモリを必要とします。 プレイヤーヒープを使えば、この様な場合に、メモリ消費量を必要最低限に押さえることができます。

サウンドヒープが、サウンドデータを手動でロードするのに対して、 プレイヤーヒープでは、サウンドの再生開始時に自動的にロードを行い、再生が終了した時点で自動的に解放します。 解放されたヒープは、次に再生するサウンド用のデータをロードするために使われます。

以下に、サウンドヒープを使った場合と、プレイヤーヒープを使った場合との違いについて、例を示します。

この様に、あるシーンで再生される可能性があるBGM用シーケンスデータの内、 データサイズが最も大きなシーケンスデータをロードできるサイズのプレイヤーヒープがあれば、 それら全てのシーケンスを再生することが可能になります。

プレイヤーヒープの使い方

プレイヤーヒープの設定は、プレイヤーに対して行います。プレイヤーリストのプレイヤーヒープの項目で、プレイヤーヒープのサイズを指定してください。

シーケンスサウンドを、プレイヤーヒープが設定されたプレイヤーで再生しようとすると、 シーケンスデータが、自動的にプレイヤーヒープにロードされます。 従って、シーケンスデータをグループに含めて、あらかじめサウンドヒープにロードしておく必要は無くなります。

なお、プレイヤーヒープが設定されていても、シーケンスデータが既にサウンドヒープにロードされている場合は、 サウンドヒープ上のデータが使用され、プレイヤーヒープへのロードは行われません。

プレイヤーヒープの注意点

ロードできるデータの種類

プレイヤーヒープには、シーケンスデータのみロードさせることができます。 バンクデータやウェーブサウンドデータなどをロードすることはできません。

消費メモリサイズ

プレイヤーヒープ用のメモリ領域は、サウンドリミットの個数分確保されます。 例えば、サウンドリミットが３だった場合、プレイヤーヒープで指定したサイズの３倍、メモリを消費します。 また、プレイヤーヒープ用のメモリ領域は、初期化時に、常駐領域として確保されます。

再生開始遅延

プレイヤーヒープを使うと、再生開始時にデータをロードします。 実際に音が鳴り始めるのは、ロードが完了した後ですので、音の鳴り始めに遅延が発生します。

再生開始時に即座に音を鳴らしたい場合は、プログラム側で、再生準備処理（Prepare処理）を行うことで、 前もってプレイヤーヒープにデータをロードしておくことができます。


大きなプロジェクトの作業方法

このセクションでは、大きなプロジェクトでの作業について、Tipsやヒントを説明します。

コンバート時間の短縮

大量の波形ファイルを扱う、大きなプロジェクトでは、特にコンバート時間の長さが、通常作業の障害になります。

この対策方法として例を挙げると、現在以下の2種類が有効であると考えられます。

1. SoundPlayerでは無く Viewerを使う

※現バージョンでは Viewer に非対応です。

コンバート毎にプログラムの転送を行うSoundPlayerに比べ、Viewerは最初の起動こそやや時間がかかるものの、起動後はサウンドデータの転送のみでサウンドを確認できるので、快適な作業が可能となります。

2. 頻繁に編集するサウンドセットのみで作業用のサウンドプロジェクトを作成

最終的にアプリケーションで使用するサウンドアーカイブを作成するのですが、全てのサウンドを含んだサウンドプロジェクトで作業するのではなく、これとは別に、頻繁に変更を行うサウンドセットだけを登録した、作業用のサウンドプロジェクトをいくつか作成して、通常の作業はこちらで行うようにすると負荷が軽くなります。


トラブルシューティング

このセクションでは、SoundMaker を操作する際に起こりやすい問題や、陥りやすい問題などについて、その解決方法を示します。

SoundMaker が起動しなくなった

(プロジェクト名).cspj.settings ファイルを削除して、起動し直してみてください。

サウンドセットおよびバンクタブにあるはずのリスト項目が表示されなくなった

(プロジェクト名).cspj.settings ファイルを削除して、起動し直してみてください。

コンバートに失敗する

再コンバートを試してみてください。
[ツール]→[オプション] の“並列コンバートの最大数”が 2 以上の場合は、1 にしてコンバートし直してみてください。

リスト内の文字が表示されなくなった

サウンドセットタブやバンクタブのリスト内にある、数字が表示される項目において、この項目が右端に位置し、スクロールバーの表示と重なった場合、数字の部分がスクロールバーで上書きされ表示が消えてしまいます。

表示例．

上図の上側の画面状態から、「コメント」項目を非表示設定にすると、下側の画面状態となり「ユーザー設定」の値が見えなくなります。

このような場合、「コメント」など重要度の低い項目を最右端に表示して回避するようにしてください。


商標表記

Microsoft、Windows は米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

その他、記載されている会社名、製品名等は、各社の登録商標または商標です。


ハードディスク録音機能

※現バージョンではハードディスク録音機能は使用できません。


DLS ファイルのインポート

※現バージョンでは DLS ファイルのインポートはできません。


プレビュープレイヤーパラメータ

※プレビュープレイヤーパラメータは Viewer 専用のパネルなので、現バージョンでは表示できません。


エフェクト

※現バージョンではプリセットファイルが未対応なため、エフェクトウインドウは表示できません。


注意事項

このセクションでは、SoundPlayer を使う際の注意事項を解説します。
SoundPlayer の起動が正常に動作しない場合には、このセクションの確認項目をお試しください。

NDEV で SoundPlayer が正常に起動しない場合

NDEV ソフトウェアの DvdRoot に何か値が設定されていますか？

NDEV を使用してプログラムを起動する際には、SetNdEnv コマンドで DvdRoot に何かしらの値が設定されている必要があります。
設定していない場合は、コマンドラインから次のようにして値を設定してください。

SetNdEnv DvdRoot ""

Viewerに接続中ではありませんか？

ショートカットキーによる誤操作を回避するため、Viewer に接続中は、SoundPlayer の起動はできません。


画面表示

SoundPlayer は、TV 画面にサウンドの各種情報を表示します。
画面は簡素なウインドウシステムを採用し、カーソルのあるウインドウがアクティブなウインドウとなります。

このセクションでは、画面に表示される各ウインドウの役割と表示の意味を解説します。

SoundArchivePlayer ウインドウ

サウンドの再生や停止などを行う、メインのウインドウです。

SoundArchivePlayer ウインドウ内には、さらに上下に分割された 2 種類の領域が存在します。
上領域をプレイペイン、下領域をパラメータペインと呼びます。

プレイペインの各行には、以下の情報が順に表示されます。
サウンドの種類　…　WSD, STM, SEQ が、各々「ウェーブサウンド」「ストリームサウンド」「シーケンスサウンド」に対応します。
サウンドの番号　…　選択しているサウンドの番号です。
サウンドの名前　…　選択しているサウンドの名前です。

パラメータペインには、一番上の行にパラメータの種類、以下に続く行に各パラメータの値が表示されます。
パラメータの種類は、次の５つに分けられています。
  1. BASIC PARAMS
  2. PLAY OPTION
  3. OUT SWITCH
  4. OUT VOLUME
  5. SEND PARAMS

SoundSystem ウインドウ

現在の再生モードや DSP の処理負荷、Wii リモコンスピーカとの通信状態など、シンセサイザと AX の状態を示します。サウンドの DSP 負荷などの確認と、再生モードの切り替えに使います。

Output Mode: は現在のサウンド再生モードを示しています。
  MONORAL　…　モノラルの再生モードです。
  STEREO　…　ステレオの再生モードです。この再生モードが初期状態となります。
  SURROUND　…　ドルビーサラウンド（マトリックス）の再生モードです。
  DPL2　…　プロロジックII（ドルビーサラウンドプロロジックII）の再生モードです。

Compressor: は現在のコンプレッサの状態を示しています。

Remote Volume: はWiiリモコンのボリュームを示しています。
Wii本体設定メニューから行うWiiリモコンのハードウェアボリュームの変更ができます。
変更したハードウェアボリュームは、本体内蔵フラッシュメモリに書き込む事もできます。

REMOTE はアイコンで Wii リモコンとの通信状態を示しています。
表示は、左から順にリモコン番号の 0 から 3 に対応します。
－　…　リモコンスピーカが使用できない状態
■　…　リモコンスピーカは使用できるが、データを送信していない状態
再生マーク　…　データを送信している状態

THREAD は現在のサウンドスレッドの処理負荷を示しています。

DSP は現在の DSP 処理負荷を示しています。

AXVoiceViewer ウインドウ

AX で実際に発音しているボイスとそのレベルをリアルタイムに示します。シーケンスサウンドがどのくらいのボイス数を消費しているか？などを調べるのに使います。

ウインドウ最下部に ?? / ?? で示す数字の、/ の左が現在アクティブな物理ボイスの数を示しています。/ の右側は最大値が更新された時に、その値を数秒間保持して表示します。

MasterOutViewer ウインドウ

マスターアウトの状態を、ウェーブフォーム形式でリアルタイムに示します。
クリップノイズなどの原因特定に使います。

最近再生した8192サンプル（0.256秒）分のウェーブフォームを表示します。
拡大や、スクロールはこの範囲内で行います。
左右方向の拡大縮小度合いは、ウインドウ下部にスクロールバーで表示されます。

SoundHeap ウインドウ

サウンドヒープの状態を表示します。
このウインドウではサウンドヒープへのデータのロードや破棄を試す事ができます。

Effect ウインドウ

補助バスに適用するエフェクトの種類と、各エフェクトのパラメータを変更する事ができます。

1つのバスに最大3つのエフェクトを登録し、直列にかけることができます。

SoundInfoViewer ウインドウ

サウンドの状態を示します。ページの切り替えによりサウンドの種類が変更できます。

・シーケンスサウンド1ページ目

テンポを倍率で調整できます。

・シーケンスサウンド2ページ目

シーケンスサウンドでは、16チャンネルの各パラメータをリアルタイムで表示します。
count の列は、チャンネルで発音されているボイス数を示しています。

・ストリームサウンド1ページ目

（操作できる項目はありません）

・ストリームサウンド2ページ目

・ウェーブサウンド

（操作できる項目はありません）

Player ウインドウ

プレイヤーの状態・パラメータを表示し、パラメータを変更する事ができます。

playing count には現在の再生サウンド数と、監視を始めてから最も多い同時再生サウンド数を表示します。
sound limit で監視するプレイヤーのサウンドリミットを表示します。

PlaySoundList ウインドウ

再生中のサウンドの一覧を表示します。全サウンド・サウンド種類別・プレイヤー別で切り替えて表示することができます。
プレイヤー別の表示の際はプライオリティ順に表示され、それ以外はプレイヤー順に表示されます。

MIDI ウインドウ

選択したバンクを使ってMIDIアダプタによる入力信号を再生します。
"MIDI In"の行は入力インジケーターで、左からコントローラの１，２，３，４の入力になります。

MIDI アダプタについての詳しい解説は、「MIDI アダプタの使い方」をご覧ください。

SeqVariable ウインドウ

シーケンス変数の状態確認、操作を行うウインドウです。

以下の機能があります。
・現在のシーケンス変数の状態を表示
・シーケンス変数に任意の値を書き込む
・SoundArchivePlayerウインドウで選択中のサウンドの再生および停止

1行目はタイトル行で、プレイヤー変数・グローバル変数・トラック変数ごとに分かれています。
最初の「 0( 0)」はシーケンス変数番号です。カッコ内は、通しの変数番号で グローバル変数は16から、トラック変数は32から始まる数字になります。
2列目の数字はエディット値です。数値を変更しただけでは実際の変数には反映されず、書き込み操作を行う必要があります。
3列目の数値は、現在のシーケンス変数の値です。

マークされている変数は、シーケンスサウンドの再生開始時に自動的にエディット値が変数に書き込まれます。

LogViewer ウインドウ

OSReportされる警告メッセージなどを確認する事ができます。

PCにシリアル出力される文字列と同じものが、TV画面上で確認できるようになります。


メニュー画面

メニュー画面の表示

ゲームキューブコントローラのSTARTボタン、またはWiiリモコンのＨＯＭＥボタンを押すことで、メニュー画面を表示する事ができます。
表示されたメニュー画面は、ゲームキューブコントローラのSTARTボタンかBボタン、またはWiiリモコンのＨＯＭＥボタンか－ボタンで閉じる事ができます。

メニュー画面の機能

メニュー画面では、SoundPlayer がTV画面に表示している現在のウインドウレイアウトを、SoundPlayer 起動時の初期設定としてファイルに保存する事ができます。

ウインドウレイアウトの初期設定の保存

Save Startup Layout

    現在のウインドウレイアウトを、ウインドウレイアウトの初期設定ファイル（拡張子 .brdwl）に保存します。
    保存される初期設定ファイルのファイル名は、%NW4C_ROOT%/SoundMaker/SoundPlayer/SoundPlayer.brdwl です。

    保存したウインドウレイアウトの初期設定ファイル（SoundPlayer.brdwl）は、SoundPlayer の起動時に SoundMaker のオプションで指定されている dvdroot 直下にコピーされます。SoundPlayer は、このコピーしたウインドウレイアウトの初期設定ファイルを読み込み、保存したウインドウレイアウトを復元します。

    ウインドウレイアウトを保存する際には、MCSサーバを起動する必要があります。
    保存されたレイアウトを復元するだけなら、MCSサーバを起動する必要はありません。


SoundPlayer の停止

コンバートの出力先に dvdroot を設定している状況で、SoundPlayer の起動中にコンバートのみを行いたい場合や、作業中に別のプログラムを NDEV で起動する場合などには、SoundPlayer を停止する必要があります。

SoundPlayer の停止方法

[プレビュー]→[SoundPlayer の停止] を実行します。


Viewer との接続

Viewer との接続方法

Viewer と MCS Server が正常に起動中である事を確認してから、[プレビュー]→[Viewerに接続] を実行します。

この操作により、SoundMaker は Viewer との USB 通信を開始し、Viewer と接続中になります。


Viewer と接続中の動作

このセクションでは、SoundMaker が Viewer と接続中に行なう動作を解説します。

サウンドアーカイブの転送

Viewer と接続中は、以下の操作が実行された時に、自動的に SoundMaker から Viewer にサウンドアーカイブが転送されます。

  • [プロジェクト]→[コンバート]
  • [プロジェクト]→[再コンバート]

GUI からの Viewer 操作

Viewer と接続中は、コントローラによる操作とは別に、SoundMaker の GUI からも Viewer の一部の操作を行なう事ができます。

サウンドの再生は、ツールバーにある [再生], [一時停止], [停止] ボタンによる操作と、PCキーボードのキー操作により行えます。
以下に SoundMaker が行なう事ができる Viewer のキー操作一覧を示します。

キー入力 | 操作
F9 | 選択中のサウンドを再生（リストでサウンドを選択中のみ有効）
F10 | サウンドの停止（リストでサウンドを選択中のみ有効）
Shift + スペース | 押下中サウンドを再生（サンプルマップでリージョンを選択中のみ有効）

※[F9], [F10] は、サウンドセットタブ、バンクタブの両方で有効ですが、[Shift + スペース] は、バンクタブでのみ有効です。


Viewer

このセクションでは、Viewer を使った実機での音の確認方法を解説します。


Viewer の起動と操作

Viewer の起動

Viewer と MCS Server の起動は、SoundMaker とは別に行なう必要があります。

Viewer の起動方法

Viewer の起動方法については Viewer のドキュメントを参照してください。

Viewer の操作方法

Viewer の操作方法については Viewer のドキュメントを参照してください。